Acard 1:1 copy box problem

Hello,
My apologies if this is in the wrong section.
I’ve got an Acard 1:1 Duplicator, AEC 7763LD. I have ran it for a long time
with a Pioneer 105, and Asus Rom. Finally the 105 has died on me so i took my
Pioneer 109 out of my pc and put it in the box. Usually during a burn the rom
and writer (105) light stay on constantly but when i put the 109 in the lights are flashing and the burns take longer. So far i have tried the following;
Updated firmware in The DVR 109.
Updated firmware in The Acard Controller.
The Asus rom already has the latest F/Ware.
None of the above have helped.
I’ve just been and bought a pioneer 111D. I get the same symptoms, although
The lights dont flash no where near as much, but they still do !
The Asus dvd rom is not that old and has not been worked too much,
Could it be this rom thats the problem ?
I dont know what else to try, if anyone could suggest anything
i’d be most gratefull.

Thank you.

An 109 and 111 needs UDMA4, an 105 only UDMA2.

Upto now i’ve replaced the writer and the rom but i still have the problem. Has anyone ever experienced an Acard Controller goin bad ?

Any info would be great.

Thank you.

Honestly, they all suck without an appropriate and actual firmware…

Chef,
i’ve got the latest firmware in the writer, the rom, and the latest firmware for the controller. All taken from the retailers websites. What more can i do ?

Hm, I’d ask Acard support then.

All posts I’ve read so far where the poster had trouble with Acard controllers could be solved by installing a new card firmware…

Yeah thats what i’ve done Chef, hopefully i might get a reply off Acard.

Thank you.