About Plextor's TLA#s....!

vbimport

#1

I’ve recently bought a 1210A model with a TLC# 0308…
Will it work if I downgrade my firmware? To be exact will it daowngrade at all? by the way, I heard somebody got SD2 copied perfectly by changing the jumpers… Has anybody tried this too?


#2

To my knowledge (and correct me if I’m wrong) all PlexWriters can downgrade their firmware. I today upgraded my firmware to 1.08 and it works very easy. You download the firmware, a tool to apply it and click on upgrade. That’s it.

PlexWriters (the 1210A version) can copy SD2 when firmware 1.04 is used. Plextor deleted these firmware (or adapted them) versions from their sites. It’s best to get the firmware from a different site then Plextor. For instance http://www.cdrinfo.com (use the search function to find it there).


#3

G@M3FR3@k, i think you’re wrong, only Plex-writers with a TLA# lower than 0202 can downgrade to firmware 1.04 or lower, I have the 121032TA TLA#0305 and tried to downgrade it to 1.04 and all the time i get an error message, also tried it under the good old DOS, but with the same results, looks like Plextor has made a deal with the makers of safedisk2, all new drivers (after TLA#0202) are protected against downgrading, and the old firmwares have been replaced by ‘new’-old ones…unable to copy safedisk2 cd’s with those ‘new’-old ones…


#4

btw, changing jumpers around does not let you copy games better. the jumpers are just used to identify the device in the system bus, and have no bearing on anything else.


#5

Originally posted by Squage
btw, changing jumpers around does not let you copy games better. the jumpers are just used to identify the device in the system bus, and have no bearing on anything else.

Sorry, but you misunderstood my question. I saw somebody saying he downgraded his plexwriter by setting the jumpers…So what I was saying is that maybe it’s possible to downgrade your plextor cdrec. by setting the jumpers right. Even Plextors should have times when they have to unguard(?) the drives don’t they? they might have these factory settings to give AS(after services)… just a theory of mine…

And another one…what does BTW stand for…?
this ain’t no joke…I really don’t know…
I’m new to foreign(to my Home) web sites…


#6

btw = by the way
lol = laugh out loud
rofl = rolling on the floor laughing
lmao = laughing my ass off
brb = be right back
afk = away from keyboard

and the list goes on and on…


#7

thnx^^(I figured this out my self!! Cool huh?)

Got a personal BIG news for you all!!

I finally got the 1210A TLA#0202 on my hands…
I had to use extra $'s and time to lay my hands on this one…It was hard to find 0202, when everybody’s selling 0308 models…yup…darkness of my past is going down the sewers now… so long, farewell, sayonara~

but come to think of it…is it worth it?..hmmm…


#8

I’ve got a Plex1210A TLA#0307 and I CAN downgrade it so I don’t know what your talking about! :stuck_out_tongue:
Haven’t tried burnin’ some SD2 games yet cause I already had the games (patched) that R protected that way before people even knew it was SD2 that protected it! (And before I had the Plex!)
Can anybody tell again which games R SD2 protected?!

:smiley: L8rz…!! :smiley:


#9

Have you tried to downgrade your firmware to ver1.04?
It’s almost a fact that TLA#s with 03xx are impossible to downgrade under 1.05(that means you can’t downgrade your firmware to ver1.00~1.04). And this is where the conspiracy theory came from in the first place.
plz CHECK AGAIN!


#10

can you tell me where to get the firmware 1.04 for my plextor W124TS ? The file at cdrinfo is the wrong, 440K file from plextor. I’ve heard that the right firmware is 530K big


#11

Originally posted by Sensimmy
can you tell me where to get the firmware 1.04 for my plextor W124TS ? The file at cdrinfo is the wrong, 440K file from plextor. I’ve heard that the right firmware is 530K big

grt the your firmware at http://cd-rw.org


#12

The file size for the firmware is different because the US version has a different program to apply the .bin file to the version released in Europe. The .bin file(firmware file) is the same for both.This is for the 1.08 update W1210A108.exe 545,236 bytes is the Europe file and 1210au108.exe 456,597 bytes is the US version.
Hope this helps


#13

I know that the first two numbers in the TLA# shows the version of the hardware…and the latter two firmware versions…
What I dont get is what’s the difference…
Some people say it’s not the TLA# that matters and some say they do matter. Is there any place where I can find what the TLA# really means? kind of gets me down when I think of what I’ve done to get a 0202 marked product…if it’s not worth it, of course…
PLEASE, anybody who has answers!!! HELP~


#14

I found this in a list of SD2 compatable burners
PLEXTOR: PX-R820 (SCSI), PX-W8220 (SCSI) only if TLA=01xx
No Plex 12/10/32 listed at all.All reports I have read say that you can only use the copy in the 12/10/32 burner you made it in and most people are saying that it dosn’t help to downgrade firmware.The most common workaround is to get a Philips type burner for SD2. I have a Acer 6/4/32 that works also.


#15

Yeah I read the report, too. Like you said you can’t find 1210A on the report. So, does that mean the whole story was made up? The coder of DiskDump(I forgot his name…) must be a con-artist or something. I’m not saying you’re wrong. I’m just confused. Anyway, I thank for you’re reply.

But, my question was What are the changes made as TLA# get higher.


#16

As far as I know the TLA# is the production run batch code.The changes may not be very big or may have no change at all.My personal opinion is that too much is placed on the TLA# of a Plextor.It seems the more I read about SD2 the more it become clear that there is a lot of misinformation around and the fact that SD2 has more than one version isn’t helping.The fact that programmers can also program the type of SD2 with different options is lost on some people and from what I have read that some burners can copy some SD2 games and fail on others seems to confirm this.This is just my take on it all from reading forum posts and reports on a lot of web sites.Please feel free to correct me if I’m wrong in any area.

The jumpers you mention are the factory reserved ones and reports have said that jumping them will put thr drive in to UDMA33 mode.

This is what http://www.justcdr.cjb.net/ reports.

"If you facing problems when try to read SubChannel Data with your Plextor based recorder there might be a solution for you. All the above drives have 2 jumpers next to the digital audio out. If you jumper them then you drive would recognized as UDMA33 and probably it will start reading SubChannel data. We tried it in our TDK CyClone 121032, which refused previously to read SubChannel data, and worked fine with latest CloneCD (2.8.4.2).

This is the official Plextor answer about jumper the drive:
“…The “Reserved jumper” (2 horizontal pins next to the digital audio out) is used for testing during production. If these jumper pins are shortened, some PC motherboard will work at Ultra DMA-33. But we do not guarantee the working…”

All I can say is get on the net and read up on it all and do a bit of your own homework.The info is out there you just have to look :slight_smile:
Good luck