A108XLA problem reading disks?

vbimport

#1

Hi,

I just got my new A108XLA, and I seem to be having a couple of problems. I upgraded to FW v1.18 before using it.

First, it won’t run the software CD that came with the drive…I get an “autorun.exe has generated errors and will be closed by windows” (I’m running Win2k with all the latest updates).

Second, I burned a game ISO to a Verbatim 16x DVD+R at 12x using Alcohol 120% v1.9.2 1705, and when I try to run it in the drive I get a setup.exe - application error msg. “The application failed to initialize properly…blah blah…”

The drive is set as master, and is properly recognized by both the board BIOS (Soyo P4 Dragon Ultra), and in win2k device manager, and everything also appears correct in the SiS IDE UDMA controller properties. I can’t see anything that’s obviously wrong as far as settings go. Suggestions? Please? :confused:


#2

I wouldn’t think that these problems are caused by the drive. Something may be wrong with your OS.


#3

Plz redo in nero, if its a hmm hmm “warez copy” nero as of legal reasond wont copy, but if its to vack up ur own legit sofware in case u damage original, you need nothing more than nero and daemontools, if its movie slysofts anydvd will let nero on fly it.


#4

Except this doesn’t explain why it won’t read other disks. I have a DVD movie that it won’t read, as well as the software disk that came with the drive. After reading through the threads a bit, I’m thinking it may be the cable.


#5

Quickly installing the drive in another PC (friend’s, ect.) is a good way to test the hardware end of it if after the cable swap you still experience issues.


#6

Sorry about the typos BTW, i never seen you saying it not play a dvd movie bought not copy :slight_smile:


#7

OK here’s what I’ve determined:

After numerous uninstallations/reinstallations of several IDE drivers (my board uses SiS 645, using SIS PCI IDE controller, tried newer one and also the standard MS IDE controller), I’ve discovered that the drive will initialize ONLY when it’s set in PIO mode (it’s the primary master on the primary channel). Changing it to “DMA if available” in device manager sets DMA mode properly, but after rebooting the drive doesn’t read anything and I get the errors I described in my initial post. I change it back to PIO mode, reboot, then it reads fine. WTF?

Might this indicate a problem with the cable compatibility? As far as I know it’s an 80 conductor cable, but not certain.

Any help/suggestions?


#8

Even a 40 core would give you ata 33 (udma mode 2) much higher than pio mode, not sure, i would deff check ribbon.


#9

Yes I will, thanks. However, I was able to burn an ISO to disk (Verbatim 16x, burned at 12x…seemed to come out ok since the drive was able to read it in PIO mode, but I burned it in DMA mode), but that was before I discovered the disk reading problem. It burned at 12x in a little over 5 mins. It was when I loaded the burned disk to test it that I discovered the drive wouldn’t read it (with DMA enabled that is). Like I said, it reads it o.k. provided PIO mode is set.

This is getting really annoying. I’ve never had this much trouble installing a piece of hardware before. I’m running Win2k BTW, if I didn’t mention that. My board is a Soyo P4S Dragon Ultra with 1.6 CPU, 768mb memory.


#10

Forget your extra controller and connect the drive to the internal IDE as MASTER as it is recommended.


#11

If by that you mean don’t use the board’s UDMA IDE drivers in the OS, I already tried using win2k’s standard IDE drivers. The drive is connected to the non-RAID internal IDE on the primary as master. There is no “extra” controller per se, unless you count the onboard Highpoint RAID controller, and none of my CD drives are connected to those two channels…my HDs are, in a non-RAID configuration.


#12

Looks like it was the cable guys. Switching the drive over to one of my 40/80 cables enabled the drive properly in the correct UDMA mode. Lesson learned here, eliminate cable questions first then spend hours jacking around with suspected driver issues LOL. :o

Thanks very much for all of your suggestions, it’s very much appreciated!


#13

I thought you were talking about an extra controller, heh.
Glad you have solved the problem.