A/V Sync issues

vbimport

#1

I have frequent A/V sync issues with DVDFab. Mainly converting direct from DVD (rather than copying over the VIDEO_TS folder) though also indirect converting to mp4 and when converting from *.ts or *.mpg (MPEG-2) to wmv or to mp4.

I was wondering a few things:

  1. Some have said that using the cpu for other processes can cause this, but I really dont understand if its doing a digital conversion, wouldnt it just do the same thing slower. Its surely not playing the audio and video separately and live then re-encoding? Can any one explain?
  2. Could using 2-Pass improve things for me or is this ONLY to improve video quality?
  3. Is there a more preferable TO format to convert TO? One that is les prone to this kind of thing. Bearing in mind however that I’d like to play on WMP12, but also XBox 360-S via UPnP and there’s only a small number of formats (with very specific parameters) that are supported by XBox 360-s.

#2

[QUOTE=hardya;2561945]I have frequent A/V sync issues with DVDFab. Mainly converting direct from DVD (rather than copying over the VIDEO_TS folder) though also indirect converting to mp4 and when converting from *.ts or *.mpg (MPEG-2) to wmv or to mp4.

I was wondering a few things:

  1. Some have said that using the cpu for other processes can cause this, but I really dont understand if its doing a digital conversion, wouldnt it just do the same thing slower. Its surely not playing the audio and video separately and live then re-encoding? Can any one explain?
  2. Could using 2-Pass improve things for me or is this ONLY to improve video quality?
  3. Is there a more preferable TO format to convert TO? One that is les prone to this kind of thing. Bearing in mind however that I’d like to play on WMP12, but also XBox 360-S via UPnP and there’s only a small number of formats (with very specific parameters) that are supported by XBox 360-s.[/QUOTE]
    Hi hardya

Have you tried changing the Codec settings from one to another in common settings ?

Also it is best to rip the movie title to your hard drive and convert from the HDD rather then doing it from the DVD itself.


#3

I can only change for MPEG2. MPEG2 DXVA is supported, other changse are not supported by the graphics card. For my example of converting FROM MPEG2 (*.ts, *.mpg) TO WMV, I guess it would need to be that the problem was at the reading end rather than the writing end. What do you think?

I presume I can still leave “DirectShow” in use. What about the audio and video Directshow filters?


#4

[QUOTE=hardya;2561981]I can only change for MPEG2. MPEG2 DXVA is supported, other changse are not supported by the graphics card. For my example of converting FROM MPEG2 (*.ts, *.mpg) TO WMV, I guess it would need to be that the problem was at the reading end rather than the writing end. What do you think?

[B]I presume I can still leave “DirectShow” in use. What about the audio and video Directshow filters?[/B] [/QUOTE]

DirectShow and the DirectShow filter is related to the “Preview” window playback not the conversion process, the settings I’m referring to is in common settings-> [B]A/V Codec[/B].

Since doing conversions take a lot of CPU usage/resources you should close all programs that are running in the background and don’t use the system during the conversion process, and on the A/V Codec settings page choose “Software” for all the settings.

I don’t know what brand or model your graphic card is but you may also want to check to make sure the graphic card driver is up to date.


#5

I am a bit confused.

When you said "changing the Codec settings from one to another " I thought you meant the kind of change I refered to in my last post, but you indicate after that that you prefer all set to “Software”, which was already set.

Is it some other codec settings that I ought to change.

After my change to DXVA I found the decode would run to 9% and never get any further. This happens consistently on every attempt. It does use half the cpu however, which I found encouraging. With “Software” setting its up around 95 - 98%