A ring protech ¿2? thread (laserlock star involved?)

vbimport

#1

Well , hi everybody.

First i will try to make that post usefull to people by sharing spanish (mainly) testings.
About the name (ring protech 2(second version or whatever you would like to call it, i did 2)), we are all confused about the real version of the protection. Well, many people call it ring protech in general, i distinguish between first (iron storm and before) and “second” (Haegemonia, Chicago 1930, Roland Garros 2002/3, Robin Hood…).
Differences?, well, first version could be “easyly” “back-uped”, but version 2 not at all.
Checks are obviously differents in both versions, but with the same data. In the next lines hope could explain that.

Secondly, i will consider two parts: CD-R and CD-RW.

CD-R:

Well, many people burns all its copies into common blank CDs, as just every mortal, but there is interesting result with this protection if we changes between CD-R and CD-RW.
For that i used for reading two plex writers: PX-W2410A and PX-W5224 ( not the premium) a toshiba writer SD-R5002 and a toshiba DVD drive ( Sd-m1402).
I have also info from other users with another writers/readers, but i have not the specific model, so will not post because i’m not sure. Results, anyway are important.
Many people ( and i include philamber…if i correctly recall…;)) stated they have not had any problem with this protect, since theirs backups works everytime.
Well, in our testings this is an interesting part.
With the above writers/readers, the most near of a 1:1 true copy of this protect we could get , was made with CloneCD and reading and writing only from the plextors. Reading from other devices result in a non working copy ON CD-R. Reading also with BlindWrite (newest version included), alcohol and fireburner result in a “casual” pseudo 1:1 working copy, so will get away those tools for evident reasons.
Burning with a non plextor drive result ALWAYS in a bad copy.
When stating a near 1:1 copy, i means a copy that worked perfectly on both plextors and most drives like asus, liteon or sony units, but not in my sd-r1402/sd-r5002 and a toshiba unit in general.
This could explain why people reported success, when others can’t ( and they really know what they are doing)
I posted time ago, a peculiar theory about lead-out and this protech, well, i re-considered that and stated the same (Roland Garros 2003) but know i include the fast skip sector way of working. With all that, we conclude, that errors are not correctly get when the fast skip sector “way” is on and now will try to post why.

CD-RW:

Well, with this, that protect changes a lot. In the above testings, we didn’t got a true 1:1 copy anyway, but if we burn into a CD-RW,things changes a lot. Since first experience with safedisc ( copies worked always burning in a CD-RW, but failure on a CD-R) this is almost the same.
We were so frustrated, so tried to burn that on CDs. Result where a 1:1 copy in almost every reader/writer with most nowadays software. Then there were no need to read from the plextor, just every writer can afford that.
This is quite frustrating, and we can inmediatly connect that with those safedisc cases where the copy on CD-RW worked and in a CD-R didn’t.
In both there is read errors (different in the practice but errors anyway) and both have the same behaviour.
I remember that where solved by changing the way of reading and burning safedisc errors, maybe ring protech should need a new way to read/write that. I know this is not a key for todays software, but i think it’s important to get in mind for developers.

And now, i will correlationate that with laserlock star.
Well, i haven’t had the lucky to get a CD protected with this scheme, but i got a CD with “common” laserlock some time before laserlock star were released.
As securom new tecnics tested on spanish games in the 4.74.xx.xxxx version (soccer manager)officially released three months later on the rest of the world, i think laserlock star tested it’s new system on a spanish game: IceWind Dale - Heart of Winter.
I could get true 1:1 copies till that tittle appeared on Spain.
Maybe, “normal” laserlock but the case is that i couldn’t get a full 1:1 copy of this “new” kind of protection.
Then , burned onto a CD-RW and forgot that, till i tried to play with such CD. Result…success…why???, don’t know.
I tried to make another copy into a CD-R, and always, game panic!.
So, both systems are pretty close respecting main idea of errors, and i think both can be solved in the same way.
Obviously there were a problem.
In all my toshiba, the original does not work anyway. Well, can be curious, but this is what i tested.
(In the other way, emulation works like a charm)

And that’s all i think. Remember, these are experiences and not a “tech” post so it’s not necesary to move/post that in other place.

Could be wrong, but i think i stated my point of view with enough especific data.

And sorry again for that bad english post: i try my best.

Good luck!