8x drive, coasters @ 4x - what is this I/O Magic drive?

(Creating thread titles is a fun business!)

I’ve got several questions and frustrations. When I first got this I/OMagic 8x “Dual Format” drive, it was my first DVD burner, and it was the cheapest thing I could afford at CompUSA.

Right out of the box it had problems. It wouldn’t remember my region setting, and every time I set it to Region 1, it counted down a tick. Finally, when I reached “1”, I emailed I/OMagic and asked them why their firmware update was telling me “Not support for this device”.

Finally, I got it updated from 140I to 150I, which solved the region problem. It, however, did not solve my coaster problem. No matter what computer I put it in, any power supply, any setup, it always produces coasters above 2x or 2.4x (for -R or +R media).

I have the very sure feeling that this behavior is caused by a screwed-up write-method-cache, if this drive has one, because on a new 16x Memorex drive I sold (Lite-On type), it had the same problem but burned PERFECTLY after an EEPROM media cache erasure.

However, my major problem is that I don’t know what this drive is! Obviously I/OMagic isn’t a DVD drive production company themselves, just a distributor. So how do I figure out what kind of “base model” this drive is?

Here’s the thing: Its drive identification string is, and always has been - get this - “GENERIC DVD RW 8XMax”. There is absolutely no hint at any kind of model (I/OMagic calls it “Internal 8X DVD±RW/±R Dual Format Drive”, no model number), or brand.

A link to the drive’s latest firmware (contained in an EXE file within the ZIP) is here:
http://www.hostfile.org/DD0401-150I-win.zip
http://www.hostfile.org/DD0405-150I-win.zip

Can anyone tell me what the heck is going on? And how can I squeeze 4x +R and 8x -R burns out of this darn thing (or vice versa but it only permits 4x burning on my new 16x spindle of +R media…)?

Use good media, preferably 8x Verbatim or TY.

I’ve used just about every kind of media in existance… same, uniform results every time - verifies fine at 2.4x (reads at about 4-6x while verifying) but if I bump the recording speed up to 4x, it slows the reading down to 0.5~1x and produces read errors about halfway through.

(Forgot to mention that. Lol…)

http://www.videohelp.com/dvdwriters.php?DVDnameid=210&Search=Search&list=2#comments

Are those speeds correct? Looks like it’s a BTC or an OptoRite, depending on… luck, I guess. See if anything there helps you out.

It looks like it’s an OptoRite version, guessing from a few reports of the drive string (the GENERIC DVD RW 8XMax string) and the firmware version numbers (mine’s been 130I, 140I, 150I, etc) - except that they’re calling it “150E”, instead of “150I”. Maybe I means “I/OMagic”? clueless

Those speeds seem right - I guess the media I just bought doesn’t support 8x on this drive for some reason (though it’s 16x media). However I have burned about 25 verified good burns with this media, though at only 2.4x. :frowning:

So, from here, I guess I’ll look up some info on OptoRite, see if it can help me repair this drive :stuck_out_tongue:

Funny, this site has a few programs for this drive, but no descriptions as to what they do. HD-Burn? Drive Rescue? What are they? :frowning:

edit: Yep, it’s definately an OptoRite DD0401. Now with that resolved, I’m gonna see if I can get 160E loaded onto it (crosses fingers)…

I 17:34:25 Destination Device: [0:0:0] GENERIC DVD RW 8XMax 160E (E:) (USB)
I 17:34:25 Destination Media Type: DVD+R (Disc ID: CMC MAG-M01-00) (Speeds: 2.4x, 4x)
I 17:34:25 Destination Media Sectors: 2,295,104
I 17:34:25 Write Mode: DVD
I 17:34:25 Write Type: SAO
I 17:34:25 Write Speed: 4x
...
I 17:49:02 Operation Successfully Completed! - Duration: 00:14:37
I 17:49:02 Average Write Rate: 5,468 KB/s (3.9x) - Maximum Write Rate: 5,630 KB/s (4.1x)
...
I 17:49:29 Source Device: [0:0:0] GENERIC DVD RW 8XMax 160E (E:) (USB)
I 17:49:29 Source Media Type: DVD+R (Disc ID: CMC MAG-M01-00) (Speeds: 2.4x, 4x)
I 17:49:29 Verifying Sectors...
I 18:01:32 Operation Successfully Completed! - Duration: 00:12:03
I 18:01:33 Average Verify Rate: 6,323 KB/s (4.6x) - Maximum Verify Rate: 9,798 KB/s (7.1x)

It was verifying at about 7x (constantly increasing speed) until it hit about 64%, then it dropped down to a flat 4x. Maybe a media problem there, I dunno. No errors, though!

But it burns at 4x now! That’s a HUGE improvement! That little firmware update seems to have fixed it!

My next burner is going to be that LG DVD-RAM one, I think. Of course I’ll check reviews and whatnot first. :stuck_out_tongue:

Any problems you’re having are probably due to the fact that the drive does not recognize the new CMC MAG. M01 media, and is thus using a generic 4x write strategy. This, coupled with the fact that 16x media is supposed to be burnt at a faster speed is probably cause for write errors. CMC MAG. M01 also isn’t really great media either. See if you could find some 8x discs from Fuji or Sony, preferably made in Japan, for top results.

The latest firmware that’s appropriate for the IOMagic is 160I (July 2004), but it’s not going to help with your 16X problem. You could stick MCC004 in there, and it’s also going to top out at 4X.

The 160I firmware can be grabbed from here (scroll down to the DD401 section): Accesstek site
(The ‘I’ series firmwares are for the OEM drives like the IOMagic and are the ones you want.)