880SA/Firmware 1.11/Plexutils 1.26 light flashing on drive continuously?

vbimport

#1

Updated to firmware 1.11 for my 880SA and 1.2.6 Plexutilities and am getting error in side plexutils. Click on system information and it says “Invalid image size”.


#2

So all updated here. And now the light just flashes endlessly. The drive works fine. Seems like its some power saving setting, something. Can’t find any explanation of it or how to turn it off!


#3

It would have been better to post a response under the topic you already had open:


#4

Maybe. But there’s more to this story than the problems with PlexUtils. Firmware 1.11 renders my 880SA useless. I had to go back to 1.10. And PlexUtils is the one that told me that 1.11 was available.

I suggest to be very careful with 1.11 firmware.

Not sure how that is related to the problems with Plexutils. But hey, feel free to have your point of view.

And neg… did you have a suggestion or were you just criticizing my posting?


#5

[ I merged both threads, since they concern the same hardware/software/firmware combination. ]

As for the problem itself I’ve no idea right now. Might be a bug in 1.11.


#6

Firmware v1.11 is only for Asia version PX-880SA which is a iHAS324 clone and does not support LightScribe feature.


#7

Thanks but I didn’t go out looking for it to install. Plexutils presented it to me as the latest firmware for my drive.


#8

[QUOTE=jsmiddleton4;2476934]Thanks but I didn’t go out looking for it to install. Plexutils presented it to me as the latest firmware for my drive.[/QUOTE]

Then you should yell at Plextor and tell them they should do a better job considering all the extra money they charge to rebadge drives you could get cheaper elsewhere.


#9

I let their support folks know.


#10

FYI: PlexUtilities 1.2.7 is available now.


#11

Still has invalid image size error in systems option and wants to install the 1.11 version that is non-lightscribe.

Could be since its the Chinese version of Plexutils?

Regardless it should not try to update a lightscribe drive with the non-lightscribe firmware…