822A Firmware upgrade not recognised by ReadNow! upgrade (7.2)

vbimport

#1

I have flashed my 822 to be at firmware level L.

BUT

When I run the update for the software (provide from the BENQ web page) it first uninstalls the existing (7.2) software and then says it can’t find a suitable DVD drive and aborts the installation.

The DVD is shown as ATAPI DVD DUAL 8x4x12.

Does anybody else have this problem?


#2

It’s a bit unclear to me what your problem is.
You flashed the firmware of your Benq 822A with firmware update B3LC.
Later you updated the Sonic Record Now software from 6.7 to 7.2.

Maybe your were runing Sonic Record Now 7.2 already and the uninstall.exe did this work, so now your drive won’t be recogniced. Which version of Sonic are you running now. Maybe you just need to install the Sonic update patch from 6.7 to 7.2 again.


#3

Thanks for making a response.

I have re-read my post. What I have written is not correct (too late at night here in China to write clearly). What I should have said was:

I have flashed the firmware to level L. This was no problem.

I obtained the provided software upgrade via the BENQ website.

When I tried to upgrade the software from 6.7 to 7.2 the following happened:

  1. The upgrade unistalled the exisiting software (version 6.7)
  2. The upgrade then failed to install the new software.
  3. I got a message saying that the upgarde could not find a suitable drive.

According to Device Manager, my drive is an ATAPI DVD DUAL 8x4x12.

Any ideas?


#4

Which exact drive did you purchase? Was it an OEM or retail version?


#5

You’ll probably have it solved by now, but just for the record: There seems to be an issue with Win XPSP2. It needs to be uninstalled first, then RecordNow can be upgraded to 7.2, then upgrade again to SP2. As you may have guessed; I’ve been there! Best of luck!


#6

Thanks both for the comments. Answers are:

  1. I bought a boxed, retail version. The drive is DW822A

  2. I am using Windows 2000. I guess I could try uninstanlling service pack 4, but I have no knowledge if this will help. (I can imagine your frustration on XPS2!).

Any more ideas?


#7

vonstahlein, take a look in this forum, http://club.cdfreaks.com/showthread.php?t=102905 ,you probably will find answers here. More peolple with the same problems. I hope you’ll find the solution to your problem in that thread.

I wish I could help you more directly, but I’m not runing Win2000 nor Sonic Record Now software.


#8

Thanks for the comments. I checked out the long thread. It seems like there are issues with the PeX engine not recognising a Dual Layer 822a. My problem is that the new install removes the old software. The upgrade then cannot ‘see’ the DVD device at all. Maybe the 7.2 upgrade is using a PeX engine that can’t see a Dual Layer DVD drive. However I have no idea what to do about it.

Both BENQ and SONIC are being rather unhelpful.

I have also tried Windows 98 and I am now runing the latest BIOS on my mobo and I also have the latest VIA chipset drivers. I must admit to being at a loss what to do next.

Waht software do others use to for the 822a Dual Layer and Windows 2000?


#9

Not sure about Win2K but had a similar problem with XP. Try uninstalling the VIA IDE drivers and use the Microsoft Standard ATAPI drivers (atapi.sys). Worked for me.


#10

Yeah, I’ve heard many others reporting problems using VIA IDE drivers. Try doing what lightning9 said. :iagree:


#11

Thanks for the idea. I tried it. No success. Maybe the Sonic upgrade just does not work under Windows 2000?


#12

Have you tried updating the pxengine? Maybe it’s worth trying the 7.1 update?
http://www.benq.com/drivers/storage_drivers.html


#13

Thanks for the suggestion. I tried it. No success. The 7.1 upgrade tells me I have no valid version to upgrade… At least the 7.2 upgrade recognised ReadNow 6.7. It just couldn’t recognise the drive.

The good news is that a Demo version of Nero recognises the Dual Layer Drive with no problem. So if I spend the money for Nero, I have a solution.

Just to make every body laugh, I received an e-mail from Sonic today. It was promoting the upgrade to 7.2! Since the free one doesn’t work. I don’t think that I want to pay for it!


#14

well, all I can say is thet I understand your frustration, but still, don’t give up. Why not write and describe the problem to sonic support? That’s how I got my solution! I also have the free version packaged with the dw822a drive. For what it’s worth: the problems are exactly the same as the ones I had before removing SP2. I know that won’t help much if you have win 2000, but I’m anyway quite sure that support may be able to help you out.


#15

@vonstahlein,
I got into this DVD thing about a year and a half ago. Started off with Sonic also since it was FREE with the DVD burner. Since then I switched to NERO and never looked back. Reasons why are as follows:

  1. Nero does about 4-6 free upgrades doing the year. They keep on fixing their product and also Tech Support will work with you to fix the problem.

  2. Sonic on the other hand, states you get your support from the OEM package maker not from them. They only support their RETAIL package. Great support - ha, ha.

  3. Sonic normally does not have updates. They just come out with a new version, that by the way you must re-purchase.

  4. Getting support from Sonic is almost impossible and most of the time their recommendation is purchase the new upgraded version.

THAT MY 2 CENTS for what it’s worth !!!

P.S. You can look around to purchase an OEM Suite 6 of NERO real cheap. It’s not the full package with all the options, but will more than likely be all you need. You also get your support from NERO unlike Sonic…


#16

:iagree:


#17

The same here with XP SP2. I can’t update.

But I will try to install the MS IDE drivers instead of the VIAs one.

Maximilianus


#18

BenQ Germany send me a cdr with Sonic RN 7.1 last week. That’s really good support!

Maximilianus


#19

Please let us know if 7.1 works OK. I hope it does. I failed to install it on Windows 2000.

Meanwhile I have cleaned up my machine a lot and got it running well. Even so I cannot make the upgrade to 7.2 work. It still refuses to see my DVD burner.

I have also started a separate thread to ask if anyone is using Windows 2000 with a DW822a, so far no postive responses. Maybe I am the only user with a Dual Layer DW822a on Windows 2000?