812S won't DMA

vbimport

#1

Hi,

I have an AMD Atlhon XP2000 with and Epox 8K3A+ Motherboard.
I have the Lite-On SOHW 812S DVD Burner as Master on the Secondary IDE Channel and a Pioneer DVD Drive as secondary on that same channel.

If i try to rip a DVD to my HDD using the Burner it can take upwards of an hour using DVD decrypter, put that same disc in my pioneer drive and it will take 10 mins. I believe the problem is that the burner is in PIO mode instead of DMA mode. Does anyone know how i can make the burner go into DMA mode. If i look in the device manager --> IDE/ATA Contrlr --> Secondary IDE. It shows that the Pioneer drive is in DMA mode 4, and that the burner is in PIO mode, DMA if available shown for the burner but it is not using it for some reason.

I had a look in the bios and found the right section but was unsure what to do and it all seemed to be ok anyway, this is how it was setup.

PIO
Primary Master - “Auto”
Primary Slave - “Auto”
Secondary Master “Auto”
Secondary Slave - “Auto”
*The Options available under these section were PIO Modes 1-5

DMA
Primary Master - “Auto”
Primary Slave - “Auto”
Secondary Master “Auto”
Secondary Slave - “Auto”
Options Available are DMA33, DMA66, DMA100, DMA133

All the options default to Auto and both my HDD’s and my regular DVD drive automatically go to DMA Mode, its just the burner, it also takes about 25 mins to burn a DVD at 4x as it is constantly emptying and refilling the buffer, thank god for smartburn.

Any help would be appreciated.


#2

BIOS settings look OK, should be working. What version of Windows are you using? Have you installed the appropriate VIA Hyperion drivers? VIA

In the BIOS, there will be an option for detecting connected drives - run that and ensure that the Secondary Master comes up correctly, everything on Auto. Also, have you tried forcing UDMA33 in the BIOS?

On the second POST screen, the BIOS shows what drives are connected and their modes - if you can catch that screen using Pause it’s another check.


#3

From what You’ve wrote it seems You have Win 2000 / XP.
These sometimes (after some count of ATA errors) switch the drive to PIO and do not longer respond to setting it back to DMA.
I solve it by removing all 3 IDE devices (primary, secondary & parent host). Then after reboot they are redetected and set (or can be set) to DMA again. I think this might solve Your problem.


#4

Ok, yes, i have windows XP i thought i posted that, sorry, i have the latest hyperion drivers, or what we’re the latest at last windows re-install, not sure what version exactly but they are the hyperions, and were downloaded about 3 weeks ago, so i’m assuming the most up to date.

I will try and force the drive to dma33 mode through the bios right now and see how that goes. I’ll let you know within 30 mins.


#5

Reinstalling over already installed (even older) drivers WILL NOT solve the problem I wrote about. You have to manually REMOVE the hardware from Device Manager and then reboot and let Windows redetect it!


#6

Forcing in the bios did not work so i took the case of my commputer unplugged the cd drioves, let it go into window, turned off re-plugged the cd drives in back into windows, still PIO mode, go here to tell the story and see your post, so ill post again in like 10 mins and see how it goes with that lil bit of information.


#7

OK, i uninstalled dvd drives through device manager, unplugged the cables (wasnt sure if i needed to but i did anyway) went back into windows, turned it off, plugged them back in, windows detected the drives went back to device manager but it was still in PIO mode.

Was it the DVD drives i had to un-install through device manager or the actual secondary controller?


#8

You did it wrong - you can keep your drives OK, but uninstall IDE controllers - all of them: primary, secondary and the parent (VIA BUs Master or. something like that)


#9

Uninstall… :smiley:


#10

I do not think uninstalling secondary channel only is sufficent. I’ve tried it some time ago and it did not allow to set the drive to DMA. I had to remove the parent host too.


#11

Originally posted by DavesMan
I do not think uninstalling secondary channel only is sufficent. I’ve tried it some time ago and it did not allow to set the drive to DMA. I had to remove the parent host too.

Attached picture is only as an example. He don´t need to REMOVE the drives…heh he. :smiley:

DavesMan is right. Remove all IDE ATA/ATAPI controllers; main, pri, sec.

GL kmartin1982

@work right now, sorry…


#12

OK, i’ll try that tommorow, i’m back at my place nowm it was my brothers that has the problem, i have the two exact same drives and he was getting annoyed because what took me half an hour took him 2 lol.

I’ll let you know this time tommorow night but hopefully fingers crossed, it will be good news.

Again, thanks for all your help.


#13

thanx for all your help guys, its working perfectly for him now :smiley:


#14

OK. Glad to hear that!:cool:


#15

Hard disk connected as master device and pioneer connected as slave on the primany IDE port; nothing connected to the sec. IDE port.
connect the 812s as master to the sec. IDE port. this will give the best copying speed.

uninstall primany IDE in device manager reboot, primany IDE will be reinstalled with DMA on, do the same with sec. IDE if you have to, or do the sec. IDE first.
if you check the info on any disc that came with the lite-on the manual shows you how to connect the 812s.

Originally posted by kmartin1982
[B]Hi,

I have an AMD Atlhon XP2000 with and Epox 8K3A+ Motherboard.
I have the Lite-On SOHW 812S DVD Burner as Master on the Secondary IDE Channel and a Pioneer DVD Drive as secondary on that same channel.

If i try to rip a DVD to my HDD using the Burner it can take upwards of an hour using DVD decrypter, put that same disc in my pioneer drive and it will take 10 mins. I believe the problem is that the burner is in PIO mode instead of DMA mode. Does anyone know how i can make the burner go into DMA mode. If i look in the device manager --> IDE/ATA Contrlr --> Secondary IDE. It shows that the Pioneer drive is in DMA mode 4, and that the burner is in PIO mode, DMA if available shown for the burner but it is not using it for some reason.

I had a look in the bios and found the right section but was unsure what to do and it all seemed to be ok anyway, this is how it was setup.

PIO
Primary Master - “Auto”
Primary Slave - “Auto”
Secondary Master “Auto”
Secondary Slave - “Auto”
*The Options available under these section were PIO Modes 1-5

DMA
Primary Master - “Auto”
Primary Slave - “Auto”
Secondary Master “Auto”
Secondary Slave - “Auto”
Options Available are DMA33, DMA66, DMA100, DMA133

All the options default to Auto and both my HDD’s and my regular DVD drive automatically go to DMA Mode, its just the burner, it also takes about 25 mins to burn a DVD at 4x as it is constantly emptying and refilling the buffer, thank god for smartburn.

Any help would be appreciated. [/B]


#16

i have now the same problem…
drive had DMA on, i updated to US0N, then VS08, then backto US0Q…
now it is in PIO mode only…

@kmartin1982:
what was the solution? remove primary and secondary controllers?


#17

i tried uninstalling the drive only and restart, on reboot will be detected, but remains PIO mode.

tried to remove the primary, secondary and main IDE controllers, and
:a :a :a :a
on each reboot windows xp will detect primary and secondary, then hdc that will be installed as primary and another hdc that becomes secondary, then error about driver not intended for this platform, 3 times reboot, the same.

uninstalled via, same result, reinstall latest 4-in-1 the same…
:a
thanks god Windows system restore had made a copy 2 hours ago (before problem started), restore (for the first time i use this tool), and WOW :eek: :eek: everything is ok now :slight_smile:
IDE Controller drivers ok, liteon detected correctly, DMA is on…


#18

I have come across this at work, as we sell alot of these drives. The solution we’ve found is to use an 80 wire ide cable instead of standard 40 wire ide cable.

Hope this helps you out


#19

Read the Article on the MS Knowlegebase at:

http://support.microsoft.com/default.aspx?scid=kb;en-us;817472

I fixed this problem permanently (and safely, no registry hacks or uninstalling reinstalling devices, etc.) by obtaining the Hotfix. Since the Hotfix showed up as being part of Win XP SP2, I suspect that it is now included in the full Win XP SP2 download.


#20

I have exactly the same problem, but i don’t have System Restore enabled…

What now??? :confused:

I have on IDE ATA/ATAPI controllers

  • Unknown device
  • Unknown device
  • VIA Bus Master IDE Controller

HELP!