812S and SP2

vbimport

#1

Last year I bought a DVD-RW unit I installed on my XP SP1. It was sold as Sony even there is no brand printed in front of it. System recognized it as a Sony and it worked fine. I have burned around 100 data DVDs. Last week I upgraded to Service Pack 2 and then DVD is recognized as a LITE-ON 812S. The issue is that the burning time has been cuadruplicated, red light blinks to orange constantly. All the computer slows down while recording during an hour.
It is a mess. Should I remove SP2 because of this?
I Installed last firmware (Q) succesfully but problems have not gone. Please help. Thank you.


#2

Sounds like the SP2 upgrade somehow turned off DMA… this might help:
http://club.cdfreaks.com/showthread.php?t=101616


#3

Thanks for your answer.
I set “DMA if available” for two channels and two devices. After restart it all “Transfer Mode” are “DMA if available” and “Current transfer mode” are “PIO Mode” (3HD 1DVD).
I contacted Lite-On support service and they kindly have answered my questions but still cannot solve this problem.

Before upgrading I had installed two HDs a CD-RW and this DVD-RW.
I removed the CD-RW and added a third HD. I had to change something to master and/or slave (jumpers). Is it possible that this changes may cause this issue?


#4

How may I test DVD burning speed without having to waste dvds?


#5

Please read the DMA guide I linked to in my post. At the end, it has instructions on how to deal with the problem you just described where the transfer mode remains stuck in PIO even after you tried to change it.


#6

I uninstalled DVD-rom channel and Windows reinstalled it.
Both drives are recognized but no ‘Advanced settings’ tab is under IDE channel properties to check DMA.
I restarted twice.
I am burning a DVD now and it is very slow too.
Different behavior.
Nero 6.6 4X
“Used read buffer” is emptied rapidly so, orange light becomes for a while until it is “charge” again.
Total time has decresead 1hour->40 minutes, far away of regular 15 minutes.
Regular burning mode is red burning light always turned on. Sometimes, when resources or memory are low, short periods of orange light appear.
I use Mac and Win(because of my customers) and have to say: I hate Windows. I mean: I hate Windows.
Thank you for your help.
PS:
All my Device manager descriptions were in Spanish until IDE channel was uninstalled. This reinstalled channel has its description in English. Who knows :bow:


#7

Maybe it would’ve been better if you didn’t uninstall the channel (and instead went with the alternative registry solution in the note at the end). Oh well, too late now.

Your system is still stuck in PIO mode, and from your description, I’m starting to think that you’re using a 3rd party driver here.

Check the drivers used for your channels and for your IDE controller. You should be using Micrsoft drivers. If you are using drivers from another company (Intel, for example), uninstall them. You should never use anything other than the default Microsoft drivers. The so-called improved performance of things like Intel’s Application Accelerator is more or less snake-oil and often just causes problems.

What probably happened is that because you were using 3rd-party IDE contoller/channel drivers, the SP2 upgrade probably triggered some kind of compatibility problem that kicked you into PIO mode. Another reason to use the default drivers that come with Windows.


#8

DVD channel
DRIVER
Driver supplier: Intel
Date: oct 1, 2002
Digital sign: Microsoft Windows Hardware Compatibility Publisher
Driver: IdeChnDr.sys

The other channel, Driver supplier: Microsoft, atapi.sys, storprop.dll

How may I change the first channel driver?
Surely it will be a big problem to exchange channel 0 and channel 1 wires on motherboard. Isn’t it?


#9

Try to “roll back” the driver. And if that doesn’t work, uninstall the driver.


#10

I had tried “roll back”.
Uninstall driver did install intel driver again instead of microsoft (mainboard is intel)
There is (was) a third atapi driver apart of channel 1 and 2. It is intel related.
I have removed it and now I cannot start windows (safe or other mode)
I am on Recovery shell but I don’t know what to do.
Command listsvc displays installed and uninstalled drivers


#11

I fixed this last issue, I forgot to follow ‘last working conf’ at starup
options


#12

XP reinstalls intel driver for the channel I deleted


#13

Now I have opened my computer and swapped ide0 and ide1 wires.
Then I changed to ‘DMA if possible’ but it didn’t change it.
Then I went to registry and deleted MasterDataCheckSum, nothing changed.
I’m afraid to delete this (microsoft driver) channel.
I’m also afraid to uninstall SP2, I don’t trust Windows.


#14

Just a remind, that swap was made because “advance conf” (to set DMA if possible)tab have dissappeared after deleting the other channel


#15

I’m out of ideas, then; the standard tricks don’t seem to be working. This is purely a problem with Windows, so maybe a visit to Microsoft’s support site might help.


#16

Previous experiences were funny.
I remember the enormous differences between Apple and MS support sites 4 or 5 years ago.
After reading your post I was exceptical about visiting Microsoft support site.
‘Just a try will not hurt’ I thought.
url: http://www.microsoft.com/
‘set dma drive’ I set into the upper left box for search to see what would happen.
Nice!
Http 403 error, forbidden.
Nice!
Yes, I know, there is always a reason.
Maybe, I have to set Preferences-options-myPreferences-option4-MyHiddenWishes-…to ‘yes’
Such huge company with this error on its main page!


#17

I have reinstalled XP SP2 so I get ‘advanced conf’ tab again with the option to PIO or DMA if available.
Nothing has changed, I’ve repeated all previous steps and at last I remove secondary channel. When it was installed again, ‘advanced configuration’ had disappeared again.
I burned a DVD with the same problems but I kept the nero log file, burning was successfully but verification was not.
When reading the disk I cannot find errors. Even more, I use cdTree to catalog its content and no errors were found.
I’ve attached this file. I found that DMA is ON !!!
So, what is slowing burning performance?
I hate that excuses like ‘just a coincidence!’ but is it possible that de DVD-rom got a hardaware problem just after SP2 was installed? Obviously the answer is Yes.

woDMA.txt (13.5 KB)


#18

There’s no hardware problem.

Sisoft Sandra is telling me that Current Active Mode is:
Ch 0 device 0 (HD) -> UDMA-5
Ch 0 device 1 (HD) -> UDMA-5
Ch 1 device 1 (HD) -> UDMA-4

while XP tells Ch 0 devices are set to PIO; no info about Ch 1.

Today I have installed XP SP1 in another disk (ch 1 dev1) and on ‘Adv. Conf’ HD DMA’s are set same as Sandra at SP2, plus
Ch 1 device 0 (DVD) -> UDMA-2
I could burn a DVD in 15 minutes (4x)
Conclusion: SP2 misunderstands itself. It informs the user the drives are in PIO mode(who knows real transfer mode), it is unable to change or keep SP1 settings in any ‘regular’ way.
Even worst, as I’ve been reading I’m afraid it will be a nightmare to uninstall SP2.
Any suggestions?
Thank you very much for your time.


#19

reinstall windows from a sp2 integrated cd, I am a firm believer when it comes to service packs never install them on top of current os, instead install integrated service pack from fresh.


#20

I have an 812S/832S running CG5g firmware

I had problems when I installed SP2 in that my machine seemed to ran slow. I disabled Automatic Updates and have had no problems since.