812@832 VS08 - Bitsetting Not Working

I recently flashed my 812 to 832 with VS08. I used the latest version of Omnipatcher and loaded in the “pre-patched” 812@832 VS08 firmware and then saved a new firmware with all the checkboxes checked. I then ran the saved .exe firmware and rebooted.

Since then the burns have been fine but the Auto-Bitsetting simply isn’t booktyping DVD+R to DVD-ROM. I’ve tried 3 burns since and re-flashed once and it still isn’t bitsetting.

I had no problems with bitsetting previously with the latest 812 patched firmware via Omnipatcher.

Is there anything I have not done properly?

Thanks…

C.

What program are you using to check the booktype?

Use DVDinfoPro it will tell you the media type and booktype

Nero and Kprobe both report my DVD+Rs as DVR+Rs instead of DVD-ROMs. Plus my 1997 Sony DVD player no longer plays them.

I figure I must be doing something wrong as far as the proper procedure for flashing an 812 to 832.

I think the problem might be I am using “patched” VS08 through Omnipatcher instead of the stock VS08 firmware. Perhaps I am double patching which is causing the the settings not to take.

I’m going to try downloading stock VS08 firmware, running it through Omnipatcher and then flashing.

C.

Yeah mate you’re suppose to use the stock firmware from codeguys website and patch it with omnipatch (don’t forget to tick that autobitsetting feature).

Good luck

Are you using Nero? Newer versions of Nero have been known to override the effects of auto-bitsetting and the official booktype utility.

One way to check to see if autobitsetting is working is to pop in a blank disc, open up KProbe 2.2.3, and see if the “change to” drop-down says “DVD-ROM” instead of “Normal”. If it does, then abs is working and your problem is something else. If it says “Normal” then you should make sure that you flashed your drive with the correct patched firmware.

Nero 6.3.1.7 doesnt have the bug anymore. Open Nero, then go to - recorder - choose recorder - select liteon dvd burner - options and there you can see that nero has a built in booktype software setting. Just select the booktype you wish for - click ok voila :wink:

regards

Same here liteon booktype1.0.6 or Kprobe 2.2.3 setting no longer shows correct booktype. I have flashed back to my original 812 eeprom and back to stokc US0N . Powered off and and checked Booktype and it shows DVD +R as the booktype and when I select DVD-ROM and click Change and then re-query it still shows the current booktype to be DVD+R. I flashed back to VS08 and that doesn’t make a difference. Now I’m not sure but I started to use Omnipatcher 1.3.5 and have check and unchecked enabled auto bitsetting and with it unchecked I can not change book types. With it check it is burning with a Booktype of DVD-ROM. My issue is I want to be able to select my booktype if I change all my settings to stock but something has changed and flashing the original eeprom and using stock firmware doesn’t fix this problem. Any suggestions?

Same here,
Patched with 1.3.5 Omnipath. Dvdinfopro report booktype dvd-rom nero cd-dvd speed
report dvd+r. Use VS08 fw. Tested also in 1.3.3 the same results.
Whats the differrents between dvdinfo and cd-dvd speed concerning report of
booktype setting.
Any idees??

I do believe it works!
Take a look here:

Press the red-bordered icon …

…et voila! “Disc type: DVD+R (Book type: DVD-ROM)”
I think that burners show in CD/DVD Speed and in similar tools the type of disc by default, and not the book type. Same happens with my NEC2500A; viceversa, when I had a DVD-ROM reader, those tools showed only the book type.
HTH!



Ok I have now uninstalled Nero and delete all registry entry for it. flash my original 812 eeprom back and flashed stock US0F f/w back. Hard booted my system and I still can not get the booktype 1.0.6 to show DVD-ROM Booktype it still shows DVD+R. So I am unsure what the true book type is. I would like to be able to choose between DVD-ROM or DVD+R but now it looks like that will not be possible anymore. Code65536 is this a bug that happens when you flash from 812 to 832 with the recent US08 f/w or is it a bug with the new omnipatcher 1.3.3 and higher( I say this because I tried OP 1.3.3 and with autobitset not check but I still get the above results. I may now tried an older version on OP with bitset not check to see if it makes any difference. but from the CODE Gods Heeeeelp! :confused:

For the record (since I started this thread), I was able to fix my bitsetting issue.

It was, as I speculated in one of my earlier posts, simply me incorrectly loading “pre-patched” 832 firmware into Omnipatcher and then flashing with it. The correct way is to load -stock- 832 firmware into Omnipatcher and then flashing.

No problems now to report of - I’m getting very nice burns with my 812@832(VS08) drive using RICOHJPNR01 media. I have yet to try any DL burns yet (where the heck in Canada can ya get the stuff anyway!!??).

My latest burn which (since I am new to “Kprobing”) is not bad…I think. I’m looking for under 280 PI and under 4 PIF, yes?

I wish it was that easy for me to fix as to use stock uS08 F/w of whichI did but it still doesn’t allow me to change booktype setting or at least doen’t show the correct booktype setting that is set to the 812@832. This persist even after flashing back to stock US0N with autobitsetting not enabled. I even have tried OP 1.01.2 version to see if it was something in the new version of OP but so far it no OP. so I don’t know what it is. You would think that flashing org eeprom and stock firmware would fix this problem but it not so something has been written and can not be over written or is in a location that the firmware is not updating. I don’t know i just guessing

ok booktype 1.0.6 was is working all along I am a dope getting disc type field mix up with booktype field so booktype are being changed now that I am back at stock but Kprope 2.2.3 is the problem and even when you change booktype there the booktype field still shows DVD+R but you switch to Booktype 1.0.6 and it show it set to the correct booktype. so I guess this is bug in Kprobe.

sorry for me being stupid :sad:

ok not a bug in Kprobe I just thought that the booktype field would show the current state the burner is in not the booktype on the burnt disc. doh :o