7260s reads discs in XP but not Win7

vbimport

#1

I’ve got an Optiarc 7260s, flashed with Liggy’s 1.03bt firmware.

In XP, discs read fine and I scanned one and it was fairly good at 94%.

In Win7, the same disc causes Explorer to freeze and the drive head can be heard constantly struggling to read the disc. The contents are visible but clicking on a folder doesn’t open it, or at least not for ages, so something about Win7 is making the drive act wierd.

I’ve gathered some driver info from both XP and Win7 and attached it below. I have tried disabling Daemon Tools’ SPTD driver and also uninstalling and reinstalling the 7260, neither of which has helped.

There’s also a load of Event ID: 51 warnings in the log which say “An error was detected on device \Device\CdRom0 during a paging operation.”

XP:
Drivers - cdrom.sys, imapi.sys, redbook.sys, storprop.dll
DTlite - 4.35.6.0091 SPTD v1.62 (only SCSI drive)
Standard Dual Channel PCI IDE Controller: atapi.sys, pciide.sys, pciidex.sys
AMD SMBus Driver for South Bridge v5.10.1000.8 installed

Win7:
Drivers - cdrom.sys
DTPro v4.41.0314.0232 SPTD v1.78 (SPTD disabled)
Standard Dual Channel PCI IDE Controller: atapi.sys, ataport.sys, pciide.sys, pciidex.sys

===============================================
Filter Driver Load Order - ImgBurn v2.5.5.0

Upper Device Filter: [None Found]
Upper Class Filter: [None Found]
Device: CD/DVD-ROM Device
Lower Class Filter: [None Found]
Lower Device Filter: [None Found]


#2

The Win 7 one is a fresh install ?
Have you already tried to completely remove DT Pro ?

What’s your motherboard ?


#3

Yes it’s a fresh install, done just last week.

I haven’t tried removing DT Pro yet as it’s only a trial and I’m not sure if I can re-install it and use the remainder of the trial. However, I think I had problems before installing it, when I had Liggy’s 1.6 on the drive and it wouldn’t recognise discs at all (kept asking me if I wanted to format them!). I know I got the drive working better by flashing another firmware, but I can’t remember if it was original or Liggy’s, so it may be that these problems started happening again when I re-flashed with Liggy’s 1.03. Maybe I should try flashing an original firmware again and see if that helps.

Motherboard is Biostar TA790GXBE.


#4

So the drive once before worked ok in Windows 7 ?


#5

I’m afraid I can’t recall whether it worked [I]properly[/I] as I’ve only just installed Win7 and haven’t got round to using the drive until now. All I recall is that with Liggy’s 1.06 it didn’t read discs at all and I improved that somewhat by flashing with a different firmware.

I’ve asked on the Daemon Tools forum about whether I can uninstall/re-install and still use the remaining trial period and I’ll probably try uninstalling that first I think, before flashing the drive again.


#6

OK, so I’ve uninstalled DT Pro and flashed the drive with the original 1.03 firmware, and still the problem’s the same. I never thought the DVD drive would be the most complicated part of moving to Win7!


#7

In BIOS, what’s set at Chipset -> SouthBridge Configuration -> OnChip SATA Type ?

Already tried this SouthBridge driver ?
http://sites.amd.com/us/game/downloads/Pages/integrated_win7-32.aspx#3


#8

I’m pretty sure it’s set to Native IDE but I’ll have to double-check. Yeah it is

I do normally install the AMD SB driver in XP but I’m not sure I have in Win7 yet, so I’ll try that one thanks.

EDIT: Nope, that didn’t fix it unforunately.


#9

Hem, i’m running out of ideas.
Just to be sure: there’s no exclamation mark in device manager ?
Any change in Safe Mode ?
Do you have a second optical drive in this rig ?
Any related errors in Computer Management/Event Viewer/Windows Logs/System ?

What i personally would (desperately) try besides waiting for the straight tip at Club MyCE:

  • a BIOS reset …even though the drive works in XP (remember, i’m desperate ;))
  • testing the drive in my second Win 7 x64 system
  • creating a backup followed by a fresh Win 7 install
  • if i get depressed :sad:, i’d maybe try a BIOS update

#10

Yeah, it’s baffling I know. :confused:

There’s no exclamation mark in DM.

I’ll check in Safe Mode, you never know!

I just took delivery of a new Liteon to replace the one in my other PC that’s just died, so I might as well try that in this PC first, and then try the 7260 in my other PC under XP and Win7.

I’ll check but I think the only relevant errors in the log were the ID: 51 ones I mentioned in my first post. Not sure if they were under System though.

I’ve actually flashed the BIOS twice recently (no, I wasn’t depressed, ok maybe a little :smiley: ), which reset it each time, so unfortunately I don’t think that’s going to help.

I’ve got a VHD I made quite soon after installing Win7 and I tried with that and no improvement. I guess I could always make another VHD and do a fresh install into that to see what happens. Actually, I’m curious to see what will happen if I try and access the drive via XP running in Virtualbox on top of Win7 now. That should confuse the bugger :disagree:

I’ll report back, if I don’t accidentally create some sort of monster that destroys me :wink:


#11

Only one thing left to say: Good luck !

EDIT: just found a thread with similar issues - different chipset though:

I finally narrowed it down to anytime there is flash media attached to any USB device on the PC (regardless if its a card reader or a thumb drive plugged into a USB port.

Boot with no flash memory and the drives work just fine. Insert flash memory and you get the errors. Errors will continue until you re-boot.


#12

Cheers!

Hmm, I haven’t been booting with any flash media attached, but it might be worth just disconnecting my front USB bay to see if that helps. Hell, I’ll even disconnect my USB keyboard and mouse and Remote Desktop in to see what happens!


#13

Well I should update the title of this thread!

I tested the disc on my X3 box (in an SH-D163B drive), and exactly the same problem, disc reads fine in XP but causes the drive to chug in Win7.

I also tried my new Liteon drive on the X4 box and the same thing. I tried to identify what the two PCs have in common, so I uninstalled Antivir from the X4 and disabled Win7’s CD Burning feature via Group Policy Editor, none of which helped.

I’ve still to do a fresh install (into a VHD) and try Win7 in Virtualbox as well, so I’ll try those when I’ve got a minute.


#14

Yea, I’ve made some progress at last :slight_smile:

I installed Virtualbox and booted an XP VM that I already had handy, and there was no problem accessing the DVD drive from within that, whether I ticked the “Passthrough” box or not, which satisfied me that there wasn’t a hardware configuration problem.

I then installed Win7 into a VHD and booting from that, again the DVD drive reads my discs just fine.

I still haven’t got a clue what’s fudging up my real Win7 installs on two different boxes though :confused: I’ll do some Windows Updates and see if they trigger it.