7240s refuses to work?

vbimport

#1

Hi everyone, i have a problem i really need help with, so far everything i have tried does not work.
My old Liteon ide drive started getting sticky so i decided to go for the 7240s sata . I originally plugged this drive in to my Striker Extreme motherboard thinking everything would be fine but i was wrong. I have Raid 0 enabled and i read somewhere that this may cause problems with a sata dvdr, so after trying two sata ports(3 and then 6) and getting the same result,(ie nothing) i bought a pci express sata controller card, installed the non raid drivers, but still no luck. Heres what happens:
In the BIOS it shows up fine.
When i boot up i can insert the vista disc and the drive will read it and spin up normally. When i reach desktop it’s a different story. It will not work at all, furthur more, when i look in Device Manager the drive is showing in ‘other devices’ and has no driver information. If i try to update the driver i get the ‘Windows has found suitable drivers but access denied’ message. I have tried different sata cables, i have updated the bios to 1901 , i have removed the Upper/Lower filters, no matter what i do nothing seems to work??
I am on Vista 64bit Ultimate with latest service packs etc
please help if you can, this is doing my nut in!
Many thanks-Rich


#2

Welcome to the forum.
If the drive shows in the BIOS when connected to Intel ICH SATA, the correct setting if your HDD’s are in RAID0, should be NON Member RAID, and on this setting it should work ok. At least it works fine on Windows 7.

Also, normally to install a driver, you will need to be logged in as an administrator in Windows. Have you checked this?


#3

Hi, as far as i am aware everything in Bios is correct,( there is no option for non member raid) and i am logged as Administrator.


#4

I probably didn’t explain it very well.
In your BIOS (if you have 2x HDD in RAID) then your BIOS setting will be RAID.
Assuming it is a Intel RAID (ICHxR) then you will have built the RAID array with the Intel utility in the BIOS.
So lets say you have two HDD
They will be listed at boot as xxxx member RAID
2nd drive xxxx member RAID
Any optical drive should be listed as…
Optiarc AD7240S [B]non[/B] member RAID

You’ll also need to install the Intel Matrix RAID drivers and utility in Windows


#5

I dont have Intel Raid , i have Nvidia 680sli Striker extreme motherboard, but everything is correct when booting up, it’s just when i reach desktop that nothing happens, and the drive appears in Device Manager in ‘other devices’


#6

Hi,

is your drive still connected to the add-on controller card? Also please provide some information about the card.

Michael


#7

Yes a little more info on the add in card would give us more to go on to try and help you get it
sorted out info like is it a SIL chip set card say like a 3132 chipset. Some times you have to flash
the card’s BIOS to a non raid base BIOS and use the non raid drivers I’ve had to do that to 3 different
SIL add in cards to get them to work correctly with my DVD burners.

I have a PCI SIL 3114, PCI SIL3512, and a PCI-E SIL3132 card, all three had to be flashed with the base
BIOS before they wanted to worked correctly with my DVD burner’s.


#8

Hi, Yes it is still connected to my controller card. the card is here: http://www.novatech.co.uk/novatech/prods/Components/ControllerCards/IDEAndSATA/Novatech/M275.html
When the card was connected to my motherboard Sata ports i had the same result as with the controller card.
I have the non Raid Bios etc installed, but it still refuses to work at desktop, and still remains in Device Manager- 'Other Devices’
Regards-Rich


#9

[QUOTE=e575fho;2491641]
When the card was connected to my motherboard Sata ports [/QUOTE]YOU DID WHAT? :eek:

Sorry for shouting…

Michael


#10

[QUOTE=mciahel;2491661]YOU DID WHAT? :eek:

Sorry for shouting…

Michael[/QUOTE]

LOL!!! mciahel I think e575fho meant when he had the drive hooked up to the mobo ports. :bigsmile:

@e575fho on the site all it says is (“There is no specification on this product.”) I can not tell if
it is a SIL chipset or not by looking at the picture. Can you look at the chipset on the card and
see if it says SIL or VIA or what ever it is and let us know. If it has a VIA chipset on it then they
are known to have compatibility issues with some if not most or all SATA DVD burners.


#11

A poster on another forum identified the card as a SiI3132 chipset. As this is happening with mobo and pci card, perhaps a Vista quick-fix from MS is worth a shot? Here’s a link to one of them http://support.microsoft.com/kb/929461. Don’t forget to uninstall the drive from device manager.


#12

[QUOTE=getit29;2491664]LOL!!! mciahel I think e575fho meant when he had the drive hooked up to the mobo ports. :bigsmile:[/quote]Nothing is impossible. Look at these awful galleries of mistreated hardware: http://www.dau-alarm.de/gallery.html

[QUOTE=deanwitty;2491726]A poster on another forum identified the card as a SiI3132 chipset. [/QUOTE]If so, then the non-Raid controller bios should be applied also. I wouldn’t trust the combination of Raid bios and non-Raid drivers at all.

Michael


#13

Ooops, i did mean the Drive hooked up to the Sata ports! lol sorry for causing the stress! I have tried the Mr fixit utility and it does not work, as in it detects a problem, but cannot cure it. I have just purchased an Lg ide drive now , but would still like to get this one working, as i have just been informed that they (Overclockers) will not refund me as it has been over a week, unless there is a problem with the drive(i am fairly sure the drive is fine)
Regards-Rich


#14

Hi,[QUOTE=e575fho;2491766]Ooops, i did mean the Drive hooked up to the Sata ports! lol sorry for causing the stress![/quote]Okay :slight_smile:
You mentioned, you have the non-Raid drivers for the controller card installed.
Assuming it is a card with Silicon Image chipset, have you also tried the (non-Raid) “Base Bios” for the controller card? You need to have a drive attached to the controller. And perhaps you need to have the Raid drivers installed in order to be able to flash the controller.

Additionally, the drive might be faulty for some reason. Is there any opportunity to try the drive in another computer?

Michael


#15

Yes i have the non raid bios, but it makes no difference, also the controller card shows correctly in Device Manager. I know the drive works because during boot up, it will read my Vista disk just fine. When i reach desktop i have the problems.
Regards-Rich


#16

Hm. I guess you also have uninstalled the drive from device manager and rebooted? Additionally, check if there are newer drivers for your controller card and your motherboard chipset available.

Michael


#17

Yeah, i have tried uninstalling from Device manager several times. I have the latest drivers for my m/b and for the card as well. I’m thinking maybe i will try Windows 7 as Vista has been a complete pain in the rear…:rolleyes:


#18

Ok folks, many thanks for your help in this matter, in the end a complete reinstall of Vista and all updates has fixed it. I now have my Optiarc running off of port 6 on my Motherboard! :clap:It would appear that something screwy had happened to Vista as it would not install drivers for anything!
Anyhow many thanks and best wishes- Rich


#19

I’m happy you got it sorted out. :slight_smile: