7170A got checksumError even in safe mode, any other options to flash the drive now?

Hi, anyone know if some of the old TDB dos flashers 2x00,5x00 etc can be used for flashing 7170A drive? I have used the Dee’s AD-7170A 1.O4 Modified Firmware and although I was flashing under safe mode I got the checksum error. Tried just about every fw/flasher I could find but none will write sucesfully. It seems maybe the DOS is the only way to restore my drive. The problem also is that all the 7170A firmware seems to have more than 1,44 MB, but maybe I could make a boot flashdisk and update from it. My bios should support it. I read the flashdisk must be formatted to specific format USB-Floppy, USB-HDD etc, so I guess if I just copy the files from the floppy created by drflash it won’t work. Anyone has some thoughts that could help me please?

btw when I tried the BINFLASH utility (http://binflash.cdfreaks.com/) with the -v option I got this error. Maybe the info will be useful to someone who knows how it works. I have used the original sony 173_rpc1.bin (only bin fw I could find for my drive)
http://img248.imageshack.us/my.php?image=20070718190935ul2.jpg
http://hidebehind.com/67639A

after sending firmware to 0x1e8000
it says sending checksum f3c5 to drive
Error submitting checksumError while flashing firmware

Have you ensured before flashing that the drive is in PIO mode?

i have the same problem man. tried to flash my AD 7170A without running on pio mode and resulted in the same error. is there a way to flash the drive and works? i might have to change the connection from the jmb36x raid controller to the standard ide of the mobo to flash correct .

Some of Optiarc’s AD-7170A OEM drives have an updated bootcode that seems to allow flashing even when not in PIO mode. Unfortunately these OEM firmwares are not compatible with those from Optiarc’s own drives.

For now the only recommendation is to use the standard IDE ports where available or try flashing with the drive attached to a 40 conductor cable.