716SA no detect in PlexTools

vbimport

#1

First post to this forum, thanks for any help you may be able to provide.

Plextools Pro will not detect the PX-716SA. For simplicity sake, I will paste the problem as submitted to Plextor - who has thus far been unable to help.

I am using an Intel 915P chipset with an ICH6R controller on an Asus P5GD2 Premium mobo. The system is configured with a RAID 0 on the primary SATA ports using two Western Digital Raptor drives. These are the Intel Matrix Storage Technology ports utilizing the Intel 82801FR I/O Controller Hub. The system also uses a Seagate Barracuda drive on one secondary SATA port and the PX-716SA is on the remaining secondary SATA port. An Asus DVD-ROM is configured on the standard IDE port as the master. The PlexTools software detects all of these drives except the one it should detect: PX-716SA! All motherboard software, drivers, and BIOS have been updated with the latest releases as has PlexTools and the 716SA firmware. The drive is detected in BIOS, Windows, and works in all other applications (i.e. Easy CD Creator).

I have checked on the Intel website for issues pertaining to this problem and have found no such item regarding the ICH6R or Intel’s Application Accelerator driver producing this type of issue. Furthermore, the fact that other SATA devices are detected by PlexTools, seems to discredit the idea that the problem lies in the chipset or controller. Therefore, I would respectfully request that Plextor investigate this issue further for a suitable problem resolution. Your assistance is much appreciated.

Again, thanks for any assistance. Great Forum!


Windows XP Pro SP2
ASUS P5GD2 Premium, P4 3.2Ghz
Kingston Extreme DDR2-533 2X256MB
2X WD Raptor 74GB in RAID 0
1X Seagate Barracuda 250GB
Plextor PX-716SA DVD Burner
Asus 48X DVD-ROM IDE
Asus EN6600GT 128MB
ThermalTake Soprano w/ 480W PSU


#2

obvious question: what version of Plextools?

welcome to the forum :bigsmile:


#3

I recently updated to V2.21… still no change!

Thanks… nice to be here.


#4

sorry, don’t have the SATA version of the drive so i can’t be of much more help. perhaps someone else here who owns it can provide some insight.

btw, i’ve heard horrid software conflict issues regarding the Intel Application Accelerator…have you tried uninstalling it to see if it makes a diff?


#5

thx for reply drpino…

no, haven’t tried uninstalling IAA… concerned about the RAID drive with respect to that, would I lose it? Anyway, hope someone can post more info. Have not heard of this problem before, nor has Plextor.

Thx again…


#6

no problem and good luck with your issue…as i don’t have an Intel either :wink:


#7

Not really since all of your other S-ATA devices are hard disks and it’s a known fact that some S-ATA chipsets have problems detecting S-ATA optical drives such as the Plextor. However, this post reports that the Intel 915 chipset does work with the Plextor drive. In that thread though there is also a report that with the Intel Application Accelerator drivers, the S-ATA drive does not work. Maybe your problem lies there? Sorry I can’t be of more help. Just like drpino I don’t have a S-ATA Plextor drive (anymore) and also no Intel based system.


#8

Hd6492, the Intel Matrix Storage (RAID) driver appears to have some serious problems supporting the PX-716SA. I have a ASUS P5AD2 Premium motherboard (925XE/ICH6R chipset), a PX-716SA, a pair of Maxtor 300GB SATA HDs, and WinXP SP2 with Intel Matrix Storage driver, so my configuration is very similar to yours. Plextools Pro 2.21 can recognize my PX-716SA, but I also have Kprobe2 2.4.2 installed to run with my LiteOn SOHW-1633S drive, and every time I launch Kprobe2, I get a STOP 0x00008086 blue screen! If I disconnect the PX-716SA from the ICH6R SATA port, Kprobe2 will launch properly. I also tried running a single SATA HD without the Intel Matrix Storage driver (using WinXP inbox Microsoft IDE driver), and Kprobe2 is fine even with the PX-716SA online. I am using the latest available Intel Matrix Storage driver 4.7, but the crash persists. There will soon be a new Intel Matrix Storage driver 5.0 to support the new 955X/ICH7R chipset announced by Intel yesterday, but I have also seen 5.0 crash the same way with Kprobe2 and PX-716SA! :frowning:

Another problem I encountered is that with RAID 1 (mirror), the Matrix Storage Utility cannot rebuild a broken mirror, if a PX-716SA is attached to one of the ICH6R SATA ports. Again, I had to disconnect the PX-716SA before the Matrix Storage Utility behaved properly.

I have reported the crash directly to Intel and awaiting an answer (I have contacts with the Intel RAID driver folks). My guess is that SATA optical drives such as the PX-716SA are relatively new, and probably did not get thoroughly tested by Intel prior to their Matrix Storage driver release. Until Intel can address this problem, I suspect their Matrix Storage driver will continue to have compatibility problems with the PX-716SA, and possibly other models of SATA optical drives as well. This is most unfortunate! :frowning:


#9

Thanks to all of you for the replies. The information is very helpful. It would seem that I have a couple of alternatives to try:

  1. There is a Silicon Image RAID controller on this mobo. I will connect the 716SA to this port and see how things work. Seems that others have had some luck with SI controllers.

  2. Based on your responses, it may be worth trying to uninstall the IAA and work with Windows XP IDE driver. This brings up a few questions however; Doesn’t the RAID 0 require IAA and Matrix drivers? And if not, might I expect any performance hit without IAA? Finally, can anyone briefly advise how to make the switch without losing data on the RAID 0, if possible.

I must admit, I’m new to RAID and especially this motherboard. But I sure am loving the performance.

Thanks again for all your help.


Windows XP Pro SP2
ASUS P5GD2 Premium, P4 3.2Ghz
Kingston Extreme DDR2-533 2X512MB
2X WD Raptor 74GB in RAID 0
1X Seagate Barracuda 250GB
Plextor PX-716SA DVD Burner
Asus 48X DVD-ROM IDE
Asus EN6600GT 128MB
Onboard sound w/ Klipsch Promedia 2.1
ThermalTake Soprano w/ 480W PSU


#10

HD6492, you are correct. If you want to do RAID 0 with the Intel ICH6R, you must install the Intel Matrix Storage driver. The Windows XP inbox IDE driver has no RAID support.

There is no simple way to transfer a bootable partition (with WinXP) on a 2-drive Intel RAID 0 array to a single SATA drive running with WinXP inbox IDE driver, without losing data. It may be quicker to re-install WinXP on the single SATA drive, after the ICH6R SATA controller on your motherboard is switched back to “IDE” mode, which is supported by the WinXP inbox IDE driver.

If you cannot tolerate losing everything off your RAID 0 array, here’s how you can transfer to another drive, and switch back to the WinXP IDE driver:1

  1. Connect both RAID 0 drives and the single SATA drive to the ICH6R ports (3 drives total). Leave the ICH6R SATA controller in RAID mode to allow the RAID 0 array to boot WinXP. Place the RAID array ahead of the single SATA drive in the boot sequence.

  2. Boot into WinXP. The RAID 0 array must be specially modified in preparation for copying to the single SATA drive to boot WITHOUT the Intel RAID driver. First, double click to launch the attached ICH6IDE.REG file to add an entry into the registry for critical boot devices. Next, look under the C:\windows\system32\drivers folder and ensure both pciide.sys and intelide.sys files are present. If either is missing, you may need to copy them from the WinXP installation CD.

  3. Install a Windows-based drive copying application. This can be Symantec Norton Ghost 9, or the older PowerQuest DriveImage 7.0, or similar.

  4. From WinXP, launch the drive copying application and copy the C: on the RAID 0 array to available space on the single SATA drive. Make sure the application can configure the SATA drive as bootable after the copying completes.

  5. Shut down the system. Disconnect the two RAID 0 drives. Power up and reconfigure the ICH6R SATA controller to IDE mode. Restart the system and the WinXP should be able to boot up from the single SATA drive with the WinXP IDE driver in control.

This is obviously a rather complicated and risky procedure, so I leave it to you to decide whether to attempt it.


#11

Thanks for the reply scan80269, you guys are awesome! This would be a last resort measure for me to take if only because I like the RAID 0 performance. Next attempt will be to configure the 716SA on the Silicon Image controller. My assumption is that this controller can be used for a non-RAID device?

Incidently, does anyone know if Nero 6 Ultra (6.6?) supports the PX-716SA?


#12

Hd6492, I use Nero 6 Ultra with my PX-716SA with no problems. The latest Nero 6 version is 6.6.0.12.

I haven’t tried connecting my PX-716SA to the SiI3114 SATA controller on my ASUS P5AD2 Premium motherboard. I would suggest going to Silicon Image website to pick up their latest IDE driver:

http://www.siliconimage.com/support/downloadresults.aspx?pid=28&bios=0&drivers=0&sataraid=0&


#13

yes NERO 6.6.X.X works with the PX716. just make sure you check here for known compatibility with SATA/RAID controller cards: http://www.plextor.com/english/support/media_712SA.htm