716A firmware update failure

vbimport

#1

Recently tried to update the firmware on my Plextor 716A burner from 1.08 to 1.09. It worked flawlessly.

Then the moment of stupidity came in when I tried to update the firmware on my other drive (LG GCE-8481B) with newer firmware without first removing the Plexy from the IDE channel. Needless to say, the firmware update on the LG failed and it toasted (I think) my 716A in the process.

I cannot get BIOS or Windows to see the LG at all so I think that drive is toast. However, I can get Windows to at least acknowledge that the 716A is on the IDE channel. It shows in device manager as the correct drive and even shows the firmware to be 1.09, but it has the red “X” in its profile, meaning it is disabled and no matter what I do I can’t enable it. If I try to flash again (either in safe or normal modes) it keeps telling me drive not found. I’ve tried putting the DMA jumper in place and booting that way to reflash but it always shows as disabled.

Is this drive toast too, or is there some trick I can do to get Windows to enable it again? I did read through some old posts here but none really addressed this and for some reason the search function isn’t working for me (I just get a blank screen instead of results).

Machine specs (if it helps):

Dell Dimension 8250
Windows XP SP2
1G RAM
ATI Radeon 9700 (w/latest drivers)
Maxtor 120G HD
Maxtor 250G HD
Creative Labs SB Live

Thanks in advance,
Matt


#2

Remove the cable from the controller, then delete the controller from dev mgr. Reboot and let the system re-detect the controller. Shut down, connect the cable with the 716 only and reboot. Should detect and access the drive. If you can read, shut down and connect the LG. Reboot and check drives in DM. If the 716 now has the x on it or you can’t access, the LG is most likely the cause. Could be the controller or drives just need to be enumerated again.