712a.. Slow DVD Read

vbimport

#1

Ive been trying to rip couple of dvd movies ( for personal back up), and no matter what software i use, it will only Ripp at x2 speeds. Thus taking much longer then it should. None of the software gives me an option of selecting speeds either.

My 712a has 1.07 firware. It is connected to a separate IDE chanel with 80 wire ribbon cable, in BIOS it is set to UDMA4, in windows xp is says its DMA 5

Anything i can do to make Riping at a faster speeds?

my system;
p4 3.0 @3.6
1 gig of ram
Mobo Asus p4c800 e dlx
bunch of sata and ide hard drives.
WinXP Pro with latest drivers, patches, etc etc

Thanks in advance.


#2

It’s definitely a DMA problem. PX-712A can only support up to UDMA2 so the one saying UDMA4 or UDMA5 is most likely not your 712A. Can you check the other IDE channel in Device Manager and please report back.


#3

Try holding down the eject button for three seconds, and put in the DVD to be ripped when the tray opens. I don’t think SpeedRead is enabled by default for CSS-protected discs…


#4

Or you could try enabling SpeedRead in PlexTools.

If you are using DVD Decrypter to rip your DVDs, then you can explicitly enable SpeedRead for Plextor drives in DVD Decrypter options


#5

OK.
I double checked BIOS settings and 712a by default is set to UDMA2. In windows device manager however, it is set to DMA5.

Installed new IDE cable, no other drives are connected to the same IDE and cable.

Now i am using DVD Encrypter to rip dvd’s, and after setting Speed Read to x16, my drive will only go to x2.8.

So, my guess atm is my 712a drive is screwed up and its time to exchange it for a new one.

If any one has any idea what else i could try, then more then welcome to.

Thanks in Advance.


#6

Windows seeing your Plextor PX-712A as UDMA mode 5? I don’t think that’s possible. It will either detect UDMA mode 2 or a lower mode. Are you sure that you’re looking at the right IDE channel and the right device? Denisimo, start up PlexTools and check if the “SpeedRead DVD” option is enabled. If not, enable it, reboot, check if it’s still enabled, insert a disc, rip it. In your BIOS, don’t force an UDMA mode, but rather select auto detect. Let us know how things go. I don’t think your drive is the problem here so exchanging it won’t solve anything.


#7

I will post screen shots later when i get home from work. I dont use Plextools so ill give that a try as well.

Thanks again.


#8

Ok then. Long week, work kids , wifes, gf’s… :stuck_out_tongue:

Ive tried PlexTools by setting Speed Read DVD and it made no difference. Ive tried Nero Drive Speed, that made no difference. Ive ran Nero CD-DVD Speed and ive got a max of 2.79. Ive installed Plextor from hardware manager and let the windows find it and reinstall it after a reboot.

So, im attaching a screen shot of all my IDE controlers on my mother board.
Primary IDE has 1 HDD. Secondary IDE has the Plextor 712a, and they are both set to UDMA 5 via auto by windows.


#9

Denisimo, obviously you have two ide harddrives (both showing Ultra DMA Mode 5). Your PX-712 is in PIO mode (in Slave?) and that’s why you are experiencing slow read/burn.

I am guessing you have a CDROM in the secondary IDE channel as master and Plextor as slave (in PIO mode) in the same IDE channel.

I would suggest the following:

  • In Device Manager, delete your secondary IDE channel where the PIO mode showing. Reboot.
  • If the problem still exist, move the PX-712A to Master and the other drive to Slave. Dont forget to set the jumpers (Master/Slave) accordingly.

let us know how it goes.


#10

Just to clarify what Zevia said, this is probably your Plextor drive. The drive does not support anything higher than UDMA mode 2 so I think it’s impossible for Windows to detect UDMA mode 5. It’s strange, I agree but it looks to me that your Plextor is set-up as SLAVE device. What is the exact set-up of your system?


#11

Update.

Took the drive out, and had to put a jumper on for DMA mode on the drive. Now its in DMA-2 according to windows. And im able to copy dvd’s at faster rate.

Thanks for all your help again.