712A No Longer Recognised By OS

vbimport

#1

My IDE 712A has been working fine for months. Then it started to have a problem reading discs. It would go real slow, and nothing had changed in my setup. I got by with that for a while because I have a Creative DVD-ROM, but then it started to write slow as well. According to PlexTools Pro it was barely getting read or write speeds of more than 1X.

Well, now it’s at the point where putting a disc in the drive while Explorer is open locks it up and cannot be read. I put the disc in, it goes orange, then solid green, but if you are in Explorer the window locks up and you can’t do anything with it until you end it’s task via Task Manager. If you use a burning program the program locks up when you put a disc in the Plextor, and won’t come back until you’ve taken the disc out.

The drive is correctly recognised in the BIOS.

My setup is WinXP Pro SP2, Asus A7V333 motherboard, Via KT chipset, 768MB ram. The Plextor is the slave on the secondary IDE channel.

I have tried a clean install of XP. I have tried removing the player and letting it be rediscovered. I’ve tried updating the firmware from 1.05 to 1.06 but I get a message that “Update is failed.” I have run the diagnostics and the disc is ejected so it is not reporting a hardware problem.

Can anyone help?


#2

Does it shows Ultra DMA Mode 2 in the Device Manager - IDE ATA?ATAPI Controllers - Secondary IDE Channel - Advanced Settings - Device 1 - Current Transfer Mode?


#3

Any way to put it in another computer and see if the same problems happen? If the problems do not happen in another system, maybe upgrade the firmware, check/replace the cables, update the Via chipset driver. .


#4

Yes, it does have Ultra DMA enabled.