6500A Question for Liggy and Dee

vbimport

#1

Hello Liggy and Dee,
I was wondering if yourselves can help solve a problem. I bought a ND-6500A drive for a Toshiba Notebook, the drive wasn’t recognised by the bios so I flashed the drive from F/W 2.40 back to “Original NEC 6500 firmware 2.23” (using the Win GUI 1.29 version) hoping this would work, it didn’t. I then used the NEC ND6500A Reverse ATA firmware package hoping the Notebook could detect the drive as slave. As this also didn’t work I required to return the drive to its original 2.40 firmware. However when I ran the Normal ATA firmware package, DOS reported ‘Firmware isn’t changed correctly - Drive is Old Boot’ i.e. unit remained in Slave mode. Using Win GUI 1.29, the drive is reported as [_NEC DVD±RW ND-6500A 4.21] I presume this means that F/W 4.21 is on the drive, or am I wrong?. I don’t understand how this can be? ( except inexperience and I’ve flashed the wrong fimware). When I tried to reflash the original 2.40 firmware an ERROR:- Probably mixing up master and slave firmware. Likely to damage the drive, not allowed to continue, ask for personal bin flash build. The following is also displayed I.D. from drive : 85 , I.D. from firmware : 84 , F/W is for a different drive. All work was done on a desktop PC using the recommended IDE adapter. Is there a way to return the drive to its original state? , if not I can still use it in a PC working in Slave mode. Any help is greatly appreciated. Thanks in advance, Howdie (novice).