64bit Windows install STOP 0x7B problem

I picked up a cheap 64bit computer from Gateway that came with 32bit Windows Vista. (BTW, that’s really lame when manufacturers pull that one.) I don’t like Vista, and I want to use 64bit. I cannot get 64bit Windows XP to see the DVD drive. Everything else works.

Windows XP has no problem with the hard drive. I managed to install XP by booting from an external USB DVD drive a custom installation CD with drivers slipstreamed in with nLite. When I try to install from the DVD drive that came with the computer, it begins loading, then BSOD. The XP installed via the USB DVD can’t see the internal DVD drive. Yes the internal DVD drive does work. I also installed Linux on the computer and it can use that DVD drive just fine. Before I disabled it, Windows Vista could use the drive. Also, the install CD does get to the F6 prompt (I don’t use floppy drives anymore, so, not much use). It seems I must have the right drivers, or Windows XP could not read the hard drive, and installing from an external USB DVD would not have worked. The computer is usable, but it would be nice if I could access the DVD drive from Windows XP.

Technical details: Gateway GT5628, motherboard Intel DP35DP, flashed with latest BIOS (version DPP3510J.86A.0507.2008.1202.0024). DVD drive is an Optiarc 7173A, which I have not flashed with anything. BIOS gives 3 options under Advanced -> Drive Configuration->SATA configuration: IDE, RAID, AHCI. If IDE is chosen, then another BIOS item, ATA/IDE mode, has 2 options: Native or Legacy. If RAID or AHCI is chosen, then ATA/IDE mode can only be Native. I have tried all 4 combinations. I use the RAID setting, as both Linux and Windows work with that one. The computer has only 1 hard drive, so I suppose RAID is useless. Within the installed XP, the Device Manager shows: ? Other Devices -> ? Mass Storage Controller. A search for drivers specifically for the Optiarc 7173A only turns up firmware updates, no drivers. I have not tried a 32bit Windows XP, but I’m betting that would work. What magic driver or other piece am I missing?

The error message:

A problem has been detected and Windows has been shut down to prevent damage to your computer.

*** STOP: 0x0000007B (0xFFFFFADFADA323C0,0xFFFFFFFFC0000034, 0x0000000000000000,0x0000000000000000)

Hi, welcome to the forum :slight_smile:

When the system was installed did you try going into the device manager and telling it to update the driver for the drive?

Also what bios do you have? if you got it from gateway it might not be the latest. 0517 is available from Intel, I don’t know if you can flash it without a problem but I would try.

Thanks for the welcome.

I have tried many things. Tried many different driver files. Tried letting it check MS for drivers. Tried updating the driver. Tried deleting the device and letting the new hardware wizard find it again.

All I managed to do was screw up the audio drivers. They were working. Now they can’t be reinstalled. Some registry problem I suppose.

I thought I had the latest BIOS, but you pointed me to a later version. I put 0517 on. Thanks. But, didn’t help. I think the answer may be that there is a bug. About the only thing I haven’t tried is updating whatever firmware is on the DVD drive. That’s a little difficult if Windows can’t even see it. Should be a way to update the DVD firmware through Linux or DOS.

You have most likely a corrupted CD/DVD/Image or a hardware failure of some kind.
Try running memtest86 for like 12 hours to start with and why do you want XP 64-bit?

I think it has to do with the DVD burner, nothing might fix this, but definitly put the latest firmware on the burner and try again. Install the drive in another PC if you have to.

Latest firmware, modified, by the all-mighty Liggy and Dee :slight_smile:

Having some troubles putting firmware on. Windows won’t do it because it can’t even see the drive. I tried, using safe mode as instructed. The flash software says it can’t find anything. Then I tried it in Linux, and that didn’t work either. I’ll try it in DOS next, soon as I’ve burned a suitable FreeDOS disk.

As to the possibility of a corrupted CD, I tried that CD on another 64bit computer. Made it to the text installation menu without any problem. That’s further than it got on the Gateway. I’ve burned many variations many times, on 2 different discs. They always crash at the same spot with that STOP 0x7B error.

Linux Necflash finds the drive, and it reads the original firmware (version 1.03 btw). But necflash -flash just crashes. Prints the 2nd question, “are you sure you want to proceed?” and then exits without waiting for an answer. I ran necflash as root, with strace and got this:

write(1, “Vendor: Optiarc
”, 17Vendor: Optiarc
) = 17
write(1, "Identification: DVD RW AD-7173A "…, 33Identification: DVD RW AD-7173A
) = 33
write(1, "Version: 1-M1

Remember no one c"…, 80Version: 1-M1

Remember no one can be held responsible for any kind of failure!
) = 80
_llseek(0, -1, 0xffe07fb0, SEEK_CUR) = -1 ESPIPE (Illegal seek)
write(1, “Are you sure you want to proceed”…, 40Are you sure you want to proceed? (y/n)
) = 40
munmap(0xf7d46000, 1839104) = 0
exit_group(0) = ?


Last thing to try is to PM Liggy or Dee and ask if there is some kamakazie flash method that can do the flashing in one step or something, maybe force flash it in dos or something.

Or maybe just some ACPI kind of problem. Is the HPET timer set to 64bit in BIOS? Is the MPS version configurable in BIOS? Set to latest available (“1.4” I guess).

More fun today. I put the Optiarc in my ancient 350 MHz Pentium II. Works fine there. My FreeDOS CD would boot and read the CD. On the Gateway, FreeDOS would boot, then give an error about the CD driver not loading. Could use FreeDOS, just not the CD. I still have DOS 6.20 and Windows 3.1 on that machine. And Linux. I still could not flash the drive. The LD7173 program says it won’t run in DOS mode. And in Linux, the necflash program behaved identically to the way it did on the Gateway.

Meanwhile, I put a Samsung SW-216 CDRW drive in the Gateway. The Gateway would not even get to the BIOS setup screen with that drive plugged in. I’d see the text from the video card, then just a flashing underscore in the upper left. Powered off and unplugged that drive, and then I got the usual “press F2 to enter setup” and “The AA number has not been programmed on the system. Press the Enter key to continue”. That 2nd message started happening after I flashed the motherboard with Intel’s BIOS, and I haven’t been able to go back to Gateway’s BIOS.

I found an HPET setting in the BIOS. It was set to Disable. The only other choice is Enable. The HPET settings made no mention of 64bits. I didn’t find any MPS configuration.

My guess is a problem in the BIOS or the Windows driver or both. Both drives worked fine in the Pentium II. The Samsung powered up and would open and close the tray on pressing the button, but the Gateway’s BIOS would hang with that drive connected. The Optiarc worked everywhere except for under 64bit Windows on the Gateway. Would AHCI screw things up? I noted that the DVD drive uses standard IDE cables. It seems AHCI should be moot for the DVD drive because it’s all IDE, but if not, I would guess the Samsung doesn’t support AHCI.

I installed 32bit Windows 2000 on the Pentium II, using the Optiarc drive, solely so I could flash it. I flashed the drive with the nice region free code from here (version 1m1). The install and flash all worked. I moved the Optiarc back to the Gateway. The Gateway hangs a little longer on that cursor in the upper left but otherwise the behavior is the same as before. No problem using the drive under Linux. And still can’t boot the 64bit Windows installation CD, or see the drive from Windows.

The Wikipedia page on AHCI had links to information about problems very similar to what I’m experiencing. It’s like Windows can’t do both IDE and SATA. The hard drive is SATA, the DVD drive is IDE. So I tried picking the IDE driver for the unknown Mass Storage Device. And that got somewhere. It found some IDE devices. But Windows still can’t see the drive.

After much pain, I got the audio to work again under 64bit Windows. This time, I went with 64bit Windows Server 2003 with SP2 and the Intel disk drivers slipstreamed in. (The pain involved totally wiping the hard drive and installing Windows and Linux again and again.) Windows still can’t see the internal DVD-RW. Linux has never had a problem with the audio or the DVD, or any other hardware.

Audio did not work in Windows with the motherboard BIOS update from Intel. I tried many times to flash the BIOS with the latest from Gateway rather than Intel. It would warn me that the current version was newer, and I’d tell it to flash anyway. Then the flash would fail, and I’d still have the Intel BIOS. If I flashed a newer BIOS from Intel, that succeeded. Finally, an attempt with this one from Gateway worked: http://support.gateway.com/support/drivers/getFile.asp?id=21978&dscr=Intel(r)%20(Schroeder%20Town)%20G33%20Motherboard%20BIOS%20Update%20Version%20DPP3510J.15A.0316

And just like that, audio worked in Windows. And, as a bonus, the BIOS no longer stops with this message: “The AA number has not been programmed on the system. Press enter to continue”.

I’m giving up on using the Optiarc DVD-RW in Windows. Maybe some new drivers that fix this problem will be released before this computer or disk media become obsolete.