5.25" Drive Enclosures & USB 3.0

Good evening,

I don’t know what I’m doing wrong but maybe someone can help me.

I use a Notebook together with an 5.25" Drive Enclosure to rip UHD Blu-rays to my Notebook. In the past, I used a Drive Enclosure from Delock, now from RaidSonic (Icy Box).

The ripping process is fine as usual but the curious thing is, both Enclosures only works properly when I connect them via USB 2.0, although they both support USB 3.0.

To get faster ripping Speeds isn’t the problem for me, USB 2.0 Speed is fine for me. First I always thought this is a driver issue but this can’t be the solution.

I bought a new Notebook, which has USB 3.0 only now (the other one has 3x USB 2.0 and 1x USB 3.0), but there are the same issues. When you connect it to USB 3.0, the Drive gets recognized, but then it disappears, then 10 seconds later it returns - sometimes even twice oO - and another 10 seconds later, it disapears again, which leads to the problem that on my new Notebook, I can’t rip any Discs at all!

I know it’s difficult to explain but has someone similar experiences with those Enclosures?

Thanks in Advance.

Best Regards
Ravenhearst

Could you post a link to the exact model of enclosure that you are using?

My “gut” first reaction to this is that the USB3 portion of the cable is bad. Have you tried a different one?

Thanks, but I doubt that both included cables where faulty at the same time:

Both Devices also use special USB cables where on one end which goes to the device doesn’t look like a typical USB slot. So you can‘t just use another standard USB cable like when you charge your phone etc.

For me it´s the Standard USB3.0 which I have also at my HDD-Docking-tations from Sharkoon and deleyCON.

https://de.sharkoon.com/product/11797#gallery

OK - didn’t realize this affected two different external drives (and two different notebook PC’s?).

I’m fishing here now, but - some other insights from other “USB 2 but not USB 3” situations which might help.

I’m presuming these computers are running Windows 10. If so, some issues affecting USB 3.x exclusively relate to a buggy Windows UASP driver (uaspstor.sys) and/or incompatability between that driver and the SATA-to-USB bridge chipset in the enclosure. If you check the Windows Event Viewer during the times that the drives disappear, you may see entries that say “device reset” which would confirm this.

  • Are these enclosures identified by Windows as “mass storage device” or as “USB attached SCSI device”?
  • What specific build of Windows 10 are these computers running?

Hello again,

yes my plug looks the same like that one from Sharkoon, on both Enclosures.

Yes it also affects both my Notebooks and the reason why I post this now is because I would like to use the Enclosure on my Notebook, which hasn’t any USB 2.0 Slot anymore.

I will try to check this Event Viewer later. Yes I run the newest Milestone from Windows 10. How do I check if it is identifed as a mass storage or SCSI?

Thanks for your help.

Regards

Should be listed in Device Manager under device properties:

image

or else identified as the target when you click on “safely remove” if Windows sees it as removeable (usually not for optical drives)

OK now it seems I was able to kill it completely.

On my First Notebook, it’s getting recognized as a „USB Mass Storage Device“ and it still works fine. My first Notebook is the one with 3x USB 2.0 Slots and 1x USB 3.0 Slot.

I don’t know why and this happened never before but from nowhere, the Drive disappeared even faster now when I tried to test it again. But this time for some reason Windows decided to recognize it as a „SCSI Storage Device“ but there was no access to the drive itself from the Explorer. I decided to delete the driver and now Windows doesn’t do anything when I plug it in USB 3.0, only USB 2.0 gets recognized now.

Sorry for making things such complicated, later I will test if it will still get recognized on my 2nd Notebook which has USB 3.1 only. Can someone explain me please where I look exactly at Errors on the Event Manager?

Thanks in Advance!

Best Regards
Ravenhearst

Just to understand your “deleting the driver” - did you delete the file usaspstor.sys? If yes - that is not a good idea - and it is no surprise that the device would not be recognized at all, as that is the driver assigned to it in the registry.

The commonly circulated solution to UASP problems in Windows 10 is to have two copies of the mass storage driver. Usually this must be done in safe mode, or by CD/USB boot of another OS so you are operating outside of the installed Windows system.

Then create a second copy of the mass storage driver usbstor sys, and rename that second copy to uaspstor.sys. This forces Windows to use the mass storage driver for UASP devices as, in effect, usbstor.sys is used for both mass storage and SCSI devices.

This is best accomplished in from an elevated command prompt:

cd \windows\system32\drivers
rename uaspstor.sys uaspstor.old (of course you can’t do this if already deleted)
copy usbstor.sys uaspstor.sys


As for looking for the hardware event:

Launch event viewer from the Windows Administrative Tools folder in the Start menu.
In the left column is a folder called “Event Viewer (Local)”.
Underneath that, open Windows Logs --> System.
After some processing, a window containing event entries will populate the middle column.
Scroll down to the time of the drive disconnect, and double clock on that line.
A separate window will open giving the details of the event.

I think it had another Name but can’t remember exactly anymore (something with “USB” ???) and to be honest, I don’t care anymore for my old notebook at least since it still works on USB 2.0.

I looked at the hardware event but I can’t find any useful information. I get some errors about the “PCI Express Root Port” but this happens even when my enclosure isn’t connected at all so I highly doubt that this is the reason.

I wonder if I will buy a new Enclosure for the third time will fix my problem but I’m open for new suggestions. Price doesn’t matter. Otherwise I hope my old Notebook still with USB 2.0 won’t die so quick.

Regards
Ravenhearst

Some suggestions, but I can´t guarantee if it works for your config. My experience with USB3.0 is not the best, I tried many solutions since USB3.0 is available. I´ve had/have many problems with different USB3.0-chips, USB3.0 external enclosures. Some combinations don´t work.

USB3.0-hub between Notebook and Enclosure

external drive adapter like this

A HDD-docking-station with USB3.0-Hub:

https://geizhals.de/lc-power-lc-dock-u3-hub-dockingstation-a1927977.html?hloc=de

Here you have also the possibility to use a adapter-cable to use the SATA-connectors of the Station itself

Or if you don´t care about the speed, buy a cheap USB2.0-Hub to adapt the 3.0 from the Notebook to a 2.0, could also help

Ok thanks but now I’m curious. What kind of problems you experienced? Those were also problems when you connected an external Drive to your PC/Notebook?

When I go for your first link, do you think it shouldn’t be any problem that the Drive will do it’s job without any “housing” like in a normal PC or inside a Enclosure like I used?

Regards
Ravenhearst

Especially with the 1st generations of USB3.0 I had some HDD-dockingstations, some external HDD/SSD-enclosures which worked only as 2.0. If I try to use 3.0 after some minutes data rate rate decreases to zero, but some minutes ago the datatransfer already stopped.

If I connect to 2.0 it works stable

I also had disconnections with some hardware-combinations.

My external enclosure with a LG BU40N works not on some ports on my Asrock Z270 Pro4, but on other ports of the same mainboard it works.

Some enclosures like my Thermaltake Muse 5 often works only as a 2.0 on a 3.0 connector

On one of my Notebooks a USB2.0-hub gets not recognized at 3.0-connectors.

The list of problems is big, but I guess not everyone have so much different hardware as me.

I think I have almost all USB3.0-chips which are on the market, like in external enclosures or USB3.0-cards with Chips from NEC, Texas Instruments, Marvell, ASMedia.

But overall I can say, the newer generations (Chipsets of Mainboards, Notebooks) works faster and more reliable like in my older mainboards with Z77-chipsets

About your drive: Depends on the rpm/speeds you use and how big are the vibrations. I used drives without housing at low speed and did an object like a 50pcs-cakebox on it to make it heavier and more stable

On the other hand, you can let your enclosure open and try some of the alternatives. If one works for you, you can maybe dissasemble the backplate of you enclosure and use it with the working cable/adapter.

So at least it seems I’m not alone. But still don’t know what I’m doing wrong.

I think I will try it with your first link but if this won’t work again, then maybe I will buy one of those Drives inside a Enclosure, which are manufactured from an manufacturer itself, like those from Asus. Or maybe I will buy a UHD official Drive for my Notebook like the LG BU40N. Luckily I bought in 2019 the last Notebook which still supports an Optical dIsc Drive which I could replace with an UHD one.

Thanks to everyone for your help.