486S Firmware

I screwed up my 486S CDROM in my Dell. Does anyone have the bin file for the YS0N firmware??? or does anybody know how to convert the EXE firmware into binary format. I’ve looked all over and can’t find it. I’ve also already tried the new and old versions of litefirm and neither one worked. Any help would be greatly appreciated!!

Rob

Tried this yet?

Tried flashfix and that didn’t work either. It said that it “couldn’t find bytes to patch.” It’s looking like I’m screwed. If there’s anyone out there with a 486S or 526S CDROM, could they please extract the .bin file(s) out? PLEASE help me out. Thanks in advance.

Rob

Make a search here:
http://dhc014.rpc1.org/indexOEM.htm

Well, I found an older fw version (YS0J) in binary format. Used mtkflash in dos mode and it said that it updated it, but the green light still stays on all the time. Does somebody know why this is happening? Thanks.

Rob

I noticed that the YS0J f/w was only 64k after extracting it with litefirm when it should have been 128k. Finally, after hours and hours of searching, I found the YS0J f/w in binary format that was 128k. Used mtkflash and it worked & then I updated to the YS0N f/w using the official f/w from Liteon. Thanks for all the help and suggestions.

Rob

Do you have the firmware in bin file?YSON?I can’t find it anyhow.

Could you send me a copy,thanks!

                                                                         inmotion

The firmware should be 64kb. Anything larger than that has excess data.

Here’s YS0J from the 526S updater, but it should work for the 486S as well.

http://dhc014.rpc1.org/DEADLINK/526S_YS0Jb.ZIP

I used litefirm to save my firmware,it’s about 12XKB though.YUS3

I tried MTK to flash with 526S’s bin file,but it wound’nt let me.

I guess I need the 128k file,does anyone have it?THANKS.

YSON binfile for 486S

                                                                 inmotion

inmotionhome@hotmail.com

You do not need a 128kb file. Litefirm does not properly handle CD-ROM firmwares. They are only 64kb, NOT 128kb. You may be using mtkflash incorrectly.

I type mtkflash 3 w /b YS0J.bin

in dos mode.

But it seems to have errror always.

I used mtkwinflash under windows,and it worked.After I flashed to the

F/W you provide,I used the official YSON.exe updated.Now it can read

the cd-r it couldn’t before,nice :slight_smile: Thanks for your help.

I wrote to lite-on,and the reply is under:

您好:

  關於您詢問的問題,建議您詢問原來的製造商IBM,因為搭配他們的系統,

或許有不同或特殊的相關設定。

====================================================
Customer Service Dept.
Lite-On IT Corp. www.liteonit.com
Email : odd_service@liteonit.com


It told me to contact IBM,what the…#@$@