451 -> 851 -> 451 = dead recorder

vbimport

#1

I've tried to reflash the thing more times (MTKFLASH 3 W 451.BIN - the flash I saved before I flashed to 851) but it does not work.

Should I throw it away ?


#2

Hm,

If you use a bin file, then you must use the /B option for mtkflash.

And please, describe more precisely your error, because when something goes work the effect is always that it doesn’t work !!

Fredsky


#3

The DVD recorder isn’t detected at startup (BIOS) anymore. As far as I know you can’t use /B with the latest mtkflash (1.80.1), beacuse it uses the binary format by default, or am I wrong ?


#4

What exactly happens when you try to flash your firmware ??

If I were you, I’d try to flash it with /B option. I’ve used one of the latest version of Mtkflash (1.81 I think) and it requested /B option with my bin file.

BUT if you saved your firmware with mtkflash without setting /B but telling it that the name of the target file is a .bin, then you have an Hex file which name is .bin. I would check the size of the file. If it’s bigger than 1 MB, then you certainely have an hex file.

And again, try to be more precise. It’s not funny to always ask what exactly users did, because they don’t take the time to read forum rules !

Fredsky


#5

When I flash (in DOS) the firmware (mtkflash 3 w 451.rom) the program just flashes the rom (0…100% -> no errors, etc) and tells me to reboot my computer, but when I reboot no drive is detected.

The only strange thing is when I flash it, I think the DVD led should light (red, green ?) but it only does once after I reboot.

I’ve tried mtkflash 3 w /b 451.rom but I get an error (file not found -----> it tries to open /b)

I’m almost sure file is binary (~45-65Kb size (I dont have the file here, at this moment), if I open it in a viewer I can read LITEON on the end of the file).

I’ve downloaded mtkflash is from dhc014.rpc1.org/mtkflash.htm


#6

Ok I see your prob.

Did you use the /M switch when you saved your firmware ? I think that you have not. In fact the firmware size should be between 700 kB and 1MB. 65kB is way too little. It means that you saved only one 64kB bank out of 16.

The solution : Try to find a .bin version of your firmware from Internet, it should be pretty easy.

Fredsky


#7

Nope I didn’t use the /M switch. :frowning: :frowning: :frowning:

Anyone know where to find a .BIN file for a LDW451S ?


#8

Or please send me a e-mail with the LDW451S (.BIN) file to rkbtwo@hotmail.com


#9

Hmmm, a “LDW451S (.BIN)” file…:rolleyes:

Sent GSB6…:smiley:

BTW, you will find the .EXE-file here:
http://www.liteonit.com.tw/ODD/english/english-down-f.asp?show=1


#10

Thank you very much ! :bow: :bow: :bow:


#11

And now the big question… Does your drive is working again