4164B burning at 1.5X, supposed to be 16X

Hey Guys…I purchased a new DELL E510 PC, It has DVD±RW drive in it…
Same brand as the one mentioned by OP…HL-DT-ST DVD±RW GWA4164B.
It was burning at 15-16X when I removed the system out of box. I reinstalled the OS. Now when I burn movies it is burning at 1.5X max. I am using Vermatim DVD+R 16X media. The movie that was supposed to take 6 mins is taking 45 mins now. Are there any drivers or anything that I need to check/update…Please help…

This sounds like a classic DMA problem. In device manager, look under IDE ATA/ATAPI controllers and click either Primary or Secondary IDE Channel, depending on which one your writer is connected to. Then examine the “Advanced Settings” tab, and check the Current Transfer Mode. It should be “Ultra DMA” or UDMA2 or something similar. If it says PIO, change the transfer mode part to “DMA if available”.

Note : the window and tab names I’ve give may not be exactly the same for you - it varies depending on the chipset used in your motherboard.

The system will probably reboot if you make changes. When it comes back up again, go back into the same place and check that the settings now say “Ultra DMA” or UDMA2 or something similar.

The only thing you have to do is to enable DMA!

I answered to your exact same post in another thread…

kingno1, welcome to cdfreaks but please read our forum rules. Crossposting (posting the same thing more than once) is not allowed on this forum. Multi posts just create more work for our members who may provide the same answer that has already been made in the other thread. Also by keeping it in one thread the question and all possible solutions are keep together. :wink: Your other post has been deleted. Please read out rules before posting further.

Thanks Guys for the input, I see DMA at all the settings. PIO is not selected anywhere…
Here is what I see under Device Manager.
There are 2 Primary IDE channels and 1 Secondary IDE Channel.
Here are the settings

Primary IDE Channel
Device 0
Transfer Mode - DMA if Available
Current Transfer Mode - Ultra DMA Mode 5
Device 1
Transfer Mode - DMA if Available
Current Transfer Mode - Not Applicable

Primary IDE Channel
Device 0
Transfer Mode - DMA if Available
Current Transfer Mode - Ultra DMA Mode 2
Device 1
Transfer Mode - DMA if Available
Current Transfer Mode - Not Applicable

Secondary IDE Channel
Device 0
Transfer Mode - DMA if Available
Current Transfer Mode - Not Applicable
Device 1
Transfer Mode - DMA if Available
Current Transfer Mode - Not Applicable

Try setting the drive either to slave on the same port or put the drive on another channel (ie secondary)
Might be a conflict here both being on Primary IDE channel.

Remove the drive and IDE drives from the hardware settings.

Just recently, for no apparent reason my settings were changed from DMA to PIO for the LG drive (weird).
I manually set it to DMA again, rebooted, UDMA mode 2 showed up, but still slow writing and reading.

Only after removing the IDE drivers and having XP install them again automatically, things were right again.

Hi, Can you please tell me how to do this?

Is it from the DEVICE MANAGER --> Select the Primary/Secondary IDE Channel and Uninstall? How do I install it back?

By rebooting it will install automatically.

Thanks. I will do it tonight. Should I do it for 2 Primary and 1 secondary drive (all the three)? I am not sure what each one is for.

Thanks rbroer, for the tip…I uninstalled and rebooted the system. After that, I burned the 4.5 GB movie in 5 mins…Back to where I wanted…
Thanks to alll you guys for the valuable input…
cheers.