411S Firmware will not complete

Yes, another one. I will give all the details up front in order to help make the time given to me as useful as possible.

Problem: I get the Error window that says “No drivers detected” message. As soon as you click OK, the entire flash program closes. The underlaying utility “found drivers” window is empty. the 411s shows up in both the boot up and in Device Manager. I have not burned anything yet but it does play a CD.

I have a stand alone Win98Se, 1GHz P-3, 512ram, ASus Mobo ATA 133. My current IDE config is:

Primary (80 pin) Master, 80Gb HDD
Primary Slave, Zip 100
Secondary Master (40 pin), 411s
Secondary Slave, LiteOn CDrw
Note on mobo: I think that just the Primary IDE can do the 80 pin thing (blue connector).

Additional PCI IDE controller card/ATA 133- Second HDD- 40Gb for video use (will soon be changed to 120Gb)

I have tried to:

  1. uncheck DMA on both LiteOns
  2. disconnect the ribbon connector from LiteOn CDrw, 40GB HDD.
    note: tried to disconnect Zip but computer would not boot up!!
  3. run in Dos mode (said that it was a bad command and file could not be found- even though it was there).
  4. redownloaded 3x to be sure that the file was OK.
  5. ran exe file from different partitions and folders including c root and desktop.

What should I do now?? Thanks,

LarryB

Welcome to forum LarryB.

You can not run the firmwarefile FS0F.exe in DOS.
(Lite-On homepage says: in “windows”!)

To upgrade in DOS you need:
-a dos diskette
-Mktflash (“firmwareloader”) /http://dhc014.rpc1.org/
-FS0F .BIN-file /http://baazee1.web1000.com/fs0f.zip

And rule #1 is:
If you don’t have a problem, then DON’T FLASH YOUR DRIVE.

BTW, never heard of 80-pin IDE connector… but I might be wrong…

Hi Pinto2,

Thanks for the welcome!

The LiteOn firmware page seems to give you the option of installing it in Dos or Windows with instructions for both. Both had same result. See:

http://www.liteonit.com/ODD/english/english-load-how.htm

I have read that he 80 pin ribbon connector (I believe) is required for enabling Ultra DMA and I have read that the 411s either requires or benefits from this spec. Thanks

OK I se; IDE 40-pin 80 conductors


Originally posted by LarryB
[B]The LiteOn firmware page seems to give you the option of installing it in Dos or Windows with instructions for both. Both had same result.

Yes, but they only provide the Windows Flasher for download from their website. They might send you the DOS version if you emailed them requesting it.

I am having a heck of a time contacting LiteOn about the DOS firmware. None of their emails work (undeliverable) including a Report Problem link on their forum page. This is not an OEM drive so they should be accessible. I’ll try a couple of phone numbers next.

Larry are you running alchahol or daemon tools and using virtual drives if so disable them as i had same problem as you are discribing and this solved it. i think flash prog is looking at 1st 2 cd/dvd drives only and if niether are liteon 411s then it gives error

Hi KH (as in Wuntzin4Hall?),

Thanks for the ideas. I don’t run any of those things.

Virtual drives…hmmm. I do have my primary HDD split into numerous partitions but I don’t know if that is what you mean. Windows and all OS stuff is on c: and I have tried to open the exe file from c: root already. In case you think that there may be input conflicts with the utility…

I have the following inputs:
on IDE I have the Primary HDD/ Zip100, Secondary 411s/LiteOn DVD-rom.

Additional IDE card: Secondary HDD

USB 1.0: Lexar Jumpshot (Compact Flash reader- empty), Phono amp interface (unused)

USB 2.0: Printer, Scanner

I have disconnected the Primary slave (from the CMOS menu), the Secondary HDD ribbon, the LiteOn DVD-rom ribbon to no benefit.

I have tried it in Safe Mode, too and same result. Not finding the drivers in Safe Mode makes me wonder that it must be pretty basic. Does it have something to do with where the flash utility looks for the driver ID’s??

No hurry -LarryB-. Take your time…

I tryed to help you some posts earlyer, but maybe we need a short guide here.
[And “someone” pls correct me if I go wrong.!]

To upgrade in DOS you need:
-a dos diskette
-Mtkflash (“firmwareloader”)here: http://dhc014.rpc1.org/
-FS0F .BIN-file here: http://baazee1.web1000.com/fs0f.zip

  1. Make a boot diskette:
    Take a fresh A: diskette and put in your A: drive.
    Go to control panel -->add/remove programs–>there you will find an tab with the option to make an w9x boot floppy. Make one.

  2. Download MtkFlash and .bin-file from links obove.
    UnRAR o UnZip (both) to a new A: diskette (mark it nr.2)

  3. Shut down your PC and switch of the power.
    Disconnect (power-and IDE-cable) from all drives except HDD and 411S. (411 is on Sec.IDE as master, at the end of your “80 cond.” ribbon cable, OK.)

  4. Put your startdiskette in A:. Power on and restart your PC.
    When PC starts up you will have to chose 1… 2… 3. You can start “without CD support”. Hit “enter”.
    When you get the A:\promt at the end, type “C:” (without quotes)

  5. Remove the bootdiskette and put your disk nr.2 (with the new firmware) into A:.
    If your 411 is connected to Sec.IDE as master, than you can use command as follow:

A:\MTKFLASH 3 W /B FS0F.BIN

(“space” betwen MTKFLSH and 3, W, /B and FS0F.BIN !)
Hit “enter”
If everything is OK, then the firmware should be loading now and the lead on 411 should blink.
[And now… SAP (“sit and pray” /joke…)]
The upgrade can take several minutes.
When the lead stops blinking and you got a message on the screan (sorry, dont know what it will tell you), you are done!

  1. Remove the diskette from A: and restart with “Ctrl+Alt+Del”, to check if upgrade is succesfull. (Use Nero Info Tool, or check in devicemanager)
    If succesfull, Shut down, power of, reconect the other drives again,…aso.

#Long time since I used Win9X and DOS, so I am not sure of all commands.
Use this at your own risk. No warranty!

#Credit to all “Club CD Freaks” members here:
http://club.cdfreaks.com/showthread.php?s=&threadid=42502

Larry try disabling zip drive as liteon flash may be taking this as a optical drive.

Did you have trouble flashing fs0b firmware?

Hi KH,

The 411s is new so I was never exposed to the FS0B firmware. It came with FS0B actually.

Regarding the zip drive, if I unplug it (power and/or ribbon), the computer will not boot up as the HDD (primary IDE Master) is not detected either. I have them jumpered correctly so I don’t get that at all (and I pray that the zip never dies on me). I instead disabled the primary slave (Zip) in the BIOS and that worked but had no effect on the FSOF’s installation. Thx

And Pinto2, thanks for that treatise on Dos mode firmware installs. Whoa… I will need the time for sure!

Larry,I had the same problem with installing fsof on my xp pro computer,luckily I have another xp home computer so I slipped the 411s into that one…it installed fsof…no problem,…I put the 411s back into the pro and everything is working as it should.
Perhaps you can borrow a bit of time on a friends computer.
Anyway for what its worth…hope this helps

I finally got a DOS firmware file from Liteon today. I ran it from a c: prompt from a boot up disk and I got the message “program too big to fit in memory”. OK, great, another road block. So, does anyone know what ~this~ is all about?? Thx

Next they are going to email me an FS0B windows firmware file and I will try that. I have heard that re-doing FS0B can help.

Strange…, It looks like your .BIN-file dont fit in DOS memory of 1MB.
Ooooh yes, the file is 1,048576MB…:o

OK, skip the floppy to boot in DOS. In Win 98 you can reboot and hold down Ctrl or F8 to reach DOS (if I remember right).
Then choose : MS-DOS-PROMPT [ONLY IN SAFE MODE], usually the last option.

This way no drivers or anything is loaded and you can carry on safe with loading firmware from floppy as described before.

Give it a try! :smiley:

You know, I tried to run the Dos version that way and it would not work. HOWEVER!!!..

Yes, the deed is done (I did two, actually, but #2 comes
later). I was going to go the mktflsh route but I finally talked
to LiteOn about the “program too big…” and he said to go to
www.bootdisk.com and download the W98SE OEM boot disk file. The OEM one is leaner and wood leave more memory for the DOS firmware… and it did!! Wow, it was so weird actually “seeing” the utlity in action…definately surreal. So, it need be said that you guys have been selfless and incredible. I hope someone else keeps more hair than I did going through this process. Thank you.

Oh yes, #2. Somewhere along the 30 or so flashing attempts that I made, I flashed my dvd-rom instead and I think it is now dead. Luckily I have the cd-rw that the dvd-r replaced. Is there a protocol for trying to bring this drive back from the beyond? When it first happened, the flash went 1/2 way through and stopped due to some error, the drawer popped out like the tongue of a dead cow and it would not go in!! Man, it was sad. I rebooted and prayed (for naught). The drawer stayed in but the lead light was now on constantly and the drive does not exist in the eyes of DOS or W98SE. How dead is it??

Here I am, pleading for your help again. Of course, there may not be much to say on this issue.

Oh, I now have the Win and DOS versions of FS0F and FS0B.

Thanks!!! LarryB

Used mtkflash and that revived the DVD-Rom!

Congratulation…:slight_smile: :smiley: :cool:

You have done a great job.
And all of us learned a lot.:bigsmile: