411-s drive not responding after firmware update

vbimport

#1

Wow, so much information. I’ve read for about 3 hours and decided that my firmware (fs05) was horrible as my new pack of dvd-r’s (previously used +r perfectly) was going to waste. I tried changing firmware to fs0f. Inisitially, I used the windows frontend for mtkflash, but came up with error of some sort.

I then booted into dos and did it the same way.

mtkflash 4 w /m fs0f.bin (do caps matter?)

I didn’t use a /b because my mtkflash is 1.8.0.1, and was instructed not to.

It said, erasing drive info (or something like that). Unable to load .bin. And since, my drive is useless. So, I guess my question is: how do I fix this, if I can?


#2

dl the omnipatcher, dl the latest firmware, patch the firmware, dl the liteon windows flashing utility. Flash your drive with the patched firmware.

If the utility can’t see ur drive, then dl forceaspi, use killaspi and then try the util again.


#3

MtkWinFlash probably disabled all your devices. To fix this, go into the Windows device manager and uninstall your optical drive(s) and reboot. This should allow Windows to redetect and reinstall the drives.


#4

Hmmm, thanks for the quick input. Tried both.

Dl the omnipatcher
Grabbed fs0j.bin
Patched it.
Renamed it patched.bin in the C: dir
Also mtkflash is in the c: dir
(how do i change folders?, I thought it was cd c:)
d/l forceaspi, used killaspi
Booted into dos
gives me first error
A: drive not responding Abort Retry Fail?
Selected abort
Typed at the a: prompt “c:” without the quotations
typed mtkflash 4 w /b /m patched.bin
Gives the message 1.80.1 created by _________
ERR: Unable to open file
Hangs anytime I try to make windows recognize it (startup screen or add new hardware)

Also: went to device manager and uninstall 2 drives, one the combo drive that came with the system and 2 a generic drive which kind of confuses me.


#5

Put the drive at Secondary Master and try 1.80.0… worked for me last week. You can find a good Win98 bootdisk here. It won’t matter if you’re running 95/98/2k/XP. You’re only working with the CD-Rom drive and the floppy. The only thing to note on this is that it’s best to run the flash programs from the floppy drive. It’s possible that when you use the 98 bootdisk, you won’t see your hard drives if they use NTFS partitions.

If you have to change drives in DOS, you have to do this

A: (Press Enter here)
Then type your command. I always had the experience where if there’s more than one file in the same location you’re trying to run the program from, it’ll only run the file and expect the rest from the path you’re on (i.e. C:>A:\flash.exe (etc) ). Also, before running into “Data errors” on floppies, do a complete format on a floppy before transfering files to a disk. Don’t do a quick one. It’s also safe to switch floppies from boot disk to data disk in DOS mode once everything has loaded. Try this command after:

mtkflash 3 w /m /b patched.bin


#6

I think u miss something.
The flash can be done in windows.
Use LtnFlash to flash your drive. Killaspi will simply kill the aspilayer and let the LtnFlash use the other layer and detect your drive.
It’s really piece of cake to do it. Just disable your antivirus(if you have one). and then reboot.
Use the exe firmaware. You only have to select it.

But by the way what is your OS ?
w95 (forget)
w98 se (think about to change cause they do not support it and so the program is not the best with the new hardware)
Millenium (quite the same.) i have a copy installed on my pc to be abble to recover from xp crash…
XP
if you don’t have the sp1, apply it.
never format all your drives in ntfs otherwise you will not be abble to see the drive, unless u use gdisk (it’s like fdisk but can work with ntfs. you can find gdisk with norton ghost)
don’t forget too that dos mode under xp is not dos mode, it’s a fake.

If you have still a problem with your drive, open ur case, deconnect all the cable, and reconnect it firmly, shake your case to see if everything is correctly installed. Verify your power supply. A leak in power supply can give problem with the drives cause they are not primary in the distribution of power within the computer…


#7

Hey, okay will try it again. Sorry I’m such a newbie. The forums I frequented have all these uninformed people who keep asking the same dumb questions over and over. I think that’s I’m the uninformed one in this forum.

Also, I’m running XP with Sp1.

“don’t forget too that dos mode under xp is not dos mode, it’s a fake.”

What does that mean? I don’t think that that applies to me, I booted into dos using a boot cd.

I’m gonna look for ltnflash now.

Everyone who responded, everyone who took time to read this, thank you.


#8

if u use a boot disk, ok you are in the “real dos”. If you switch to a dos session by using the shortcut in winxp, you are using a fake dos and so you could damage your material (of course the burner seems to accept easily firmware change again and again) but if u do the same with a motherboard, you can kill it…

For xp, u only have to dl the firmware exe from liteone and run it. If it doesn’t recognize your drive, use then the killaspi (only), then restart it. The program should find your burner then.
If you want bitsetting, rpc, readhack etc, then dl the omnipatcher. Start it select the firmware exe that u dl from liteone, select the hack that u want apply then save the new created exe.
After that the same process apply. Stop your antivirus and remove any cd/dvd from your drive. Start the exe and follow instructions.
and voilà everything would be ok then.


#9

I had a dead drive also and I was able to get it to work by using the /m option of mtkflash and also using the downloaded boot image.


#10

Most of the people here would definitely recommend using Lite-On Flash Tool to flash/backup your firmware. One of the threads in this forum has the link for it.


#11

But the Windows tools can’t be used to recover a dead drive. Only MtkFlash can.

My recommendation is to go to dhc014’s site (http://dhc014.rpc1.org/) and use his little build-your-own-MtkFlash-command tool to make sure that the flash is being executed correctly.


#12

codeboy,

Sorry about my little mistake. Forgot that it doesn’t work on a dead drive. I wanted to recommend to tygloalex to switch to using Lite-On Flash Tool instead of Mtkflash as, IMHO, a good utility.


#13

There’s a reason MtkWinFlash isn’t in the Tools collection. The LiteOn flash tool can be used in Windows and works with more drives then MtkWinFlash (which doesn’t work at all on DVD burners).


#14

GOD! :bow: :bow: Why did you do that ??? If you’ve had FS05 you could have used original EXE firmware updater from LiteON.

  1. You can’t flash it into wrong drive,
  2. Only way not to void your warranty. :stuck_out_tongue:

#15

There is a problem with the liteone’s programs (firmware exe aswell).
If you have a crapy aspi layer, the programs does’nt see the drive. So u have to find another way to flash or remove the aspi in order to use the programs.

This is very annoying if u don’t know how to correct it… So why a lot of people using other solution to patch, …

Earlier i patched my drive within W Millenium… There the program recognized my drive…

nb: i have a dual system (millenium/xp) in order to be abble to recover from a crash (xp alone often let u the only way to format and reinstall, or ghost it back… Bye bye data…)

nb2: firmware changing, patch, hacking … should be used with caution even it’s nearly safe. There always are some leak that could result in hardware jam.
So if you are newbee, if u don’t know your system, don’t try to use the tools only after 5 minutes reading a post in a forum.
Read a lot of articles, see if you are in the condition, double check your actions before doing it. You will avoid a lot of problem. and more, if you know someone that did it before, ask him to help before…


#16

This same thing happened to me a couple of days ago. MtkWinFlash didn’t like it when I tried to go back to HS0K from HS0Q on my 811S. I thought I killed my drive until I followed your advice above. Whew! (and thanks!)

So it sounds like I need to use MtkFlash in DOS to do this? I will definitely research this better next time…


#17

For regular flashing, I’d use the Windows flashing tool found here: http://dhc014.rpc1.org/howto.htm … For dead drive recovery, use MtkFlash for DOS.


#18

So this is true even if I’m attempting to void my warranty and go back to an earlier firmware rev.? :slight_smile:

Maybe the flash utility got confused because I also have a LiteOn CD burner on that same IDE cable?


#19

deconnect the other drive to test it then… so you will be sure that there are no confusions…