40125S doesn't accept audio CDs while DMA on

vbimport

#1

I've been struggling with my new 40125S for a couple of days now.

So the problem is that when I enable the DMA, the whole system halts when I insert an audio CD to the drive. Also when I try to start up Nero, it crashes while seeking SCSI/IDE in the beginning. When I disable DMA, it's ok, but painfully slow as you know and results with millions of errors on audio. Data CDs are then burn't ok (just tried with mere 4X).

Another weird thing is that when I connect the drive as a primary slave, boot up says: "boot disk failure". My old CD-reader with same jumper etc configurations works fine on the same spot. As a master on the secondary IDE seems to be OK.
My harddisk has also DMA on.

I do have an old computer, but I refuse to accept that it's too slow. It should do the trick at least with slower writing speeds.
SOYO SY-5EAS5 (UDMA support)
AMD K6-2 366Mhz
128MB SDRAM
IBM 10Gb ATA-4, <10ms
WIN98 SP2
Nero 5.5.8...

I've tried with all kinds of audio CDs so protection shouldn't be a problem.

I'd be very pleased to hear an answer, 'cause this thing is driving me mad!


#2

No idea…

Most likely a chipset/driver/OS problem.

Had the same problem on another computer with a crappy AMD nb and VIA sb chipset (one of the first mobos that came out for AMD slot
A), never really fixed it…

he was limited to 3 IDE devices with DMA, the fourth wouldn’t work with DMA enabled.