4 CD-RW drive + an RAID Controller Card = HELP!

I have 4 Samsung CD-RW drives on my PC… or rather I’m trying to get them to work… here’s what happened:

I put my HDD and Phase Drive (some magneto optical drive) on the mobo’s primary channel. 2 CD-RW drives on the secondary. I put in a CMD649 RAID card and plugged in the other 2 CD-RW drives, one to each channel. On booting up, the system POSTs, then starts to load the CMD 649 bios. It then proceeds to detect the drives on the card. The first line says Primary Channel and then the PC will hang there. What gives?

I tried other permutations:

  1. Put both drives on the primary channel of the card.

  2. Put only one drive on the primary channel of the card. (i.e. only 3 drives)

In these 2 cases, I get the same problem - PC hangs at exactly the same point mentioned above.

  1. Put both drives on the secondary channel of the card.
    In this case, the primary channel reports no devices installed, while the secondary channel (after a delay of like 20 secs) reports only one of 2 devices hooked on. In Windows, at my first attempt at this setup, I saw 3 CD-RW drives. I could do an eject of the trays using the OS.

I later reverted back to 1 drive per channel but the same problem arose - hanging after the words “primary channel” appeared.

I then reverted to setup 3. This time, something curious happened. I was able to see the 3rd drive (i.e. the master drive on the secondary channel of the card) only for a short while (like 20-30sec). I tried to get the drive to eject the tray but then the icon for this drive disappeared altogether! Subsequent reboots failed to bring this 3rd drive back… might this be due to Windows not liking the numerous changes in hardware config?? I have not yet activated this install of Windows as it is was a fresh one.

In summary, my two drives on the mobo presented no problems throughout this. I saw the 3rd drive (card, primary, master) only once in Windows and never got the 4th drive detected.

Any advice how to get the whole thing to work?

Thanks a million!

Raid cards are pretty much a no-go for running optical drives, best to run your HDD’s from the raid card and leave the opticals on the onboard IDE controllers, you may be able to find a non raid bios for your card though and then they may work. IDE pci cards can cause conflicts so it can be hit and miss

Thanks! I’ll try that… and maybe get a an IDE controller card if all things fail! :smiley:

BTW, if the RAID card is flashed to a non-RAID bios, does that not make it a pure IDE Controller Card? I read in the sticky thread that RAID cards carry bios which try to take over from the mobo’s bios and that causes problems??

couldnt tell you in detail but i know that raid cards shouldnt be used with opticals as far as i know they wont actually work anyway (well atleast work properly), what i will tell you is that unless you actually plan on running in raid then i suggest buying a standard IDE card, if the sticky says something then you can be pretty sure its correct.

and tell us how it goes :slight_smile: and welcome to cdfreaks if nobodys already said.

Hello

Thanks for the warm welcome, Mr Brownstone.

Anyway I have got the 4 CD-RWs to work simultaneously…

Setup:
Pentium 4 2.5GHz HT
512MB DDR333

Maxtor 40GB 7200RPM (8MB cache)
4 x Samsung 52x32x52x CR-RW drives (2MB cache)
Syba RAID controller (Silicon Image SIL680 chipset)

What I did:
I replaced the CMD649 RAID Controller finally… I was surprised that the Syba RAID controller actually worked despite the advice that RAID controller cards don’t like optical drives! Having said that though, the box that it came in had a specification line that said that it worked with all optical drives (DVD-RW/RAM drives were not specifically mentioned although DVD-ROM drives were).

I plugged the HDD into the mobo’s secondary channel. No slave for the onboard secondary channel. I plugged 2 drives into the primary channel as master and slave. Did the same to the other 2 drives but plugged into the primary channel of the RAID controller card. Did a fresh install of WinXP Pro.

Booted up. POST showed that the 2 drives on the onboard primary channel were detected, so was the HDD. Next the RAID controller card bios was booted. Was able to detect both the drives flawlessly. No hanging this time. Booted into Windows (very short time, I think 50 seconds wait from POST to entry into Windows)

Windows did its slowest to detect all the 4 drives as CD-RWs (LOL!)… Burned 4 discs as audio CDs with an wave file (739MB) Note: Audio CD size was 709MB. Was using okay media (Smart Buy - anyone heard of it?).

I use Nero 6 Ultra. Settings: Burned at 16x, Disc-At-Once, Cache was set at 999MB, write track to HDD before writing to disc.

At 16x, after burning the track, when writing the Lead-Out, the discs will spin for a while without the LED lighting up. Then they will all spin down. And the program will hang. I won’t get the “Done” dialog box which informs you about the success of the burning process. It also allows u to retrieve your discs cos the drive trays will eject automatically. Well, in my case when Nero hangs, the drives go dead, I can’t open them even by pressing the eject button. Or going to My Computer to eject using the right click menu. I have to do a hard reboot. Killing the program using the Task Manager just hangs the entire system.
However, the discs are completely usable… the track length was 70’ 14" and I can play it right to the last second on the track on my rather old hi-fi set (I think pre-2000).

At 24x, I don’t have this hanging problem!!! But one of the 4 discs was a burn failure… although I could again play it back to the last second on my hi-fi set! (Note that my cache was set at 16MB only)

At 52x, I tried only 2 discs (same channel, i.e. master and slave) with a file size of 300+ MB to write as audio CDs. Flawless.

Analysis:

  1. It has been stated here and elsewhere that having 2 CD-ROM drives as master and slave is a no-no… well I say that’s not the case… cos I wrote 4 discs simultaneously which were paired as 2 sets of master and slave drives on 2 IDE channels.

  2. It seems for the 16x writes, the Lead-Out has already been written but for some reason the program hangs (heat issues?). Hence I could use the discs although hanging the system is a big no-no…

  3. At 24x, I think it would be perfect if the cache had been upped to 999MB… I think the burn failure could be attributed to some buffer underrun. I haven’t had time to do a test again. Will do so again tomorrow. So wait for my update.

  4. 52x. What can I say… flawless with just 2 discs… but then we all know that dun we? :slight_smile:

Finally, any ideas about the hanging bit? Is it due to Windows not tackling some naughty bits of code in Nero properly or what? Your advice is greatly appreciated! Thanks a million!

Oh btw, I found got it to work… didn’t know what happen… just switched off the PC for a few days… went back recorded my wave file 700+MB and then burned for a 4 CD-Rs at 24x… no problem! Perfect burns! No changes in config.