3550A, burn speed stuck at <=2.4x

vbimport

#1

Just bought the NEC 3550A DVD burner and installed it and had some problems from the get go. It shows the max burn speed on my Memorex 16x blank DVD-R discs of 2.4X. I upgrded the firmware to offical NEC 1.06 and it still didnt seem to take…messed around with it and it finally recognized the discs correctly and I burned 3 dvd’s at 16x speed. I then used Nero CD-DVD Speed to check the quality and did a scan disc and then the drive crapped on me.

It is now only showing 2.4X burning possible. I took the blank DVD out and Nero shows the same thing (2.4X burning speed). So I put a burnt DVD in to check it out and it does not show anything even though video is on it and plays in a DVD player. I tried uninstalling the drive in the Device Manager and rebooting…it re-installed, but to no avail. I also tried installing to Liggy 1.Y6 but it says no supported devices found.

Anyone have any ideas on what I should do?

Drive is on the secondary IDE channel as the master (no slave device). The jumper is set to master. I run a P4 2.6GHz machine with Windows XP Pro and 1.7GB RAM.


#2

Check if DMA is enabled


#3

Sorry, forgot to cover all of my P’s and Q’s…yes, Ultra DMA Mode 2 is enabled on the drive.

This has to be the most frustrating thing in the world! :wink:


#4

Go back to device tree and remove ide controller and reboot, it may redetect it properly when ide driver is reinstalled.