3540A won't read its own DVD-Rs and refuses to be flashed

vbimport

#1

Hello all.
I just built a new system, and haven’t used my drive for a while now.
So I insert the DVD into the drive while in windows, and noticed it would not open it. I said oh well and went on to installing a clean copy of windows.
The computer starts from the DVD, it goes all the way through loading all the drivers, and when it says “Starting Windows” it BSODs, googling the code revealed that there was a problem with the source drive.
Basically I tried 3 DVD-Rs that worked perfectly before, and none of them would be recognized by this drive, regular CD-Rs work fine.
I know this is a common problem with the NEC drives, but my problem is that I can’t even flash to another firmware.
Current firmware is 1.01, stock.
BinFlash and the official 1.04 update by NEC refuse to flash the drive from windows saying there was an error.
BinFlash from DOS wouldn’t pick up the drive (although I used a different floppy disk, the DVD drive was accessible in DOS) when running it with the -scan flag.

As I don’t have any other DVD drives I was wondering if it was somehow possible to hard-flash this drive?

Any help would be appreciated. :slight_smile:


#2

The fact that the drive cannot read a disc should not prevent it being flashed. This would lead me to believe you have a system configuration problem.
Things to check.
Have you added any new hardware to the PC?
Have you swapped drives around or swapped PCI cards around?
Is the system overclocked?
If the answer to all the above is no, check the BIOS settings, check Master/Slave jumper on the 3540, then try replacing the IDE cable.


#3

Thanks,

Well for starters, right now the drive is connected to my second box, its set to Master via jumper and is a single drive on the IDE bus.
I did manage to make a dump file of the drive’s FLASH.

No other hardware changes happened in that system. Currently its running all stock.
Its a 1400MHz Athlon on a ASUS A7V266-E board (VIA KT266A chipset). Everything is running stock settings, BIOS was just reset (board resets to default when power goes out).

Its funny how it can boot from the drive, but can’t read its contents properly.