3540A eject shuts down computer!

vbimport

#1

I need some advice/recommendations. I got a NEC 3540A not too long ago and it has been working fine up to a week ago. Now every time I press the eject button, the computer shuts down. I suspect the power supply but everything else seems to run fine (plus, it worked fine for months).

A few details, power supply is 350W, cpu AMD Sempron64 3500+, 1Gb ram, HDD SATA.
The DVDRW is connected as master on IDE0.

I do not think it is software related, since this happens also when I try to eject during boot, before loading any OS.

Any suggestions are appreciated.


#2

Try reseating the power and ide cables on the drive.


#3

Yesterday night I looked inside and replugged the power cable and still the same behavior. Do you think the IDE cable could be the cause? I read on the NEC website that they recommend to plug the DVDRW on the second IDE bus as master, but that does not seem to make much sense if it is the only IDE drive.


#4

They recommend that probably for when you have an hdd on the primary ide. You may have it figured in your original post then, suspect the power supply.


#5

Could also be a faulty tray/loader motor. This device is driven by 12V rail (also the main curent in PSU).
Does the same happen when you open tray in explorer (“software” - eject -)?

Do you have any virtual drives software running in background when this happens. I once had the same problem with Deamon tools on Win2k.


#6

It does happen with software eject and I do use Daemon tools as a matter of fact. However, the computer shut down also happens when I try to eject before booting any OS (e.g. on the BIOS screen). It also happens on Linux. So I really think it is hardware related.


#7

try a different drive if no problem then you have your answer.
in addition i would try the drive in a different computer.

also what motherboard chipset do you hve?


#8

it really looks like a short circuit, so i wouldn’t try it in another computer. the drive obviously needs to be repaired.


#9

Today I got a new power supply unit, I’ll install it tonight and see.

Actually, the drive should be fine. I used it in a different computer for a few months with no problems. Then I used it in the current computer for a while with no problems.

My motherboard is an MSI with an nForce4 chipset.


#10

uninstall the nvidia chipset drivers (or update to the latest) and see if that changes anything


#11

The problem is solved. Just posting in case someone else has similar problem. Last night I installed a new power supply and everything is working fine now.

Just for the record, my old PSU was a Magnum 350W, I replaced it with a Rosewell 450W.