3520AW Reading 16x DVD Issues.. :(

Ok here’s how it goes…

A friend of mine burned some Data DVD’s in 16x… the DVDs are TY DVD-R 8x Certified and 16x Compatible…

When I insert them in my DVD (3520AW) to read them… the dvd shows that there is no disc… but when i run ISOBUSTER … everything seems to be there… and it extracts the dvd files like there is no error in the DVD disc… :confused:

Is there a way to read the DVDs without using isobuster ??

I’m using Dee’s ND3520 2.U5 firmware…

Plz anyone any answer…Ahhh and yes the DMA is enabled…

Welcome to the forum :slight_smile:

Have you tried to restore the original NEC firmware?

Just did so… and nothing happened :frowning:
any other ideas ???
is there any other driver than basic XP driver that i can use ???

Is the problem with -R only? If so, you may have a common NEC problem whose details are at http://club.cdfreaks.com/f86/nec-optiarc-dvd-r-reading-problems-209168/.
Note IMGBurn and ISOBuster can read where Nero, Windows and others don’t for such problems.