3500ag, dvd-r not readable

vbimport

#1

everything was ok and then one day it was not

  1. dvd+r works as it should, so are all kinds of cds, cdrs and cdrws

  2. even freshly burned dvd-r is not recognized subsequently though it burns and verifies ok

  3. tried bunch of older records, different manufacturers/speeds, all the same
    dvd+r are ok, dvd-r are shown as blank or empty disks

  4. every dvd-r opens, extracts and shows no errors in ultraiso or isobuster,
    but explorer cannot find anything ( aka blank disk )

  5. all disks, newly burned and old alike, are readable and working flawlessly in other machines

  6. tried winxp with + sp2, winxp + sp2 + all the official patches,
    winxp + sp2 + ryanvm post sp2 pack
    same symptoms

  7. flashed and reflashed 3500ag with new and old firmwares, all the same

  8. cleaned lenses to the best of my abilities, all the same

  9. tried new ide cable, primary, secondary, master slave, udma on/off,
    busmaster on/off - all the same

  10. reflashed motherboard bios, all the same

am i missing something obvious ? is it a known issue ?
is my 3500 dying :confused: