3500A only reads at 2X & burns 2.5X. Ready to tear my hair out

vbimport

#1

I’ve been reading all the posts on this forum in an attempt to fix the problem I’m facing, but to no avail. I’m hoping one of you englightened souls may be able to help me out.

System Specs
Dell Inspiron 5100
P-4 2.4 Ghz
512 MB RAM
CD-RW/DVD-ROM Combo (Variable)
Windows XP (Service Pack 2)
Plumax PM-525U2-PCS (Cypress chipset) housing a Nec 3500 drive which I got last week. The NEC is currently configured as a Master. I have DMA enabled on my primary IDE channel (DVD-ROM) and secondary IDE (HDD).

I’ve flashed in all the different recommended firmwares (TDB, Liggy, etc.) but its not making any diff. I really don’t know anything about DVD burning but after following the posts out here, I started using Nero CD-DVD Speed, Info Tool to see what’s going on.

On a DL movie, it starts at 2.5X and levels off at 5.8X or dips back to 3.5-4x
On a movie disk that I burnt, it starts at 5.5x and stays in that region.
Its never gone over 6X on any kind of media. I’m using Ritek 8x (G05).

When I power up the enclosure, XP recognizes it as a USB Mass Storage Device. I get a msg saying “Found CD-ROM drive” and then _NEC DVD_RW ND-3500AG USB Device. I don’t know if this is what should happen. (Should the enclosure show up as something else?) I read somewhere that XP Service Pack 1 didnt have good drivers for it so I even moved to Service Pack 2 last nite but it didnt help.

The instruction manual on the enclosure says that drivers aren’t needed for XP. Even so, I forced it to install the drivers that came with it. Then it recognizes the enclosure as USB Storage Adapter AT2 (TPP) and the drive is recognized as “_NEC CdRom device” (v/s USB device). Don’t know if this should matter. Under Drive Speed, when I do a burst rate test, I never ever get more than 1 MB/s. Only once while tinkering with the enclosure drivers, did I get a burst of 7 MB/s. Couldn’t reproduce it thereafter.

Now when I’m ripping a movie (DL disc), it takes 35-55 minutes to rip it. It starts at 2.5x, moves up to 5x and then starts dipping all the way back to 3x. Thereafter, I select max burn speed (8x) and although Nero says its burning at 8x, it takes 22 minutes to burn the disc, roughly translating into 2.5x speed. I even tried a pure data disc with 2.5 GB of data. It should’ve taken 5 min but it took me 12 minutes. I should point out the the movies I’ve burnt work absolutely fine on my dvd player.

I thought maybe the enclosure is the problem. Except there are no other drivers to be had. I know my burst rate is unnaturally low. Burn speed is ridiculous and Nero’s buffers swing like crazy from 6% to 100% and back.

Or that my HDD is the bottleneck. I don’t know its RPM and I only have 5 GB free on it. I’m trying to defrag it right now. Will that help?

I’ve been trying to get this to work the for the last 4 nights and I’ve finally given up. I’m at my wits end. Just so frustrated. I read through the posts, tried everything that was suggested and nothing has worked. I’m so upset that I bought a 16x burner and its performance is so horrible.

If you guys know anything that might help, I’d really appreciate your inputs. Currently I have TDB firmware flashed in (with RPC1 and Riplock). RPC1 is working abs. fine but riplock aint.

Thank you.

I’ve included pics of my setup as it shows under Info Tools.


#2

That is the problem, you’re using a Cypress USB chipset for the enclosure. If you head over here, all of those who have external enclosures, including myself, are mainly using the Plumax USB/1394 combo enclosure with the Prolific chipset to house the 16x DVD burner. I’ve tested the NEC 3500A, Benq 1620, and LiteOn 1633S and all have burst rates of 24 MB/s when using 1394. The highest USB was only 15 MB/s. My Plumax 3.5" USB-only, Cypress-based chipset only bursted at 7 MB/s when I tried an optical drive with it. Since I’m keeping a hard drive in the 3.5", it doesn’t really matter as that’s only for backup/storage. You’ll have to get/use 1394 to have any speed increase.


#3

Hmm… I just connected the enclosure to my roomie’s desktop and its getting a burst rate of 7 MB/s each time against 1MB/s on my laptop. This is so weird. I thought USB 2.0 is faster than firewire but I read posts on this forum that’s not necessarily true in practical terms.

BTW, I wanna do a test burn through this machine and see what speeds I get. How do you do that under Nero CD-DVD speed??

Many thanks


#4

Is the enclosure USB 1.1 or 2.0? I’d guess it should be 2.0 but you never know! I would go to intels or Dells site and try to find latest USB drivers for your board!

And ripping with the NEC is slow anyway if you don’t use a riplock free f/w!


#5

It is USB 2.0. When you say latest USB drivers for the board, do you mean the controller in my laptop or the enclosure? I do have a riplock free f/w. (TDB to be precise)


#6

Theoretically, USB is faster than 1394a in terms of numbers, but 1394a has been known to have higher bandwidth and take up less CPU resources.

You may want to check with Cypress to see if they have a newer firmware for the chipset, but the only way to identify the actual chip is locating it on the bridge board. This way, you won’t flash the wrong firmware if there are different revisions or versions of the chip available.

For Nero’s Create Data Disc, it’s F9, or under Run Test menu and it should start.


#7

Sorry, I edited my post when I realised you had a laptop :slight_smile:

You need USB drivers so you laptop knows how to talk to your enclosure, the enclosure does not need drivers only the controller on your laptop, just wondering if there is a newer USB driver for your laptop that may help.

And KTL may have found the reason why your enclosure is not performing, just spotted that reply too!!


#8

Ok, so I’m now considering buying a new enclosure. Which model would you recommend and where can I get it? I got this one from DealSonic.

BTW, I did a Create Data Disc data disk using Nero and a Riek G05 media. The results were quite weird. Maybe I got a bad batch of media? They’re supposed to be 8x. What’s a good media to use for burning movies (Brand, -R/+R) and where should I buy it from? I used MeritLine for my Ritek.



#9

Yuck!

Is your USB controller sharing an IRQ with anything? If so,try to get it on it’s own IRQ if possible!

As for enclosures, I pass on that as I’ve never used one, but I’ve read plenty of problems using them!!


#10

Both of the Plumax enclosures I have were bought from Dealsonic, which does list the chipset maker for all (if not most) of the enclosures. Make sure you look for the Prolific one. There’s also the Oxford (1394)/Cypress (USB) combination also, but people have reported the Oxford wasn’t able to get up to 24 MBps either.

It would be nice to have a DVD-ROM drive just for reading/ripping purposes, but that means you’ll need another enclosure. A good DVD-ROM drive is the AOpen DVD-1648/AAP (might be discontinued) or /AAP Pro (newer version). Supposedly, Newegg may have the /AAP Pro by 1/17. The LiteOn 167T / Sony 1613 (clone) should be good too, since the 166S/1612 is discontinued. Codeguy’s website has patched firmwares for faster reading on the LiteOn drives.

It’s not surprising to see Ritek G05 burned only at 4x, but it seems like the limitation of the Cypress chipset is in effect. Taiyo Yuden +R (YUDEN000T02, 8x) is great, even for 16x burning. However, there’s no reason to get “better” media if the limitation is elsewhere.

Do a transfer rate test (F2) and see how good/bad the line is.

If you just purchased the enclosure, talk to Dealsonic and see if they can give you an upgrade/alternative without any restocking fees. People have mentioned they’re good about returns.


#11

You can only get 15MB/s on USB? I just tried a burst rate test on my BenQ 1620, which is in the same Plumax case, and I got 22MB/s. Strange.

@kushmon
I would definitely get the Plumax PM-525C2-PPB from Dealsonic. It has worked great for me. I am actually getting a second to house an AOpen 1648/AAP…they should be here next week :smiley:


#12

It was using the 0907 firmware, but I’ve yet to test the latest one (11-something) since I just keep the NEC and Benq drives internally.

Just did a burst test with the 1633S (KProbe) and got a whopping 14-MB/s. But no biggie, 1394 is fine with me. :slight_smile:


#13

I would definitely suggest using the new firmware (1109). I think my burst rate had been around 15MB/s on USB with the original firmware.


#14

Someone mentioned checking for IRQ conflicts. I did and oddly enough I have 4 USB Universal Host Controllers (24C2, 24C4, 24C7, Enhanced 24CD), 1394 Host controller, my wireless card, and my graphics chip sharing IRQ 11. Could that be a problem.

To all you guys, thank you very much for taking the time to share your thoughts. This is a great forum and you guys are really helpful :slight_smile: