32123S XS0X - Problem with Offical Firmware

vbimport

#1

Just want to inform OC-Freak and other moderators about Lite-On 32123S Firmware XS0X.

I used Nero CD speed and got pretty weird results. My average speed was managed only to hit 24x. Starting was around 18x and Ending was around 24x as well. I used 3 different discs on it.

I reflashed the drive using XS0U and got back normal results.
Average of 31x. Starting 18x and Ending 41x.

You may wish to test this out for yourself. For your info.


#2

XS0X works just fine. You did test three different brands of media didn’t you? Not three from the same box…


#3

XS0X is fine here as well…


#4

Yes…I did use different discs. I was Jedi Knight 2 Jedi Outcast, the other Return to Castle Wolfenstein and the third one was Star Wars Galactic Battlegrounds. All with roughly the same results: 18x starting and 24x average and ending 24x.

Even CloneCD v4.0.1.10 reports 24x reading average.

Weird huh?

DMA is enabled. Using WinXP Home and latest VIA 4-in-1 drivers.

BTW, I’m not posting a hoax. :wink:


#5

Hi there just flashed all my lite on drives (24,32,40,48) and i’m having the same problem with the 32x drive; flash it back with previous firmware and now it’s working fine!


#6

it happened me the same, if you read my thread http://forum.cdfreaks.com/showthread.php?threadid=49942 you’ll see that you’re not alone… :slight_smile:

once i updated the firmware to xsox i could not burn at that high speed…

i have to say that the copy of that game only works in my lity (traxy)… :Z


#7

Aha, you used protected discs, that might explain it… I guess XS0X is more sensetive to read errors than the previous firmwares. Maybe they did something to SMART-X, dunno…


#8

Airhead,

My guess is that Lite-On made some changes to the XS0X firmware. What the changes are is anyone’s guess. (Anyone out there has a clue?) My three discs had 1 no-copy protection disc(RtCW), and the XS0X still delivered slow reading times (ave. 24x).

If any of you have time to spare on your hands (OC-Freak perhaps? After all, Freak right?! :stuck_out_tongue: ), try Nero CD speed on the XS0X and previous firmware versions. Post it here and discuss here. Mebbe Lite-On is on to those people who had 24103S and managed to flash it to 32123S, and want these people to GO BACK to 24103S PERMANENTLY? Could be some source code or something? (Heh! I’m one of them! Could that explain it?!)


#9

Lite-ON 32123S XS0X (overclocked 24103S) read result:

Test performed with a Kodak Ultima CD-R

Original 24103S with firmware XB03 read result:

Forgot what brand I used… (loaded an old dat file)

They are nearly identical in my opinion…

Edit
XB03, not XS0F


#10

I wanted to contribute another wierd problem to the current thread.

I just bought a LiteOn 32123S and after reading up on firmware upgrades here - I flashed it to the latest firmware (xS0X).

Today I noticed that my drive will no longer read CDRW discs. I reinstalled InCD and rebooted - nothing. I’m using some Memorex 1x-4x Rewritables that have always been good to me in my old burner, but I thought maybe it was an incompatability issue. So I tried the CDRW that came with my LiteOn. Still nothing. The drive would read regular CD’s and CDR’s wihtout incident, but just would not recognize a CDRW.

I desperation I downloaded MTKFlash and the old .bin file (xS0U) and reflashed the drive.

While I’m writing this, I am formatting an older CDRW (one of my Memorex’s) So far so good - I’ll be sure to let you know if I have any problems.

Like I said, I saw this thread and thought I’d contribute - at least in my case, I’ve also had problems with the newest firmware. YMMV.

Thanks.


#11

Hi folks,

its is getting even worse:

I flashed my lite-on from XS0U to XS0X a few weeks ago,
everything seemed fine… till today.
Suddenly my drive couldn’t write 32x any more with the same batch of Media.
I writes 24x till the point where it usually swithes to 32x the it starts trying to spin up to 32x … then it resumes to write 24x after about 20 Seconds of trying !
But the really worse thing is:
Those CDs aren’t even readable !
They are toast i.e. unreadable aprox the point were the drive switches to 24x from 20x !
This ain’t very funny ! :a
Now i flashed down to XS0U and everything is fine again… puh

My conclusion is that liteon changed some parameters for the laser power control and/or laser power readback.
This would explain why it first worked cause my drive was brand new when i flashed it to XS0X.

Now after i used it fow a while the Laser-Diode or Monitor-Diode
aged a little (totally normal) so the values aren’t exactly like the new firmware expects…

MAybe i should write liteon a small mail…

cya Jan


#12

CDRW and 32x writing still works fine here… How old is your drive?


#13

My drive is about 2 months old…
Any better idea ?
If it is a hardware defect then why should it start working again after flashing the old XS0U firmware ?


#14

Tried other media types?

Cheap/Low quality media may cause lots of unexpected errors…


#15

After seeing Airhead’s pics, I decided to reflash it from XS0U to XS0X ONE MORE TIME again. After all, you don’t become moderators for nothing right? :stuck_out_tongue:

Used Return to Castle Wolfenstein on Nero CD Speed. And guessed what, I had the same results as Airhead (well…very very close). No more peculiarities I mentioned anymore. I even tried it with Warcraft 3. Same good results.

Like I mentioned earlier on, it was REALLY WEIRD!

Again, this is no hoax and I’m not wasting anyone’s time…:wink:

Thanks to all, especially Airhead and OC-Freak for your valuable time!


#16

Just glad to be of help :slight_smile:


#17

OC-Freak Tried other media types?

Yes i also tried another media (TDK and KODAK) poor little discs were trash after burnig them :frowning:
I burned the same brand (Highspace) and production batch of discs a dozen times before without the smallest error (even 0 C2 errors).

But as i posted before everything here is fine again after “downdating” my firmware to XS0U.
So no1 can tell me that the media caused this problem.

I think i am really close to reality with my statement about the Laser Power in my first post.

A CD-Recorder is an very analog part when it comes to the physical data written to the disc surface, i think you agree with me in that point.

so long Jan


#18

I don’t get it !
I just flashed my drive again to XS0X and now it works flawless again !
I used exactly the same media as before, but this time everything seems fine, not even 1 damaged sector.

There are only 2 things which changed:

  1. This time I flashed the drive using mtkflash, the last time I used
    the windows prog from liteon

  2. The surounding air is about 2 degrees cooler (27 -> 25 Degrees Celsius).

(Yes my case is properly cooled believe me :wink: )

So there are 3 possible causes:

  1. The windows prog did an uncorrect flashing (unlikely)
  2. The tempeartures of the Laser-Diode and/or Monitor-Diode
  3. Liteon says their drive have an temperature-control maybee something is wrong with this ?

I will continue to monitor this “problem” and post again if something gets clearer…

OC-Freak any other idea by now ?

cya Jan


#19

I wanted to try again to flash my 32x so i downloaded the firmware a second time from lite-on site and guess what: my drive works again with XS0X and pretty well so maybe that lite-on discovered a little bug and fixed it without changing fw version.


#20

Nope liteon didn’t change a single bit !
I checked this out both images match 100%