2500a DVD isn't recognized by most programs!

vbimport

#1

I just got a NEC 2500a (Mad Dog 8x). I pulled my old TDK cdr burner (master) out and replaced it with the NEC. Windows XP recognized both drives. I inserted a regular cdrom in it and it read ok. I then inserted a commerical DVD and tried to view it with MS Media Player 9 (just installed through Windows Update). The player would not recognize that there was a DVD in the drive. I also tried PowerDVD3 witrh no luck. Nero 6 recognized the DVD, but wouldn’t copy it due to copy protection. I then tried to read a regular cdrom disk in the NEC. It now wouldn’t recognize it! I then installed DVD X Copy Platinum. It recognized the drive, but would not detect that a DVD has been inserted. This is also true with DVD-Clone II. However, when I ran the free DVD-Decrypter software, it immediately recognized the movie
and made the image files. I used CloneDVD to burn a copy which played in my home DVD player, but again wasn’t recognized by the NEC. I then made the NEC the slave and the cdr the master. No luck. I put the master on the end of the IDE cable and the NEC slave in the middle. No change. If I put just the NEC as the only drive set as master and removed the cdr drive, the NEC wouldn’t recognize a DVD or CDR and Media Player’s DVD play option was greyed out. I followed the FAQ suggestion about making sure that DMA is enabled and that the 2 drives were recognized in the Device Manager.

What’s going wrong? Please make some suggestions.

Thanks.


#2

You didn’t even provide software version numbers…
We need details to help you.
Old software doesn’t always support newer drives.


#3

The situation is strange. I got a message from Mag Dog to boot into Safe Mode, remove the cdr and dvd-r drive references and reboot. If I do that both my cdr drive and the dvd drive can read regular cdroms and the DVD can read a DVD burned with photographs. However, as soon as I insert a DVD movie, NEITHER drive will read anything with a file manager. I can watch the DVD using PowerDVD 5 before and after the movie insertion. Nero 6.3.1.7 will recognize the DVD drive and burn a data disk. DVD-Decrypter 3.2.2.0 also has no problem recognizing a movie or data disk. DVD-CLONE II 2.3 demo will not recognize a movie that has been inserted. Since neither drive will read cds anymore after inserting a movie, I have to repeat the Safe Mode procedure to get them to work! Also, Windows XP Explorer has an icon for a DVD-RW drive before a movie and a CD-R for the drive afterwards.

What’s going on here???


#4

Hmm this is weird. i replaced my ricoh mp5125a which was on sec master to a true nec2500a and everything was fine. All programs worked nero 6, alcohol 120%, dvd shrink, powerDVD5, winDVD6 etc. Maybe not the cause of your problem but you do have the latest aspi drivers in? I dont really know what has happened, sounds like maybe a dodgy drive. Maybe a firmware flash will cure your troubles, other than that i can’t be of more help.


#5

It absolutely would not…
His troubles have nothing to do with firmware.
Try default Microsoft IDE drivers.
Try a new IDE cable.


#6

I just replaced the IDE cable with the one which came with the new drive. I did an update of the IDE controller drivers from the System folder and no new ones were found (just the default Winxp). Result = no change.

I did find that if I boot to safe mode, everything is the way it should be. I then rebooted and shut down all programs which load at startup and any other unnecesary processes, but the problem persisted :frowning:


#7

It’s obviously a software issue if your drive works fine in safemode, but not after a regular Windows bootup…
Have you also disabled IMAPI WindowsXP burning service?
I suggest completely uninstalling ALL of your burning/DVD apps, cleaning your registry, and then installing ONE DVD burning app to try again.
If this doesn’t work, you may want to do a clean install of Windows.
Also, just to confirm that it is a software conflict, can you try the drive in another PC?


#8

looks like wimp9 is the issue
http://www.annoyances.org/exec/forum/winme/1087345122
I downloaded WinMediaPlayer9 after Microsoft Updater scanned and said it was available(Silly Me). Since I’ve had it on me system, I cannot play DVD’s in my Cyberlink DVD/ combo cd rom drive or some home made music cd’s, which I could play just prior to downloading wmp9.


#9

Thanks for the link cnlson!


#10

I uninstalled the IDE devices and rebooted. The first time, it looked like that was the problem and everything worked until I rebooted again. Then, the same problem. I even updated my VIA Master IDE drivers with no luck. I guess, I just have to live with the problem and only use certain burning programs.


#11

I would just do a clean install of windows. I had a problem with different burning apps that were causing a conflict and IDE drivers. I did a clean install and it worked with just having the Microsoft drivers on it.


#12

grafx1, I experienced the same issue that you are referring to.
I had a video DVD in my NEC 2500A (drive F: ), but WindowsXP would not recognize that there was a disc in the drive.
I then noticed that I had DVDIdentifier running.
After I shutdown DVDIdentifier, everything started working normally again.



#13

I had the same problem and getting rid of the VIA drivers and going with the Win XP default IDE drivers solved all my problems.


#14

How do you uninstall the VIA IDE drivers. I tried that through Device Manager and they return adfter reboot.