2500 w/ 2.F8 won't bitset

vbimport

#1

I have a NEC 2500a which I recently flashed with the Maddog 2.F8 firmware to supposedly turn it into a 2510. The problem is that I cannot set the booktype on this drive. I have another, real 2510a in a Firewire enclosure that works just fine with the same firmware (I use Binflash to set the booktype), so I don’t think the problem is the firmware. When I try to set the booktype with Binflash, I get an error message along the lines of “this drive doesn’t support bitsetting”.

Here is a list of ways the nonworking setup differs from the working one:

  1. The nonworking drive was originally a 2500a
  2. The nonworking drive is on an Nvidia Nforce2 motherboard using the latest Nvidia IDE drivers.
  3. The nonworking drive is the master with a Liteon 166S DVD-ROM as slave on the same cable.

Would any of these factors affect the drive’s ability to do bitsetting?


#2

At first my drive wouldn’t bitset my dvd+r until I restarted my computer after setting the booktype to dvd-rom. I dont know if you havent done this already but if you haven’t you should give it a try.


#3

I tried power cycling the machine but it didn’t help. I’ll have to try some other 2.F8-based firmwares like Quikee’s. If that doesn’t help, the only other thing I can think of is to try this drive in another machine with a different IDE controller. If that still doesn’t work, then I guess it must be a hardware limitation of some 2500a’s.