2500 and hdd led

hi guys…

i have my drive for 2 days now…i upgraded to herries 2510 2.15 firmware today and i just noticed that the hdd led stays on while im burning a dvd and i think that it should be blinking.the hdd led also stays on when the tray opens/closes.
is it because of the firmware or what?
how can i fix it?
my drive is set as a primary slave.

thanks…

Hi NoLimit,

it is a known problem. Take a look at this thread (and contribute if you can)…

Try to set your drive as master, if you can. Maybe the problem will disappear…

Do you have an Asus motherboard with nForce chipset?

Regards,

ET

i went through that thread while i was searching the forums.i wasnt sure if its the same problem i have because it wasnt really explained well.
i’ll post there soon.
thank you.

You are right… the link that I showed you is not the one where I read about the problem for the first time, but I was not able to find it quickly. Try the ‘master’ trick, it could work (I had a similar strange problem with my Liteon when I experimented an “overclocked” firmware, and setting the drive as master solved it).

Good luck,

ET

setting the drive to a secondery master didnt help.
installing the stock 1.07 firmware didnt help either.
is this a drive problem or a settings problem? after installing the stock 1.07 and still having the same problems i think itsnt related to the firmware or is it???

Try to enter in your motherboard BIOS settings and load the defaults! (Be careful!) What motherboard do you have?

Regards,

ET

as you see in my signature,i have a GigaByte GA-8PE800 PRO-R mobo (intel chipset).i tried loading the defaults as you suggested but that didnt work either…cant really think of something else…any help?

Sorry, reading signatures does’t enter in my dummy head… :eek:

As I told you before, I experied a similar problem when I tried to “overclock” my liteon SOHW-812 to a SOHW-832 (Double Layer). It was set as slave and I noticed that my power LED was blinking after the update. I restored the original firmware but the problem was still present.
At the end, I removed the BIOS battery and used the appropriate jumper on the motherboard to totally erase BIOS data. In your case (from your motherboard’s manual) you have to:

  1. turn off the computer and unplug the power coord
  2. remove the battery, wait for 30 seconds
  3. re-install the battery
  4. plug the power cord and turn on computer

Hope this helps,

ET

I’ve had my NEC 2500 for months now and have burned way too many DVD’s to count. The “HDD LED” stays on whenever the 2500’s “drive busy” LED is on. I don’t see that as a problem as it indicates that the IDE bus is busy - it’s not really only a HDD LED since the addition of CD/DVD drives. :slight_smile: That bothered me at first, but I’ved learned to live with it. The other burners I’ve used didn’t do that (LG 4040, Plextor 504), but on the other hand they didn’t burn as reliably as this drive does.

This seems to be normal for this drive, so don’t worry about it.

BTW, I’m using it on an old AOpen AX6B (Intel chipset) P2 450 MHz system. It’s connected as slave to the secondary channel.

I hope this helps.

  • Red

P.S. Some of the suggested “remedies” I’ve read (for a non-problem, may I add) scare me. Why? If the user is inexperienced, they could lead to more serious problems than having an LED that stays on. :stuck_out_tongue:

okay guys…it worked now.
eltranquil,thanks alot for taking time to read the manual and for the help.
here is what i did :
i reset my bios by removing the battery and restarted my system…it didnt help,at this point,i got fed up of trying to solve this issue and i wanted to burn a TY 4X dvd+r. i was using the nec 2510 2.15 and i said i’ll flash to 1.07v2 beta5 'cause it has betsitting and guess what,i don’t have the problem anymore!!!

RedBastard and everyone else,please try this it might be how to solve the issue:

  1. try to remove the battery and if there is a special jumper then try to use it so you erase all your bios settings.
    for my mobo,this did the trick (thanks eltranquil) :
    A) turn off the computer and unplug the power cord
    B) remove the battery, wait for 30 seconds
    C) re-install the battery
    D) plug the power cord and turn on computer

  2. restart your computer and flash to… lets say what i flashed to, herries 1.07 v2 beta5 with betsitting and dl.

  3. POWER OFF (dont restart) your machine.

  4. power on again.

  5. post your results.

Glad that you fixed that, NoLimit! :slight_smile:

Cheers,

ET