2500@2510 - tray & led problem

vbimport

#1

What I’ve tryed to solve led problem:
Made my drive slave - found tray problem too.
Made my drive Cable Select - led problem here.
Changed cable to ATA33 - led problem here.
Cleared CMOS - led problem here.
Flashed without disk in the drive - led problem here.
Turned off my PC - led problem here.
Changed IDE drivers - led problem here.

Any more ideas? :smiley:

Specification of my PC:

ASUS A7N8X nForce2 SPP @ 400Mhz FSB BIOS 1007
ATA 100 cable
Athlon XP Baton 3000+
Additional Ultra100 TX2 IDE controller

Please, post your specifications, even if you DO NOT HAVE led problems. We must analyze in wich systems all this stuff happens! Thank you goes to everyone who will post!


#2

Server: Any more ideas?

Did you flash empty drive back to org NEC stock 1.06/1.07 fmw as slave, then set drive as master & reflash as 2510A? Read somewher in the 2510A posts that this solved problem.
Hope it works for you.


#3

Will try this now. Stay tuned for my results! :smiley:

Update:
Here are my results: NOTHING HELPS
Flashed to original 1.07 as slave, set drive to master, flashed to original 2510a - no results, led’s bug is HERE!
Tested other combinations… NOTHING HELPS!

I think this bug is computer configuration related.


#4

Please, post your status of this problem!


#5

Hi!

OK, here are my specs:

AMD Athlon 1400 (Thunderbird)
256MB DDR-RAM PC266 CL2
MSI K7TPRO266 (VIA KT266)
ASUS GeForce4 MX420
Realtek 8139
Hauppauge PVR250
ALI USB2.0
Maxtor 120GB 8MB (pri mas)
Pioneer 116 (pri sla)
NEC ND-2500A (sec mas)
Plextor PX-708A (sec sla)

I don’t think you can avoid this HDD-LED problem by another way of flashing. It seems to be dependent on the chipset you’re using. Users with Intel chipsets don’t seem to have this problem.

Legnerp


#6

DO YOU, personally, have this led problem?


#7

i to flashed my 2500 to the 2510 firmware but have had no led or tray issues.

comp,
amd2600+
fic mainboard (nforce 2)w/4.24 drivers
fic radeon 9800p /det4.4
512mb ram DDR333
winxp / all updates
and 40gig WD HD (7200RPM)
NEC ND-2500A 1.06 dangerousbrothers to 2510fast.bin sec/ma
philips cdrw2400 sec/sla


#8

Strange… Maybe, this is ASUS BIOS related issue…
puppeteer666, please post your procidure of flashing the BIOS!
This is really strange, so you have same chipset as mine… Only manufacturer of motherboard and revisions of chipset maybe different…
Hmm…


#9

No I don’t, but my PC does! :wink:


#10

put only 1 .bin and flasher on a seperate disc from win98esd
i used a win98 ESD and booted minimal
once in dos mode i removed the win98esd,then in with the .bin/flasher
then typed this command as stated on the readme.
nec2x00a -sec -mas -flash 2510fast.BIN (of course that’s the name of the bin file i used yours may be diffrent)

in case ya did’nt know (do not cntrl+alt+del after flash is complete just use power button on pc) remove the floppy and restart.

my nec drive has the volume slider and headphone jacks.(posted cuz read others stating if they did or did’nt)


#11

Yes, I’ve tryed to turn off my PC. I tryed EVERYTHING to fix this. That why I am created this thread, to help myself and everyone who has this problem, to gather all information and try together find a fix. I still beleave, that soon will appear the next version without this bug… Or might we will examine the firmware and find difference in code wich makes this strange thing happen!

If drive set to slave - it has tray issues in my system too. Will try tommorow in the Intel TX motherboard… :smiley: Maybe, my A7N8X bios is source of evil. :smiley:

2510A firmware has additional block starting at 24730 hex… What is this? And both 1.07 and 2510’s firmwares in some parts are the same!


#12

you did exact method as me?same bin?win98esd minimal boot?


#13

I use following steps and solve all problems…
1.flash back 2500a
2.power off
3.change driver to pri-master
4.flash to 2510a
5.power off again(need turn off “the power” ,too)
6.power on and everything work fine now…


#14

@Server have you tried the latest nVidia Unified driver package?

It might be the SW IDE 4.12 causing problems?

Just a thought


#15

No, IDE drivers can do nothing with this problem, because this problem there is even in the clean DOS. :frowning:

I used minimal boot of Win95 and PC-DOS for flashing… Steps nearly the same as yours. :frowning:


#16

Test results with different IDE contollers:
Promise Ultra100 TX2 - tray problem when drive is slave(did not test with led)
CMD 649 ATA100 - tray and led problem when slave
PIIX4(TX, Pentium 233MMX motherboard) - no led problem(because this intel mobo does not indicate ATAPI drive activity by led), but tray problems when drive is slave.

Conclusion: Intel based mobos does not have led problem due to not indicating activity of ATAPI devices. All other problems with Intel chipset, like ejecting tray still presists. So, avoid this beta firmware, if you do not need DL writing right now. Wait for new release!


#17

I have sporadic led problems, not whilst burning a disc, but whilst waiting for the drive to recognise a disc. Only just noticed, but to be honest, Im not classing it as a significant problem, doesnt seem to affect burns.

I have an abit nf7s, but the nvidia ide drivers are not loaded. Running on sec master, with another dvd rom as sec slave. No tray problem


#18

Yes, led problem might disappear due to presence of slave drive. Firmware might be tuned for aviablity of the slave drive, as this can be done with HDD jumper settings on some models!


#19

I have intel 875 chipset on a msi motherboard and the only problem that rests is the led ide always on. I did it as pupeteer told, however the recorder works properly
with any other problem.


#20

Just flash back to one of Herries cheeky little numbers, from what i have seen the DL firmware isnt too cracking anyway and the discs wont be out and affordable foe donkeys anyway.