24/10/40A Help Wont read any cd's

vbimport

#1

Heres my prob. Ive had the burner for 9 months and its worked fine, until today. I was ripping audio cd's to mp3's today and i put in a cd and it wouldnt read it, it said there wasnt a disk in when there was. Now its blinking green 9 times which at the plextor website means "pickup sled failed", "pickup failed to move properly" go here to see what im talkin bout http://www.plextor.com/english/support/plexhelper/atapi/blinkchart24.html

So I turned off my puter unplugged the cables to the burner and the power cable, plugged them back in like the website said to do but its still doing the same thing, blinking 9 times green and it wont read any cd's????? So does anyone know what this means? Could it be that my burner is dirty and needs to be cleaned or am i just F%$#ed? Any help would be sweet. Thanks.


#2

On the box of my Plex2410 it says [b]2 Year Warrenty[/b]. If my Plex would start doing stuff like yours does I would return it. Maybe you can solve your prob now but the chance it will return is big.


#3

If you still get blinking LED lights after going through the troubleshooting process your drive is most likely defective.
Sorry :frowning: You can try cleaning it or if you’re warranty has expired, opening the drive to check what’s wrong. Perhaps the drive is dirty… Only keep in mind that opening the drive is done on your own risk and may void the warranty. Contact www.Plextor.be first to see if they can help you with your problem. Good luck!