20A1P - doesn't read anything after KL05 flash

vbimport

#1

My drive was having a little trouble writing on a cheap brand of DVD+R DL’s (Dynex). Sometimes it would write, sometimes it wouldn’t. I upgraded the firmware to KL05 (originally KL02) and now the drive doesn’t read anything at all, blank discs or not. Can someone post the KL02 firmware or help me out at all?


#2

Cheap media, writes 50% of the time. In other words you half of them write half of them wont. Huh doesnt Dynex also make test tubes. LOL :bigsmile:


#3

ok, well now i know not to use cheap media but that doesn’t help my problem. i found a KL02 firmware in the forums and flashed it with that, still doesn’t read anything at all. it’s functional, it opens and closes. it tries to read (green led) but it doesn’t recognize anything. i’m not sure if the KL02 i downloaded was the stock version or not, probably not. can someone post that for me to try? i just got the drive so i doubt it’s failing in anyway, at least i hope not.


#4

if the drive doesn’t like the media, and I mean really doesn’t like the media, there’s nothing you can do except get a new drive.


#5

it’s not just this brand, like i said in the original post, it doesn’t read ANYTHING. retail discs included. it has to be the firmware? after i flashed it with the KL05, that’s when it started acting up. then i found some KL02 on these forums, flash it with that, still didn’t work. if someone could send me/post the stock KL02 firmware, i’d really appreciate it. if it doesn’t work after that, then i’ll just get a new one, it was only like $35 but still, it’s brand new so i don’t wanna ditch it right away.


#6

actually now that i think of it, it might not be the firmware. i was backing up one of my games and got a error when trying to burn, i guess because of the cheap media. after that, that’s when i tried the new firmware. but maybe the error writing screwed the drive up somehow? the burner i had before this one, BenQ 1620 died after writing errors the same way i think.


#7

Hello I Shot love,
I was about to say that.
You previous drive died after bruning to that Media, this one does the same.
Can burn to a real bad dvd cause a drive to break.

rgds,soso


#8

“Can burn to a real bad dvd cause a drive to break.”

what do u mean by that? that it probably messed up the drive?


#9

@i shot love
don’t feel to bad I just received my 20A1P on Thursday and it was DOA out of the box wouldn’t even open the tray
and just sat there making a buzzing sound with the green light lit up. I really and truly believe that there is a bad
batch of them out on the market at the moment really bad quality control on Liteons part. :a I would suggest that
you get a RMA and send your drive back and get a replacment one and see how it does.


#10

yeah i’m about to do that. i just wanted to see if maybe there was something that could be done.


#11

I totally agree :iagree: I have problems with both 18A1P and 20A1P. [B]For me it’s like the days the Plextor 716A came out [/B] :eek:


#12

have any of u guys tried calling LiteOn about it? did they help at all or just give a replacement?


#13

If you do that ‘IShot’,
before you get that next burner, plse get rid of those DYnex :sad: ,

rgds,soso


#14

No i flashed my 18A1P with test firmware so i don’t RMA a drive that i’ve used test f/w on. The 20A1P has been acting weird so it will go back but i have not called them. I posted my problem Here


#15

Nope I didn’t call Liteon I just got an RMA from newegg.com where I bought the drive at it is easier to just go
through them since it was brand new than have to try and deal with Liteon support and any headaches that
might arise going with them. :doh:


#16

I had a similar problem with my 20A1P after flashing. Did your LED flash constantly the way mine did? I didn’t know whether it was due to the firmware flash or the use of the LtnRPC program. Tried all kinds of solutions. Downloaded the EEPROM utility, which had a repair funtion. Tried this, and it didn’t appear to work, even after a reset. However, when the PC had been turned off for some hours, the next time I turned it on, the DVD worked perfectly. :o