200 gb hd max capacity not recognized

vbimport

#1

Hello. I just purchased a 200 gb Maxtor Diamond Max 9 hard drive and just partitioned and formatted it using Windows XP Professional. The problem I’m having is that the maximum partition size I could make on it was 130 gb roughly, although it shows up in the bios as 203 gb (the proper capacity). I did some searching and found that the cause of this is that the OS doesn’t support 48-bit LBA addressing without any Service Packs installed although my board does. I downloaded the Maxtor big drive enabler and installed it after downloading and installing Service Pack 2. Now I am unsure what to do in order to make the drive reach its full capacity. I guess I’d have to delete the old 130 gb partition and create a new one. But if I delete the old partition that would also delete the big drive enabler patch and I’d be back to where I started. My version of Windows XP Pro doesn’t have any service packs on it either. I have to download them.

Can anyone please help me out with this? Would appreciate it.


#2

Read up on FDisk. Or if you have access to lots of software ahem try PartitionMagic. You run risks with both, but my main thing is running RAID0 I’ve hosed my array.


#3

I think I’d rather let the OS do the partitioning. Not too familiar with Partition Magic. I might just have to get a version of Win XP with, at least, SP1 already on it. I think SP1 supports 48-bit LBA addressing. If I FDisked with that I should get the max capacity.

Thanks anyway.


#4

My version of XP Pro with SP 2 has no trouble with over 135Gig partitions. I would suspect that you will not need any additional patches or partitions. I would take the current SP2 patch and burn to a CD and then start over with you WIn install disc.

I am surprised about the information that XP with no SPs installed will not support large partitions. I would have said the problem was solved in Win 2000 and that BIOS limitations were the issue.


#5

Sorry to say I have to disagree with you on this one.
I found a reg hack they may help:
Enable 48-bit LBA Support for Large Hard Drives (Windows 2000/XP)
By default Windows 2000 SP2, Windows XP and earlier versions of Windows do not support 48-bit Logical Block Addressing (LBA) for drives larger than 137GB as defined in the ATA/ATAPI 6.0 specification.

Good luck.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.


#6

The “Big Drive Enabler” from Maxtor does the same thing as that tweak actually. The main problem is that I have to have a “48-bit aware OS” while I’m creating the partition. Right now I have this old and only version of Windows XP I own installed which I updated to Service Pack 2 through Windows Update. I have enabled 48-bit lba. I installed the Maxtor “Big Drive Enabler” patch. Now I guess I have to delete this partition and create a new one for the OS to recognize the full capacity of the drive. This is the problem. If I delete the partition I guess I’d be back to where I started without the 48-bit awareness. So any registry tweak or patch wouldn’t help I guess.

I guess my main question would be what do I do next, after enabling 48-bit lba, to gain the extra 70 gb or so I’m missing?

Thanks.


#7

You could make a new XP disc with SP2 included and then format and start again. :eek:
Maybe someone has an easier way? Otherwise check this out:
Slipstreaming Windows XP with Service Pack 2 (SP2)
Good luck. :slight_smile:


#8

Runnning WXP Pro SP1 with a 160 GB Seagate hard drive. Currently have one primary active partition and three extended logicals.


#9

And your point is??? :confused:


#10

Hey, we don’t disagree, you just knew something I was not sure of. Thanks for the correction. My memory is clearly foggy.


#11

Break up the HD to several smaller partitions. You can use FAT32 or NTFS for smaller cluster size.


#12

I finally got a Windows XP cd with SP1 on it and that worked. It let me create a partition to full capacity. Thanks for all your replies. :slight_smile: