165H6S - some tools are not detecting the drive

vbimport

#1

Hello folks. I just purchased a a 165H6S and am having a couple issues with tools not deceting the drive.

Here is my setup
Secondary IDE channel
Master: 165H6S (HD0E stock), Ultra DMA Mode 4
Slave: Lite-On DVD-ROM 167T (9S1B, codeguys speed firmware), Ultra DMA Mode 2
IDE drivers: Stock Microsoft driver, (tried Lastest VIA 0571 5.1.3790.140 as well)
ASPI Layer: 4.60 (have tried 4.71)
Windows XP SP2
Before anyone suggests it, yes I’m using a 80 wire IDE cable and have confirmed the jumper settings on the back of my drives. :slight_smile: I just swapped out my old 832S with the new 165H6S.

Non-working tools (doesn’t detect my 165H6S)
Standard .exe firmware flashers from Lite-On and codeguys (HS0E.EXE, 165H6S.HS0E.stock.exe and 165P6S.HV9N503.patched-16xOS.exe for example), error "No matched drive detected ! This utility is only for LITE-ON DVDRW SHM-165H6S drive.
KProbe2
LtnFW
LtnRPC
Ltnflash 1.24

Working Tools
Flash Utility
EEPROM_Utility
BookType Utility
Smart-Burn (newest official version)
Smart-Burn (unofficial test version)
Nero CD-DVD Speed
Nero InfoTool
Nero Burning ROM
RecordNow

The drive does show in the device manager and I can read DVD’s (and scan with CD Speed) with it. I haven’t bothered trying any burns yet as I want to have it working properly first.

I’ve tried changing the ASPI layer from version 4.71 to 4.6 and that didn’t help. I have also tried the standard MS IDE drivers and the latest VIA ones.

Now I’ve read somewhere I could try removing the slave drive and that might help. To me this isn’t a very attractive solution so I haven’t tried it yet. My old 832S worked fine in the same setup. On my primary IDE chain I have two HDD (I don’t use SATA) and I don’t want to mix HDD and ODD on the same chain. I’d also run into problems with my IDE cables if I tried that anyway (they don’t reach that far).

Any suggestions would be appreciated. It’s been awhile since I’ve been heavily involved in the ODD scene so I could be missing something obvious. :wink: Thanks in advance!

Edit: For some reason the HS0E.bin stock file from codeguys website isn’t recognized by Omnipatcher. I dumped the stock HS0E on my drive to a .bin file as well and no luck with Omnipatcher on that one either.

I was thinking maybe the stock firmware that shipped with my drive might be messed up, so I just tried updating to the HS0E stock firmware from codeguys website using the Flash Utility (since none of the .exe files are working). That didn’t help things either. :frowning:


#2

Ssseth, remove ASPI using KillASPI and put this ASPI driver in your System32 folder:
WNASPI32

The reason for this is that you can’t have the NVidia IDE driver and ASPI v4.xx driver installed at the same time for those tools to work. :wink:

The other option is to remove the NVidia IDE driver and use the Microsoft one.

OmniPatcher does not work with 5S and 6S firmware. It’s not really needed with OHT and the OverSpeed patch. :wink:

Edit: Oops that link is now broken. I’ll create a new one. Stay tuned.


#3

I was just reading that thread where you posted the link and noticed it was dead too :wink:

I’ve actually just finished killing my aspi layer while ago and that did not help either so I went back to the 4.60 version. As mentioned above I have a VIA chipset, so I don’t have nVidia drivers (except for my video card, but I wouldn’t think that would matter).

Currently I’m running the stock Mircosoft IDE drivers and ASPI version 4.60. So I’ve tried stock MS IDE drives and no ASPI layer, no luck thier either. I’m going to try the VIA IDE drivers and no ASPI layer right now and see if that combo works as it’s the last one I haven’t tried. (I’ve tried ASPI 4.60 and VIA with no luck).

Edit: No luck there either, VIA IDE drivers and no ASPI layer didn’t work. I also tried an older version of VIA IDE drivers and no ASPI layer without success.


#4

Are you using an 80 wire… just kidding. :bigsmile: Sorry I should have read your post more carefully. :wink:

Hmm, this problem is certainly the same as when using NVidia drivers.

My old 832S worked fine in the same setup

So did the tools that aren’t working now, work ok with the 832S? If yes then the only thing that has changed is the UDMA [B]4[/B]…

Link updated.


#5

Yes they did work. Although I hadn’t used any of them in a very long time.

I just put that file in my Windows\system32 folder, going to try rebooting now.

Edit: Okay, that didn’t help either. Running default Windows IDE drivers and that on ASPI file you linked.

One other thing, I made one mistake in my original post (can’t go back and edit anymore now that I’m not a mod, hehe). The official Smart-Burn detects my drive. The test Smart-Burn does not detect my drive.



#6

Since it’s been so long since I’ve used some of the tools that aren’t working. I’m going to put back in the 832S and see if they still work with them as well. I’ve reloaded my OS in the last 3 or 4 months and don’t think I’ve tried any of them since then. One thing I was just thinking of. My default drive is F:\ instead of C:. Do you think that would have anything to do with it?

I’ll be back shortly to say if the 832S worked with the tools or not.

Edit: Okay, so apparently isn’t not just the new drive. The 832S is having the same problems with the tools listed above not detecting it. I tried unplugging the DVD-ROM so it was the only device on the chain as well (with both the new drive and the 832S) and that didn’t help either.

I’ve come to the conclusion that it shouldn’t have anything to do with my main volumes being F: because the tools do detect the DVD-ROM drive. Just not the DVD burner! Hmmmm, I’m running out of ideas here! :frowning:


#7

Okay, I have some progress to report! :slight_smile:

Since the DVD-ROM was being detected, I had a hunch and tried the 165H6S as a slave with the DVD-ROM set to master. Everything now seems to be working except KProbe.

When I had the DVD-ROM as slave it would detect it. However now when I launch KProbe it doesn’t detect either, I just get an error it can’t find any drives. :frowning:
I suppose I could use CD-DVD Speed… just used to KProbe is all. Is CD-DVD Speed as reliable as KProbe?

I’m also aware it’s recommended to have the burner as the primary device. However I’ve never actually heard of the technical reasons why and if having it set to slave will actually hinder performance.

I guess this could work, but I’d really like to figure it out. I just hate not knowing the answer to things! hehehe. :stuck_out_tongue:


#8

how about trying a new cable? flat 24" 80wire? I see Via and I die a little inside. :frowning:


#9

I was thinking that as well. I suppose I could pick one up on my way home from work today. Why do you say a flat one? I’ve used the smaller round ones in the past without incident.


#10

Hi,

for troubleshooting, please remove Aspi again. Running killaspi is not enough as there are remainders in the registry. On NT5.x, Aspi is not needed, but it can cause some trouble. In rare cases, ancient :wink: applications that rely on Aspi, just copy Nero’s wnaspi.dll into the program’s directory.
As your Windows drive has the letter F:, make sure, your optical drives all have higher letters. You can change this using diskmgmt.msc

If Kprobe is not working, set it to “SPTI” under “driver”.

Also, you should use an 18" flat ribbon cable, not a longer one, as these are beyond the specs.

Michael


#11

I am using 18". I’ve used round ones for years though as they allow better airflow in my case so I do prefer them over the flat ones. Does anyone know if we have any technical evidence that the round cables don’t work as well as the flat? I’ve built quite a few different systems with them now and have never had a problem before. Granted I’m not saying it isn’t possible, just from my personal experience they work fine.

Regarding the removal of ASPI all together; how would I go about that? I’ve used ForceASPI’s “killaspi” feature, however I haven’t seen info on how to remove it from the registry.



#12

yeah round cables ruin the ground wire separating each data wire on flat cables. Antec Cobras help a little bit by insulating the whole thing, and has a ground wire, but doesn’t help wire->wire interference. RDXP does, but it’s hella expensive. If I was going with round I’d either use RDXP, Antec Cobra, or short 10" single device cables. Basically most round cables change the impedance, and some ide ports and/or devices have some issues driving them. On my GA-7NNXP the ITE ports fail if I use round cables.


#13

Well it’s not a cable problem. Tried a new round and flat cable. Same problem, the 165H6S (or 832S) still does not detect with the tools above when it’s set to master. When it’s set to slave it does detect in all tools except KProbe.


#14

maybe you already tried this. what happens if each drive is alone on the channel? so your 832s doesn’t work now when it worked before? I’m slightly confused.


#15

The tools don’t work with either the 165H6S or 832S set as the primary drive with or without the DVD-ROM attached. This is really starting get annoying as I was planning on eventually having two DVD Burners and not having one of them detected by these tools is not a nice option (including standard .exe flashers afterall). :frowning:


#16

what about setting the bios to defaults/updating bios?

another option to see if it’s a software problem is to create a BartPE bootdisc and put the .exe flasher on a flash drive and see if it can detect. Kprobe probably won’t work as well, but never tried kprobe from bartpe myself.


#17

I really think it’s software since the drive does show up in Windows and works with most applications. Even if I try from a flash drive, it will still be using the O/S to run the files, so I don’t see how that would help. I’ll give it a shot though if you can point me to what a BartPE bootdisc is. :slight_smile:


#18

http://www.nu2.nu/pebuilder/

basically you’re loading up a Windows environment with nothing but the core OS files. that will eliminate ALL ASPI related issues, should that be the problem.


#19

Have you completely uninstalled KProbe then restart and re-install it?


#20

Okay, I’ll give that a try when I get some time seeker. Thanks for the suggestion.

Yes, thanks for the idea though. :slight_smile: It’s not just KProbe, any devices set to master chain aren’t detected by some other types of software as well.