1655 only works in PIO mode?

I can’t complete a scan at all when in DMA mode. I switched it to PIO just for the heck of it and it scans fine and even gives me a jitter reading. And now just checking the Booktype settings, I can only change those in PIO mode. I’ve always read that PIO mode isn’t what you want, so what’s going on? I’m going to do a burn in PIO mode to see what happens.

PIO mode will only let you burn/read at extremely SLOW speeds

Do you have some nvidia or intel IDE drivers installed?

I just found that out.

They’re the generic Windows drivers.

Check for jumpers and cables: primary drive must be connected on the esternal plug, and slave on the intermediate.

I’ve had the drive in every configuration I could and it acted the same way in DMA mode.

To exclude a damaged drive, can you try to use your drive on another computer? If it give the same problems, can be a damaged drive

This is a replacement drive. I asked here and contacted BenQ and they had no idea what was going on… literally. I could never get a jitter reading in DMA mode. On my old drive, I burned and scanned three discs… 97, 97, 99… but no jitter reading. Jitter only works in PIO mode for some reason.

Do you have other drives connected on the same IDE channel?

I suggest you read the threads about Nvidia/Nforce problems.

Zombie_Geek already said that have generic microsoft IDE drivers

I’ve tried the drive by itself already.

I uninstalled those drivers a while back before I ever got a DVD burner. I can switch between DMA and PIO with no problems. Everything seems to work fine except for the absense of a jitter reading in DMA mode.

Are you sure that these drivers were removed completely? Try to uninstall them another time and let windows reinstall standard ones

Did you use a 80-conduct cable?

I did that already, too. I just burned a disc in DMA and scanned in PIO. I got a 97. I’ll post the results in a few.

I’ve tried two different cables. One new and the one that I’ve been using in my system and had the same results.

Here’s my scans. I did the first test in PIO mode since that’s the only mode I can get a jitter reading in. The read test wouldn’t go any faster than 1x, so I had to do that in DMA mode.




The scan is good, but I don’t understand why your drive works only in PIO mode…

I wish someone knew. As of right now, I can burn, scan (no jitter reading) and read in DMA mode. I need PIO mode to scan and change the Booktype settings. Weird.

maybe a dumb question, but do you use latest version of cd-dvd speed?