1640 Won't load disks and sticky tray

vbimport

#1

Hello,

For the last couple months or so my drive has had both trouble with a sticky tray that sometimes will not open when I hit the eject button, but more importantly, has trouble loading disks.

I think the two are unrelated. I tried cleaning the foam ring around the tray with 100% Ethanol and it seems to have helped. However, it is the disks not loading that concerns me. The problem has been getting worse as time passes. Disks will no longer load by simply pressing the eject button. In order to load disks, I need to push the tray in with my hand with quite a bit of force. Once the disks have loaded the drive performs flawlessly.

It seems to me that the problem is the drive not catching the disk or something because usually the drive tray will close fine if no disk is inserted.

I am willing to open the drive to fix it if anyone knows what the specific problem is.

Thank you in advance.


#2

Its a known tray problem with the 1640. if u use windows, just use the Explorer - Right click Eject


#3

This must be a commom problem, mine has been picky since the day I bought it, at first I was making a coaster every other burn, then we had a good stretch and now I’ve coastered the last 10 dvd+r plus a few dl, so the Benq is going in a box and I’ll grab an LG. I contacted their tech support once and they were no real help. I found that if I didn’t use the eject button to close the tray, the disc failed to load, now it is hit or miss either way to load a disc!


#4

Smart decision…I am contemplating the same.


#5

I had this problem as well with my 1640. I read elsewhere of someone replacing the stretched drive belt with an elastic band. I followed his advice and mine worked better, but not perfect. I went down to my local electronics store and purchase a black rubber belt of slightly smaller length meant for tape drives for all of 40 cents. I lubed all of the moving parts carefully with a teflon based liquid lubricant. Perfect, good as new.