1640 firmware upgrade failure

vbimport

#1

Hello,

I’ve bought a benq 1640 yesterday, and tried to upgrade the firmware.
But I didn’t know the difference between GSHB and BSHB version and
tried the GSHB downloaded from some website in korea.
After that, burning programs have not reconized the device , so I tried to back to the retail firmware but faild.
I attached the error image.

And I tried the BSGB cvt file with Windwflash but failed.
Currently I attatched the device to my notebook thru 1394 card because I am in my office.

Dos program, benqcvt.exe seems not to recognize the 1394 connected device , so I cannot try the dos program.

any help please…


#2

I have had many drives fail to flash on firewire. If it were my drive, I would redo the cvt route but get the drive to an IDE cable in a regular PC. As a fallback you might try USB.


#3

thankyou for fast response.
I have tried the BSHB in my home , where the device connected to IDE, but failed.
Windwflash can not do for firewire ?


#4

I’ve never tried, but you did get your drive converted to the Generic version. Where did you get your cvt file? I searched but I cannot find any. Your drive is acting like the cvt file is not a cvt but a regular update and it will not convert the generic to the retail.

Keep at it. You might need someone to link you to another firmware to get you to a retail firmware flash.


#5

byungsoo, try the BSHB RPC1 Windows flasher version on TDB’s site:
http://tdb.rpc1.org


#6

Also here’s a cvt for BSHB.


#7

BSHB window flasher report the same message : ’ invalid firmware version’,
and cvt for BSHB too.
I tried thru firewire connected device. I will try again home after connect to IDE.

Anyway cvt window flasher reported the following error.

======== FAIL 1235========

Any idea ?


#8

IDE while flashing is the way to go, as suggested by chas0039.


#9

Are these BenQ firmwares available to posters? This link is to a forbidden area and the available firmwares at codeguys are only Liteon, etc.


#10

Thanks, for that! :clap:
I’ve searched yesterday, but without success!


#11

The link is to codeworks, which is my cdfreaks site ;). The link should work for everyone (seems to have worked for rapid fire). The cdfreaks server is being upgraded at the moment, so some odd things might happen. Make sure you try again…


#12

Yes, like you said, it worked for me!


#13

Sorry I wasn’t clear. The link works but I was wondering if we could have access to the site storage for non-Liteon firmware.


#14

IIRC WinDWFlash doesn’t support firewire interface. :sad:
But I have successfully updated my BenQ 1620 when connected to USB2 though. :slight_smile:

Hmm, TDB’s doze flasher only works on drives connected to IDE bus…

Regarding differences in firmwares GSHB and BSHB we don’t know that much for now. Probably they are the same alhough GSHB is labeled as “bulk” :confused: firmware.

@ rapid fire, don’t know what you have been up to but you could have used the 2 months old TDB cvt BSGB firmware and then just reflashed with latest 1640 .exe. :stuck_out_tongue:


#15

Thankyou everybody !
I have resolved my problem. As you mentioned, Windwflash worked only in IDE connection.
Thanks a lot K0deking. Your BSBH.cvt file worked very well.
I recovered my new 1640.
Thanks again, everyone.