1640 can't revert after flash with external (164B) firmware

vbimport

#1

Huston, we have a problem.

Flashed my new 1640 retail drive with BEFB (164B external) firmware and can’t flash back to “original” 1640 anymore. The flash takes in DOS and/or with WinDWFlash but the drivename still says -164B-.

Any ideas? :confused:


#2

Update.

Flashed with all released 1640 (.cvt) firmwares to no avail, uninstalled QSuite2, cleaned the registry, but still nogo…

W*f. I had nothing to lose, so I decided to flash back with latest Philips 1648 (.cvt) firmware and WinDWFlash.
And you know what? The drivename changed…, to Philips 1648 ofcourse, but that’s not a big deal because I knew the flash back to BenQ 1640 from Philips was working… heh he.

Finally managed to flash 1640 firmware and now the ID string shows DW1640 again. :smiley:

Sorry for interrupting your reading.


#3

I had no problem with going back to BSLB. From your screenshots you see that the firmware version did change, so the drive was flashed. Maybe windows did not refresh the drive name because the first 15 charactes of the drive name were identical. Did you reboot after flashing ?


#4

Yes, tried with “cold” and “warm” reboots, still the same. :slight_smile:

I had my drive in external enclosure for a while, doing some tests. Could that have something to do with it? This comes to my mind because windoze XP asked for reboots several times when I connected enclosure to my USB2 port.