1633s slow read with dvd decrypter since attempted firmware upgrade to CSOM

vbimport

#1

I started a thread in the firmware forum because I tried to flash my 1633 BSOS firmware to CSOM. When I got that fixed and back to the BSOS now when I try to use dvd decrypter to copy a backed up dvd the read speed goes up to 4x at first and then drops to 2x or lower for the rest of the read process. My computer is using UDMA 2 for all 4 channels (primary and secondary master and slave) is there any way to change them to UDMA 4 or would that even help. Before all of this happened it took about 15 min to read a prevously backed up dvd ad about 10 min to burn and now it takes about 30 min to read and still about 10 min to burn.
Does any one have any suggestions for a possible fix of this problem? :confused:


#2

If the 3S drive is on an 80 wire cable it should show up as UDMA 4. If it doesn’t use Device Manager and delete the IDE channel driver that the drive is on and then reboot.

BTW, you can use CS0M with your drive, as long as you use the crossflash “-cf” enabled version on my site. :wink:


#3

@C0deKing. I think that his trouble stated when he flashed to CSOM, but I don’t know if he used your crossflash FW. :slight_smile: Here is the thread.http://club.cdfreaks.com/showthread.php?t=135647


#4

when I flashed the drive to CSOM I didnt cross flash it and that is where my trouble started, I finally figured out how to flash it back and that is when the slow read problem started. I was a little hesitant to try to flash to the CSOM again because I wanted to try to fix the slow read problem first. Could flashing to CSOM possibly take care of my problem if deleting the IDE channel driver dosn’t work?


#5

I deleted the IDE channel that the 1633 was on and restarted my computer and when I checked the DMA it was still UDMA 2 and it was set to PIO for my liteon 483 which is set on the slave drive. When I started the decrypter afterwards the read rate went up to 4 while the buffer was going up and then when the buffer got to 99% the read rate started to go back down and it stayed at 1.4x from then on. Could I have some settings in the decrypter that need to be adjusted?


#6

I flashed with CSOM and the drive still acts the same as it did with the BSOS. Slow read rate is still present.


#7

Can anybody help me with any suggestions?


#8

Make sure your 1633S is the only drive on the secondary IDE as master. Delete the IDE channel driver and reboot. If this does not give you a drive running with UDMA 4 replace the IDE cable with another 80 wire cable. If it still doesn’t work, try the drive as primary slave and see if it becomes UDMA 4.

BTW, what are your system specs (cpu, mother board etc.)?


#9

@ hard-en

Is your dma in the bios at auto? Normally it should detect your 1633 as udma-4 (ata 66) and your 483 as udma-2 (ata 33), with a 80 wire cable. Recent hard disks normally are higher, udma-5 (ata 100) or udma-6 (ata 133). I read your other thread, and think it’s rather strange that the burning goes well. Dont think its firmware related, as I notice no difference in read performance between BS0S and CS0M.
If you use a 80 wire cable (you better do!), take care that the 1633 is jumpered as master and connected to the top end connector on the cable, the black one. The grey connector is for the slave device.

:slight_smile: Leo


#10

here is my system info, is there anything that I forgott to list?

I have a western digital 120 GB hard drive along with the 10 GB IBM, I flashed my 1633 with CSOM so it now shows up as a 1653 and I have a cd-rom from liteon 483 I believe.

OS Name Microsoft Windows XP Professional
Version 5.1.2600 Service Pack 2 Build 2600
OS Manufacturer Microsoft Corporation
System Manufacturer Dell Computer Corporation
System Model OptiPlex GX110
System Type X86-based PC
Processor x86 Family 6 Model 8 Stepping 6 GenuineIntel ~731 Mhz
BIOS Version/Date Dell Computer Corporation A08, 8/30/2001
SMBIOS Version 2.3
Windows Directory E:\WINDOWS
System Directory E:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Time Zone Pacific Daylight Time
Total Physical Memory 384.00 MB
Available Physical Memory 132.12 MB
Total Virtual Memory 2.00 GB
Available Virtual Memory 1.96 GB
Page File Space 921.04 MB
Page File E:\pagefile.sys


#11

@ hard-en

Run Nero Info-Tool, save the results with all boxes checked as a txt-file and post it using Go Advanced - Manage attachments.

Did you follow the instructions C0deKing suggested?
Are you using an 80-conductor cable?
Is (are) your hard-disk(s) udma-2 too? Did you check settings in bios?

:confused: Leo


#12

@ hard-en
Your problem was appear exactly after first firmware flashing? Are you sure? If yes: have you a back-up copy of the original firmware and may you compare it with existing into your drive after restoring? Another supposition: may be you have overwrite EEPROM (I don’t know how ;))?


#13

Both of my hard drives are udma-2 when I checked them in device manager, but how do I check them in the bios? I think that I may have a 40 wire IDE cable on my 1633 (now 1653 flashed CSOM). Any suggestions on where to get a 80 wire? Any way here is the results from Nero Info Tool, one thing that I saw was the bus speed sait 0 MHz, why is that?


#14

@ hard-en

I can see how drives are recognised by bios at boot-up, but I have still ME. Don’t know how and if it is visible with XP. In my case the harddisk is udma5, ata100, and the 1633 is udma4, ata66. And in the bios dma is enabled as “auto”. Normally a (1633 and higher) drive is recognised as udma4 if all parameters are right, the bios, the firmware, the cable and the drive-interface. But in my computer the 1633 was by mistake recognised as udma4 even with a 40 conductor wire. That causes Nero to quit burning with a “communicaion failure”, and changing the cable solved the problem. Every computer hardware store can supply those cables. Still puzzled though why your harddisks are still udma2?? There must be a 80-conductor cable between them and the motherboard??

:confused: Leo


#15

Bus speed is your external bus speed. it should be a wrong report.

Since your computer is 733 only. It is possible that it doesn’t support UDMA100/133.
But I recommend you to buy a 80pin IDE cable for check :slight_smile: .

I have a Fuing Acer P4 2.4G computer and the Fuing Seagate 60G harddisk running at :Z mode4 (ie half of UDMA33)!!! I think I will trying editing the firmware to see if it can be a UDMA100/133. Also, Never buy ACER’s stuff!

Here is an example of 80pin IDE cable. But the price is quite high.


#16

anyone have any other suggestions or possible fixes I can try, I am really starting to get pissed off with this piece of S#!T


#17

@ hard-en

It would really help if you report back what you did try and if it was succesful or not. There are many members asking you questions what you did not answer. The problem started with a wrong flash so it is not fair to blame the drive for something you maybe did to it yourself.
I think abalone may be right that your computer does not support ata 100 or higher. But then again, it could be ata 66 and that requires a 80 conductor wire as well. The question remains the same, what did you try by now and what not???

:o Leo


#18

Okay, first of all, to clear up a little myth:
Remember how higher numbers is supposed to be better (until it came to a panel monitor where the Required resolution resulted in tiny, very tiny print)??.

ATA 44/48 (UDMA3), ATA66 (UDMA4) through SATA 150 and beyond are limited to hard drive mechanical speeds. Physical hard drive speeds rarely exceed 48 megabytes per second sustained read or write speed. ATA, SATA do not read and write at the same time without going to half speed or less. A good DVD burner is unlikely to exceed ATA33 specs (A better DVD burner will use UDMA33 or UDMA66 on 80 wire cable to increase “burn-proof” performance).

The faster speed does do something. The tiny, nearly insignificant memory buffer on the hard drive can communicate with the mainboard at the rated speed. That is, until the buffer is empty. In the blink of an eye, its buffer is empty and usefullness is done.

The ata100, 133, 150 speeds are not beneficial for single drive use. They are for a RAID implementation whereby two identical drives are hooked up on an 80 wire cable with both drives set on Cable Select. By this, you can achieve double speeds. The secondary drive controller can then be equipped with an identical configuration for redundancy. Yes, ordinary IDE does have built-in raid capabilities in hardware. Otherwise, speeds beyond ATA 66 are useless and actually slow down sustained write speeds on many current hard drives.

An 80 wire ribbon is a requirement for all UDMA, but ordinary ata33 will run on a 40 wire ribbon, so there is some confusion between the Sony optical Ata33 (requires 40 wire) and the BenQ optical UDMA33 (requires 80 wire). This is only a problem with the “33” speeds.

Slaving drives should be done in decending order if the drives do not match and cannot be “set” with a utility.
An ATA48 and UP drive cannot share a cable with a drive that is not meant for an 80 wire cable. Change your hardware.
A UDMA33 drive cannot share a cable with a drive that is not meant for an 80 wire cable. Change your hardware.
An ATA-33 drive can share a 40 wire cable with any other ATA-33 and lower drive.

After reconfiguring drives, you need to clear your CMOS if your computer is based on the Via chipsets. However, if you have all drives/only drives that are ATA48 and UP, you do not have to worry about clearning the CMOS.

The VIA bug was never worked out. It is still a harsh reality for any ATA33 and lower drive that is plugged into a Via chipset. Reseting the CMOS and then leaving the IDE channels on Auto Detect is a partial cure. The VIA bug is incompatible with “Cable Select” feature, so use the master and slave jumpers where appropriate. Zero jumpers may also be necessary for “master” depending on brand of device. *For best results, avoid ata33 and lower drives when using VIA based motherboards (Use only UDMA33 and UP drives so you can avoid the Via Bug). *If your ATA 133 drive is paired [on same cable] with one that is not ATA133, reset it to the same communication protocol as the other drive on the same cable (using the maufacturer’s provided utilities) as this will result in much faster performance.

*If you have a seemingly permanent change after flashing a drive, it could be that the motherboard is “stuck” on the wrong communication protocol. This also happens when removing an old optical drive to install a new optical drive. In both cases, clear the CMOS and leave the IDE channels in use to Auto Detect (you may “set” hard drives if they sporadically show up the wrong sizes).


#19

@ Hard-en
aha! One pair of drives that you own cannot work on the same cable as the other pair!
Divide them by new section (on primary controller) and old section (on secondary controller).
Rules for applying Master-Slave relationships between the old and new styles are backwards (makers of UDMA thought that hard drives should be installed above cd drives. Daft but true!), but the rules for both old and new styles are defined in detail here:

Use an 80 wire cable to run your Western Digital and newer model Lite-on DVD together on the PRIMARY IDE controller.
Set the Western Digital as Master and the Lite-on as slave.
The Western digital drive will go on the END of the 80 wire cable. The Lite ON 1653 will go in the middle of the 80 wire cable.
Tiger Direct has a brilliant yellow teflon coated extra length flat 80 wire cable for a tiny price. You may also attempt the new round wire fad as there is every possible size and color (avoid EMI emitting disco-light-equipped data cords!).

Use a 40 Wire cable to run your IBM hard drive and old CD together on the SECONDARY IDE controller.
Set the IBM as Master and the old CD as slave.
The IBM will go in the MIDDLE of the 40 wire cable.
The old CD will go on the end of the 40 wire cable.

Reset the motherboard CMOS.
Be tapping the delete key like a madman on the first boot
On the bios screen, select “Optimized Defaults”
On the bios scren, select “Save and Exit”
*now, auto-timing, if present, will attempt to configure itself correctly
You may enter the bios screen on the second boot-up to configure the motherboard to match your needs, or just leave it on factory defaults.
Remove drive controllers from Windows Device manager and restart. It will auto config and restart.
You’ll be all set.

*Enjoy your Lite-on. I just switched from BenQ.
Quality is roughly equivilant, but Lite-on fits MicroATX and does not make heat.

*Sorry to hear about your difficulty in combining hardware from two different decades. If my tips do not work, you may consider splitting your complicated computer into two reasonable computers.