1620 not working properly HELP PLEASE! im at my wits end

vbimport

#1

ok so here is the scoop… i had an older pc that isnt in use anymore and took out the dvd dw1620 and put it into an hp d530 sff now i have formatted the hard drive and re installed everything from new so i now have a fresh os installation of windows xp when i put a cd into the drive it reads no problem when i put a blank cd into the drive it burns no problem, when i put a dvd into the drive it plays no problem but when i put a dvd to burn into the drive, under my computer the destination drive turns to cd drive. i have tried flashing it with every firmware possible i could find for this and only one of the flashings worked the g7 series i think its the first firmware that was released but no matter what i can not burn a dvd i have tried formatting for a second time and instead of installing an updates i tried the drive over again,and same thing… reads cd’s and dvd’s and burns a cd… but doesnt burn a dvd did i do sumthing wrong could the jumper cause this im at my wits end with this and i dont know what else to do if anyone can help me out with this i would really appreciate it .

Thanks

XX Vidalexio XX


#2

Windows showing it as a CD-RW when a DVD is in it is normal,that’s just windows. W7 does it too. What burning program are you using, what disc, what speed?

Welcome to The forum, George


#3

Hey Thanks for Welcoming me to the Forum =)

Yes Windows is showing it as a cd-drive when i put a blank dvd in… but it doesnt let me burn it fails every time and when you click on the properties of the drive it says disk is full and it just keeps spinning in the drive… ive used the nero 7.0…sumthing, and ive tried nero 9 and ive tried 2 different versions of roxio also and still nothing. Ive also tried dvd + and - and still no difference. ive tried sony discs, philips, no name, and memmorex… all these types of discs use to burn no problem . there must be something im overlooking here.


#4

Make sure the firmware is upgraded to version G7V9:


#5

ok so i checked what firmware was on and it is the G7V9 but i figured what the heck ill try it again… so i flashed it with g7v9 and no difference…

Thanks for the help so far though i really appreciate it.