1620 external burn at 16X, its was the firmware

vbimport

#1

I was only able to burn at 12x using the 1620 flashed with the B7P9 firmware and my external case (PPA usb 2.0 & firewire).
Was getting 21MB/S using the B7P9 firmware.
Flashed my external case (3507 Prolific chipset) still getting 21MB/S.
Flashed my 1620 with the 47L9 firmware, now get 24MB/S.
Burned my first DVD (verbatim dvd+r 16X) ad 16X, was only able to burn at 12X before the 47L9 firmware.


#2

ronline,
Great to hear this! I am sure other BenQ 1620 owners will really appreciate this information.
Thanks again for confirming for us.
dishinit


#3

ronline, what type of computer do you have (notebook or desktop)? Also, can you flash the drive using this firmwar like you would with B7P9?


#4

I’m using a desktop computer with a abit motherboard.
It’s not the motherboard, don’t waist your time, firewire has alwas been able to get over 21MB/s, just hook up an external firewire drive and you will see.
It’s the firmware.
I had to flash it using the USB connection will not flash with firewire, used winwdflash.


#5

Thanks! I just flashed my external oem version to 47L9 and got 21 mb/s over USB2 and 23 mb/s over FW. Is 23 mb/s fast enough for 16x? I don’t have any media fast enough to test myself.

BTW I am using the drive in the Prolific 3507 chipset enclosure which I got from dealsonic recently. I was unable to flash the enclosure firmware. It seems to have a different chip (not Pm39LV512 but En29LV512).

Also, for some reason I am unable to run the disc quality test (although I think I was able to do it with the original firmware). It tells me “drive does not support this function”.


#6

kworm,
Congratulations, 23MB/s over FW is fast enough for 16X burns.
BenQ firmware 47L9 should be compatible with QScan, mine is. Only error messages I have received are when I am scanning a poor quality disc.
How did you flash your BenQ and using what flasher? Perhaps you need to reflash, only over “USB”, using WinDWflash & the 47L9 .cvt file from Unofficial BenQ firmware page.
A new chip from Prolific? How did did you confirm this? What is your existing firmware version & date?
Did you use USB connection to attempt your flash of Prolific Firmware? (does not work properly on FW)
To hear the possibility of new chip is??? Could be improvement! Older A, B & C version chips have delayed write difficulties/problems when coupled with hard drive (principal reason for upgrading Prolific firmware).
Are you running XP SP2? Or?
Thanks for your response, & look forward to seeing some scans from you.


#7

I flashed over USB using WinDWflash and the cvt file from that Benq firmware page.

I looked at the chip by unscrewing 2 screws. On one side there was a prolific 3507 chip, on the other there was an Ion(?) chip and it said En29LV512. When I run the RomWriter 2.1.4 I get FW ver 2004.02.12.062 and the Vendor ID OX7F and the chip ID OX6F.

I run this enclosure via USB or FW out of my Inspiron 9100. I have Windows XP SP2. Do you think I should try to reflash it? It said the flash was successful when I did it the first time. I was able to scan the same disk with my previous firmware, but could not rescan it with 47L9. The problem is I flashed it to b7p9 first and I do not remember whether I scanned it with that firmware or the one that came with the drive. Is it a problem if I flash it back and forth, i.e can it damage the drive? Thanks a lot


#8

Well, just flashed my Prolific chipset case with the latest firmware I could find (July 2004, was 2003 originally) and I can now hit 16x on a burning speed graph when I do a test write, however because I have no good media to burn at that speed its a mute point. Burns with my cheap 8x media that runs at 16x takes 8 mins due to the drive checking itself so frequently but the graph is a smooth curve when you remove the dips & does not flatten out, about time I got some good +R media.

Firmware is B7S9.
Mobo is K8T800 in an Athlon 64 3000 Laptop
Using the latest VIA mobo drivers.


#9

Mine has FW ver 2004.05.21.117, Vendor ID: SST, Chip ID: VF010.


#10

kworm,
Thanks for the detailed response.
I have flashed my BenQ back & forth between G7xxB7P9 >B7S9>G7XX>B7P9>47L9 in that order & so forth. My BenQ burner(s) seem to function fine. Most of my flashing was done internally on an IDE channel, the last to 47L9 was on USB.
What app. are you using to scan your burned discs with?
CD Speed 3.42 works fine for me.
I did discover that DVDInfo Pro would not work with my external drive no matter what my BenQ firmware, if I was trying to scan over FW. I have a post in DVDInfo Pro Forum regarding this. As I can scan with Nero CD Speed (Nero Suite) or with CD Speed stand alone app. over FW, I quit worrying about it. I could/can run DVDInfo Pro as well as CD Speed scans, over USB.
When you were looking at your Prolific chip, did you notice if there was an A, B or C displayed in it’s ID string?
I remember reading about someone else having an OXxx type chip ID and also was unable to upgrade??? Perhaps I can find the thread and see if he found a solution. It may be that you have an A version which requries a hardware device(?) to flash the chip,
The reason I asked about your OS, was that my PC’s ability to recognize my external cases went south (intermittant system recognition over FW) when I upgraded to XP SP2…That was my reason for upgrading my Prolific firmware. Once upgraded, my external cases were recognized consistantly, again. This was only true when I was connected via FW (always recognized when using USB). If you are not having this problem & your BenQ is recognized by your system over FW, then I would say not to worry.
If your Prolific chiset is newer than the A, B, C versions, then perhaps the External case will not have delayed write problems with hard drives installed in them. If you do not intend to install a hard drive, then again, no worry.
Hopefully, I answered some of your concerns. Let me know.


#11

Dishnit,
okay the chip is 04133C. It seems to be working pretty good as it burns okay :slight_smile: Also, I don’t have problems with recognition – I can swap it back and forth from USB to FW(I also have a USB external harddrive on Oxford 911 which BTW was not able to recognize Benq at all). Also, interestingly I plugged it in via FW and it was able to do the scan with CD Speed. Hmm… I am getting around 92 with this firmware and my 8x rated Dynex (Ritek R03) media. Do you notice any difference in quality compared to B7P9 firmware? That is probably more important to me than the speed. I don’t have other media so I don’t know if my media is not very good or I should not be burning it at 12x. I guess I should burn something at 8x and see what the results are.


#12

kworm,
Currently I am burning at 16X (lots of Ty T02’s) & sometimes at 12X on my external, just because I can do it! Most of my scans are in the 92 to 97 range (lot’s of 95’s). Although on a bad (inconsistant quality in same spindle) disc I have gotten a low of 62, 78, 88 & 90. Those scores were usually at 12X and above, and burned on both my internal BenQ B7P9, or my external BenQ 47P9.
When I have slowed my burns down to match QScan, I have actually gotten a few 99’s on the same media. Even the 62 plays fine in my stand alones, so…? On the Ritek R03 media I have, I burn them at 4X and get 95’s.
The only real problem I have had, is with Teon discs where I have pushed their burn speed over what QScan would recommend. One disc had some digital artifacting that I attribute to poor media.
Glad to hear you can run a CD Speed Disc Quality scan on FW.
If there is a Best Buy around you, they have Fugi +R 8X, & Sony -R 8X on sale this week. Both (if good quality) will burn at 16X on your BenQ (make sure they say “made in Japan”. Look in CDfreaks Bargain Basement forum for more info.
Now, Lets see some scans…


#13

Sounds like there are a few options, either the BenQ EW162I with USB 2.0 only or the DW1620 with a profilic chipset enclosure for USB 2.0/Firewire. Which do you recommend I go with if I want 16X burns? I have both USB 2.0 and Firewire on my laptop. Is USB 2.0 fast enough to support 16X?


#14

usb 2.0 is not fast enough only firewire


#15

16X only with 47L9 firmware!
12X max with B7P9


#16

Wolffman,
Go with the profilic chipset enclosure for USB 2.0/Firewire